Can We Get Acknowledgement of the Pimax Specific RTX 4090 Latency / Lag Issue please?

I just upgraded to 4090 and there is some bizarre latency / lag that is absolutely nauseating and every 5-10 seconds the image will glitch, swap positions for a split second frame, don’t know how to describe it. I just tried clean updating the display driver, disabled HAGS, I don’t know what else to do short of reinstalling SteamVR.

Zero problems in 2D.

90 Hz, Windows 10, everything worked perfect with the 3090, upgrading the GPU was the only change that was made.

Clean installed 526.61 Hotfix, problem existed with previous driver as well.

The irony is that I upgraded from 3090 to 4090 primarily for VR as the 3090 handles 2D 5120x1440 just fine (dips to 70 FPS in the most demanding RT titles) so this just makes the purchase feel like a big waste of money.

See the comments in that thread, it seems everyone with a 4090 has this issue and nothing resolves the problem. Before Pimax address the issue via firmware there first needs to be acknowledgement of the problem. Right now Pimax is gas-lighting those who have submitted tickets with copy-and-paste “disable HAGS” “solutions”.

  1. No issues here.

also no problems

Did you own a different GPU before the 4090 or did you pair a 4090 with a Pimax HMD (in this instance I’m referring to the 8KX, so it could be a DSC resolution issue) and have no prior experience with the HMD? If I didn’t have a 3090 before the 4090 there is a slim possibility that I might not notice the latency / lag but to be honest it’s pretty bad, and the random glitching frame every 10 seconds / jutter is kind of hard not to notice.

What CPU? DDR4 or DDR5? Windows 10 or 11? What display driver?

Thanks.

For me, 4090 + 8kx, 10850k@5.0GHz, 32Gb@3800 c16, win10, driver 522.25

1 Like

Over the course of more than a year and a half, I have run my Pimax 8k X on an RTX 3080, 3090 TI, and 4090. I have also run it on a 10700k/z490/DDR4 and 12900k/z690/DDR5, ran the 3090 TI on both of those. Run on W10 and W11 with the 3090 TI too.

So no, I definitely know how it’s supposed to work and it’s not just I am not noticing it. It’s just not happening on my system.

2 Likes

No issue with a 4090 and 8KX for me.

1 Like

I have similar problem, ED v 4.0 work better with 3090 Elite Dangerous v 4.0 not working 4090! - #10 by jojon

1 Like

I have noticed a small latency since upgrading to the 4090. It’s most noticeable when turning my head sharply. I’ve tried various remedies such as clean install, repeating room setup, and upgrading Pitool, but it hasn’t eliminated it.

I tried taking the 4090 out and putting my 3080 Ti back in, and I found that this new latency was still happening. So I don’t think the issue is the 4090 itself, but rather the 522.25 nVidia driver that I had to upgrade to for 4090 support. Several issues have been reported with this driver, and based on my research online, it seems like this driver introduced significant internal changes.

I have installed newer nVidia drivers as they’ve come out, but the issue hasn’t gone away. I expect that some future nVidia driver update will fix it.

1 Like

I have 8K X & 5K XR. Used them both on 2080ti, 3090 and now when I upgraded to 4090 I have a movement lag too. Done everything you can think of, rolled back Nvidia drivers, Pitool & firmware versions etc, HAGS off (and tried on), uninstalled and clean installed everything. Tried all different settings in Pitool and Nvidia (eg smart smoothing, hidden area, parallel projections, low and ultra low latency modes, pre-rendered VR frames etc) and I cannot fix the lag.

I put my 3090 back in and both the 8K X & 5K XR are perfect as before. Put the 4090 in and the lag is back on both headsets.

Pimax suppprt asking me questions like if I am turning my head faster than before and no acknowledgement of the problem at all. And now they seem to be ignoring me.

When I got the hand tracking module they insisted it wasn’t working because of my PC. Then sometime later they released the Pitool version with the ‘fix for leap motion not detected’.

There is clearly an issue with Pitool or firmware and the 4090. I’m sure it will get fixed eventually but in the meantime it would be good if I wasn’t ignored or if at least there was an acknowledgement of the issue.

Right now I have a choice - have no VR, or put my 4090 back in its box (and I really need to sell my 3090 as the 4090 was far from cheap).

Pimax hardware is great and I always support them, and was planning on buying a 12K but the software and customer support don’t leave me feeling great right now, and I bought the 4090 specifically for the 8K X.

Come on Pimax, please acknowledge the issue and identify a fix quickly.

The lag is present in everything, even Pimax home and Experience. So it is not Steam VR, Open XR, or other applications. It is a core Pitool or firmware issue.

Okay so is everyone using msi afterburner?

I do not have MSI Afterburner installed

Many don’t use it but it’s installed and it’s service is running. Some I mentioned this to didn’t even know it was running until they double checked. So far everyone who removed (6 in a row) have reported issue resolved or dramatically diminished.

I imagine any windows service that monitors the GPU could also cause the same issue with the 4090 for some reason.

With respect, diminished is not resolved. On a 3090 there is zero lag.

1 Like

I and many others use a 4090 and have zero lag and the issue never occurred at all. This information should help most people who are experiencing this issue.

1 Like

I have checked and I have nothing installed or running. I did have iCue but I uninstalled that and no difference. Again this is not an issue when I put my 3090 back in.

I uninstalled MSI Afterburner and… problem gone.

Maybe people shouldn’t be so quick to blame Pimax for stuff like this.

5 Likes

I am asking for help from Pimax because I have tested and ensured there is nothing else running. I put my 3090 in and have no issue. With 4090 both 8K X and 5K XR have the same lag.

As it happens in Pi home, with nothing else running…and I have tried different Nvidia drivers, and I have nothing else running, checked services and processes - I don’t see what else it can be.

If people with different Virtual Reality brands also had the issue with the 4090 then I would suspect Nv drivers. In any case Pi need work work with Nv to figure this out.

Again when the hand tracking module wouldn’t work I was assured it was my PC, then the fix came out in Pitool.

What else do you suggest I do?