New Pimax 8k X with weird firmware version


Yes sir, I’ve submitted this request to our software team. They still reviewing it, as we concerned about if we upload all the firmwares on the page, it may cause users to flash the wrong FW and caused the headset stuck in DFU mode/ brick.
We’re discussing to find out the best solution to sort it out.

Simple enough to have dfu tool check current Hmd model against proposed FW and check FW compatibility and warn user if FW is not compatible


That concern already happens. The various firmware versions are already available to customers on these forums as well as sources outside of Pimax’s control, but they are available in a haphazard and unorganized way which encourages upload of the wrong firmware to the headset. These are links to random firmware versions with usually little more information than “I flashed this firmware, and it fixed my problems!!! Everyone should install this!!!” and that encourages other customers to try firmware which may not be correct for their particular hardware or the issues they’re trying to resolve.

In addition, these are often links to firmware hosted on unofficial sources like google drive which were uploaded by individual users. That opens the possibility of customers downloading firmware that has been tampered with which poses a security risk.

By implementing and maintaining an official source of firmware, Pimax will improve this situation by taking control and eliminating the need for customers to pass around firmware themselves in an uncontrolled fashion. An official web page could list which firmware is intended for which headsets and could also warn clearly that installing firmware selected yourself is at your own risk. If you are unsure, please open a ticket with Pimax support instead to ensure receiving the right firmware.

Also Pitool should absolutely not be automatically installing firmware on launch without asking the customer’s permission to proceed. That is unusual behavior, and it’s not something you see in other products from other companies, VR or otherwise. I understand the intent in trying to avoid customers having the wrong firmware, but Pimax will never be able to eliminate all cases where Pitool’s automatic decision about which firmware to install is wrong. And that’s true for all companies, not just Pimax. That’s why everyone else asks permission from the user before proceeding.

Pimax isn’t doing itself any favors with its implementation of unusual policies regarding firmware for its products. Pimax should be looking to long established best practices regarding firmware which are used by the tech industry as a whole. Pimax is very aggressive at innovating new solutions, and that’s usually great, but this is an area where the problems are already solved, and Pimax is only creating new and unusual problems by making up its own way.

1 Like

I don’t see why it’d be so hard to have something like having an input for the version of PiTool one has and also their headset’s model(And SN since we have the different 8k X versions right now), then have it spit out some FW from newest(And most recommended) to oldest based on what works with that version of pitool and the headset, then have the user pick one of those. Don’t need to have it list every FW ever since doubt they’d work with all versions of Pitool, but if somebody is on the latest version of PiTool, I don’t see the harm in it listing a couple. Just make it clearly labeled what’s the newest and recommended so people will try that first before attempting other versions if it doesn’t work.

What Pimax has right now clearly isn’t working that great because of all the complaints about things being bricked due to installing the wrong FW automatically and needing to get it from Pimax directly.

1 Like

The Firmware update even with correct FW sometimes often fails due to not verifying integrity of the download using ancient methods like crc checksum files.

1 Like

Not able to post this as a topic but I have a similar issue.

I’ve spent the last 7 hours looking through multiple forums, reddit posts, and troubleshooting docs on the official site and have got nowhere.

I have a new Pimax 8K X, first time plugging it in I was greeted with the “DP not connect” issue, did a quick google and found that it was an issue with old firmware. So I flashed to the 8KX firmware on the site (FOR 8KX : Pimax Support) which left me with a white LED and no USB connection, with Windows saying it’s an unrecognized device and couldn’t install the drivers.

After trying out many different firmwares linked to on forum posts and on reddit, I’m still in the same position. The only firmware which gets me back to the displayport not connected issue is P2_DEBUG_M270_t20210107171555_r99ad675 but then I do get Pitool telling me to update (which fails).

I’ve also tried replugging the cable going into the HMD, uninstalling my graphics drivers in safe mode as well as Pitool then reinstalling, reinstalling my USB controller drivers on the motherboard.

Pimax, why?

CPU: 12700K
GPU: 3090
Pitool version: (have also tried 272)

Firmware tried:

  • P2_RELEASE_8KX_M296
  • P2_RELEASE_8KX_M299_t20210922093742_r6066b70
  • P2_DEBUG_8KX_M299_t20210922093913_r6066b70
  • P2_DEBUG_8KX_M299_t20211101115020_r85cdd55_forEnableHDCP
  • P2_8KX_M298_EngineerTest
  • P2_DEBUG_M270_t20210107171555_r99ad675 (this gets me back to DP not connected issue but with Pitool telling me to update, which fails)

Anything else needed let me know but this issue is now really quite tedious.

Have you filed a support Ticket?

Also check #guidebank

Do you recall what FW it had when you received it?

To post new topic

I have filed a ticket and have been in contact.

Thanks for these resources, I’ll take another look incase I’ve missed something.

I don’t remember the FW it had initially I’m afraid, I wasn’t expecting to need to, just expected it to work :sweat_smile:

Excellent, thanks for the new post info.

1 Like

Thanks for working on fixing this. The major issue is still - PiTool is automatically updating firmware as soon as a new headset is plugged in. And there it either chooses an incompatible firmware or fails to load the transfer driver correctly. In any case, after that procedure the headset appears bricked and most customers will give up. It isn’t really bricked and can be revived, but for that one needs knowledge that usual customers don’t have - and most importantly a fitting firmware. Without that all the workaround steps won’t help. That’s where the firmware repository comes into play.

It would of course be much better if PiTool wouldn’t semi-brick the headsets and always reliably upload a fitting, stable firmware for the individual headset. All the other VR headset manufacturers get this done, Pimax is the only company that cannot get a reliable firmware upgrade working. And to make things worse they have enabled a forced firmware upgrade now. With this highly unstable (=for some hardware combinations predictably failing) upgrade process in place this is like playing russian roulette with a full magazine.
If the upgrade would work and only well tested firmware versions would be uploaded (that don’t drop half of the features that the older firmware had) the demand for a manually maintained firmware repository would be mostly nonexistant.

1 Like

P.S.: We have uploaded the firmware P2_DEBUG_8KX_M299_t20211101115020_r85cdd55_forEnableHDCP to the MRTV 8kX during the live session - which worked. At this point in time I didn’t know that MRTV supposably has the new 8kX hardware revision, so I gave them the firmware that works best for my (old) 8kX.
So either this firmware version works with the new and the old hardware revision (as it works with my 8kX and the one from MRTV) - or MRTV doesn’t have the new revision.(…)

1 Like

@playa haa a pretty comprehensive pimax repo. It might be an idea to have pitool inet acs blocked by your firewall until there devs implement sensible features with downloading firmware with integrity checks, built in Roil back, beta opt in/out and option to choose when to flash a firmware.

Yes, found that - great work! For me personally it is working now with said 299 firmware and I know what to do If it should reappear. For new customers it leads to an unnecessarily poor first impression though - so I’m a little puzzled why this has such a low priority for Pimax.

1 Like

Agreed hopefully they start listening and implement what was requested what 2 years ago?

I had an older Pimax 8k X and recently got one of the new 2001 firmware revisions. I wanted to get some feedback on what others who have tried both think about the differences. Here is what I have noticed about the new revision:

  • Doesn’t go as bright at 100% brightness setting but still seems decently bright
  • Headset connects and disconnects multiple times when I first turn it on and open pitools. Sometimes a reboot is required to fix it.
  • I sometimes get no audio or crackling audio
  • The colors seem better on the new version
  • I see jagged edges mostly on text with the new version. Maybe it’s because of a new sub pixel arrangement? I hope it’s not that and they can fix it with firmware because this is my biggest complaint with the new revision.

I’m sure some of these will be fixed with new firmware but the jagged edges worries me.

Can anyone else who has tried both the old and new version confirm/deny any of this? Maybe Pimax can comment on these issues as well. Thanks

1 Like

Thanks for the info. Does the new one support lower refresh such as 60 and 75 hz yet?

1 Like

I guess that Sebastian does not have the new version, because only the dmas version has the new hardware, the source of the information is pimax itself.

Think he got a DMAS with the 8kX and still had a KDMAS - so, who knows? :slight_smile:

1 Like

lower refresh is coming soon~

1 Like

AMD GPU support when?


1 Like

You should also ask amd that xD