X-Plane 12 with PIMAX

Has anyone been able to play X-Plane 12 with PIMAX?
Any advice would be appreciated.

1 Like

It is OpenXR compatible.
I tried OpenXRToolkit with the DEMO version of XP12

I tried to enable VR from XP12 options but I’v got Open composite error.

I am stuck there.

1 Like

A few months ago, Ben said that the beta will not be VR capable.
It comes a lot time later.
I have no idea if anything has changed.



X-Plane 12 does not use OpenXR. It can use SteamVR (OpenVR) directly, or you can use OpenComposite, but only on Oculus and Varjo.

So it looks like X-Plane 12 is doing some funky rendering. I have not tried myself, but I keep hearing that X-Plane 12 uses Vulkan. That alone, would work fine with OpenComposite+PimaxXR.

However, it looks like X-Plane 12 developer chose to use OpenGL for submitting frames, which means that OpenGL must be supported (even if they might use Vulkan for the rendering). PimaxXR does not support OpenGL, and I don’t really have plans to add support for it.

This would not be an issue is the game used Vulkan instead of OpenGL for frame submission. I can’t explain why the developer would choose to do the OpenGL submission, there must be a good reason, but I don’t know what it is, and I’m not going to spend hours on supporting obsolete OpenGL just for that :frowning:

PS: You can however use SteamVR, and I hear XP12 works fine with it.

1 Like

Thank you for the information.

I was able to enable VR immediately by reverting my settings in OpenComposite & PimaxXR back to SteamVR.

It is now showing on PIMAX. (with double vision…)
Unfortunately, enabling PP did not fix the double vision.
I will try to retry.

Double Vision solved the problem by setting PP and PitoolRenderQuality to 1.0.

Now I can fly with no problems, but the rendering performance is not good.
It would require tuning and update… :smiling_face_with_tear:

As announced, the final VR will be processed much later.
Apparently they have implemented the old version for the time being. Presumably in order not to shake the old user base.

Originally, the demo was not supposed to provide VR at all, which caused some confusion on the XP forums

Ok ok, I am going to reconsider this. I hear the performance difference with OpenComposite on other headsets is dramatic with this game, so I will look again at PimaxXR support.

It might even work today with PimaxXR and my updated OpenXR-Vk-D3D12, but I have not had time to try. EDIT: No it doesn’t work, require more changes to PimaxXR.

I will keep you updated.


Pimax 8kx and xplane 12 worked initially with pp but then suddenly stopped working and I was getting the double vision. I reinstalled xplane 12 and it still won’t work. I’ve tried turning off pp and that didn’t work. Pitool render has never been changed from 1.0. Xplane 11 still works fine with pp on. Not sure what happened. The only thing I tried to add was the fly with Lua plug in before it stopped working. But I removed it with the fresh reinstall and still getting double vision. Any ideas?

In my experience, the right screen drawing problem seems to occur when the drawing resolution exceeds the specified value.

I experienced multiple patterns, including not only double vision, but also improperly stretched images.

I would recommend starting with minimal graphic levels, LOW FOV, check steamvr scale,etc.

I have a working version that can run X-Plane 12. Still requires Parallel Projection though.

Not exactly sure when I will make a release, hopefully this week-end.


The new release 0.2.6 is out: Home · mbucchia/Pimax-OpenXR Wiki · GitHub

This adds support for X-Plane 12, with the following conditions:

  • You must use the latest version of OpenComposite;
  • You must disable OpenXR Toolkit (you can do this globally or per-app in the OpenXR Toolkit Companion app);
  • You must enable Parallel Projections in Pitool (this is due to a game bug in X-Plane).

There is a known issue that using Parallel Projections with Smart Smoothing is causing flickering around the edges of the screen. There is no workaround at this time, other than disabling Smart Smoothing.


I have problems gettings X-Plane 12 to run with OpenComposite and Pimax XR (V 0.2.8) with my 8KX.
The openvr_api.dll provided by opencomposite is placed under \Resources\dlls\64 in die X-Plane 12 directory, the Windows registry is set to \Program Files\PimaxXR\pimax-openxr.json under \HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1, and the PiClient (V

When I switch to VR in X-Plane I get the following error-message:


I would appreciaty any help.

System: Windows 11
CPU / GPU: 5600X / RX 6800 XT

Provide the PimaxXR log file from the PimaxXR Control Center app please.

This is the complete log out of the Pimax XR Control Center after launching X-Plane 12:

2022-10-02 16:18:44 +0200: PimaxXR - v0.2.8
2022-10-02 16:18:44 +0200: PVR: 1.23.1
2022-10-02 16:18:44 +0200: Application: OpenComposite_X-Plane; Engine:
2022-10-02 16:18:44 +0200: Requested extension: XR_KHR_D3D11_enable
2022-10-02 16:18:44 +0200: Requested extension: XR_KHR_D3D12_enable
2022-10-02 16:18:44 +0200: Requested extension: XR_KHR_vulkan_enable
2022-10-02 16:18:44 +0200: Requested extension: XR_KHR_opengl_enable
2022-10-02 16:18:44 +0200: Requested extension: XR_KHR_visibility_mask
2022-10-02 16:18:44 +0200: Device is: Pimax Vision 8K X
2022-10-02 16:18:44 +0200: Recommended resolution: 3794x3160
2022-10-02 16:18:44 +0200: Using Vulkan on adapter: AMD Radeon RX 6800 XT
2022-10-02 16:18:49 +0200: Using OpenGL on adapter: AMD Radeon RX 6800 XT
2022-10-02 16:18:49 +0200: xrCreateSession: OpenGL error: 0x505
Origin: lastError == GL_NO_ERROR
Source: D:\a\Pimax-OpenXR\Pimax-OpenXR\pimax-openxr\utils.h:237
2022-10-02 16:18:49 +0200: xrCreateSession failed with XR_ERROR_RUNTIME_FAILURE

Oh, AMD GPU… these are such a pain they have many driver bugs. I tried to fix some but it looks like a new one… unfortunately I have no solution for you right now. I will need to get my AMD GPU dusted off and give it a try with the latest driver.

PS: when I got my 8KX, I was pretty explicitly told AMD cards are not supported on Pimax.

Thanks for letting me know, when it is a driver related cause, at least I can stop trying around to find a solution.

I know AMD has a rather bad reputation for their drivers, though my impression is, that they improved a lot during the last months.
I didn’t even know that pimax didn’t officially support AMD cards, or they changed that meanwhile, hab my card first and got the headset later, I don’t remember hearing anything about compatibility issues, right know x-plane is the only game that causes such issues. But since X-Plane 12 still requires parallel projections enabled to run a Pimax HMD, it isn’t my first choice right now anyway, and the option to use it via steamvr is still possible.

Thank you very much for looking into it. I am really grateful for your work with Pimax XR, the possibility to bypass steamvr is something I have really been looking for.

1 Like

X-Plane 12 is the only game using OpenGL for frame submission (in spite of using Vulkan for rendering). I added OpenGL support to PimaxXR just for this game :slight_smile: and tested it on Nvidia only. I just need to find time to put my AMD card in the PC and debug. I already have a couple of special sauce specifically for AMD cards, but it looks like I missed that one. Will let you know if I get it working.

Working on this right now, and I found a bug in my code that could explain what you are seeing!

I cannot get my AMD card to work at all with the 8KX, but at least it was sufficient to find the bug. I will have something for you to try shortly!

1 Like

@benedikt76 here for you to try:


This should hopefully work with X-Plane 12 and AMD cards!