X-Plane 12 with PIMAX

Has anyone been able to play X-Plane 12 with PIMAX?
Any advice would be appreciated.

1 Like

It is OpenXR compatible.
I tried OpenXRToolkit with the DEMO version of XP12

I tried to enable VR from XP12 options but I’v got Open composite error.
image

I am stuck there.

1 Like

A few months ago, Ben said that the beta will not be VR capable.
It comes a lot time later.
I have no idea if anything has changed.

2 Likes

Hey,

X-Plane 12 does not use OpenXR. It can use SteamVR (OpenVR) directly, or you can use OpenComposite, but only on Oculus and Varjo.

So it looks like X-Plane 12 is doing some funky rendering. I have not tried myself, but I keep hearing that X-Plane 12 uses Vulkan. That alone, would work fine with OpenComposite+PimaxXR.

However, it looks like X-Plane 12 developer chose to use OpenGL for submitting frames, which means that OpenGL must be supported (even if they might use Vulkan for the rendering). PimaxXR does not support OpenGL, and I don’t really have plans to add support for it.

This would not be an issue is the game used Vulkan instead of OpenGL for frame submission. I can’t explain why the developer would choose to do the OpenGL submission, there must be a good reason, but I don’t know what it is, and I’m not going to spend hours on supporting obsolete OpenGL just for that :frowning:

PS: You can however use SteamVR, and I hear XP12 works fine with it.

1 Like

Thank you for the information.

I was able to enable VR immediately by reverting my settings in OpenComposite & PimaxXR back to SteamVR.

It is now showing on PIMAX. (with double vision…)
Unfortunately, enabling PP did not fix the double vision.
I will try to retry.

Double Vision solved the problem by setting PP and PitoolRenderQuality to 1.0.

Now I can fly with no problems, but the rendering performance is not good.
It would require tuning and update… :smiling_face_with_tear:

As announced, the final VR will be processed much later.
Apparently they have implemented the old version for the time being. Presumably in order not to shake the old user base.

Originally, the demo was not supposed to provide VR at all, which caused some confusion on the XP forums

Ok ok, I am going to reconsider this. I hear the performance difference with OpenComposite on other headsets is dramatic with this game, so I will look again at PimaxXR support.

It might even work today with PimaxXR and my updated OpenXR-Vk-D3D12, but I have not had time to try. EDIT: No it doesn’t work, require more changes to PimaxXR.

I will keep you updated.

2 Likes

Pimax 8kx and xplane 12 worked initially with pp but then suddenly stopped working and I was getting the double vision. I reinstalled xplane 12 and it still won’t work. I’ve tried turning off pp and that didn’t work. Pitool render has never been changed from 1.0. Xplane 11 still works fine with pp on. Not sure what happened. The only thing I tried to add was the fly with Lua plug in before it stopped working. But I removed it with the fresh reinstall and still getting double vision. Any ideas?

In my experience, the right screen drawing problem seems to occur when the drawing resolution exceeds the specified value.

I experienced multiple patterns, including not only double vision, but also improperly stretched images.

I would recommend starting with minimal graphic levels, LOW FOV, check steamvr scale,etc.

I have a working version that can run X-Plane 12. Still requires Parallel Projection though.

Not exactly sure when I will make a release, hopefully this week-end.

5 Likes

The new release 0.2.6 is out: Home · mbucchia/Pimax-OpenXR Wiki · GitHub

This adds support for X-Plane 12, with the following conditions:

  • You must use the latest version of OpenComposite;
  • You must disable OpenXR Toolkit (you can do this globally or per-app in the OpenXR Toolkit Companion app);
  • You must enable Parallel Projections in Pitool (this is due to a game bug in X-Plane).

There is a known issue that using Parallel Projections with Smart Smoothing is causing flickering around the edges of the screen. There is no workaround at this time, other than disabling Smart Smoothing.

2 Likes