What became of the 8KX 120hz Project?

So I first wanted to ask this because there appears no current information at all … was it abandoned and why ? I was sent a Firmware to test out at 120hz in September last year, I installed it and it appeared to work pretty well however I went back to using 75hz because in sim racing that feels optimal on my RTX3090 and I get the best frame rates.

But now after just beginning to use the 8KX again in past 2 weeks, after being away from it for about 5 months, I got some racing and pinball playing in for a week or so and then the 8KX DMAS suddenly stopped working. There is power to the headset via USB but no video signal from the Displayport … an error message says there is no DP connection, Error 20300.

Nothing wrong with the 3 x DP’s on the GPU and they all tested 100% with a 4k monitor. A few days prior to it stop working yesterday, there was a few strange things I noticed. It suddenly had scrambled image of white noise in the left screen panel, I rebooted and it was good again, but then for no reason and without me doing anything the HMD decided to change from 75hz back to 120hz. I changed it back to 75hz and it was okay again for a few hours but now there is no display at all because it says DP is not connected.

I tried rebooting and reinstalling several different earlier pitools from 275 upto 283 but no luck.

So there is no logical cause for this happening as the 8KX is connected in its usual way and there is nothing wrong with any other hardware in my PC. So should I try to overwrite the 120hz Firmware and downgrade to earlier firmware ? Could that be related to this problem ? I do not want to risk to brick the HMD if there is no good reason to downgrade.

Does anyone have any experience with this or useful suggestions ? My 8KX has about 3 months of warranty left and is already my 2nd due to the first being replaced within couple months due to a tracking problem inside the headset. I worry now that even if I get it working it will wait until warranty is expired and then die on me again. I never had such problems with any of my earlier headsets, 3 x Oculus and a Reverb G2. But the 8kX is by far the best of any VR Headset I have owned and I accept they are niche and bit quirky !


1 Like

My 9 month old 8kx stopped working for me the other day, the hmd led went permanently to dim red, 10500 error message in PiTool. I changed my cable to a fiber optic 1 that i had bought as a spare and it worked and has worked fine since. So the cable must have been the fault; it had gave no indication of failing prior to giving out.

1 Like

Thanks Tykey6 that is really interesting … also a bit worrying because my 8KX DMAS headset also is 9 months old. I am going to try going back to the 281 firmware because I read that is the last that was compatible with MrBucchia’s Pimax OpenXR software and in just the 2 days prior to the headset losing video signal I was using that software to try get better FPS in Automobilista2.

It did not work because tracking was all over the place with it running. So I went back to just SteamVR. But now I wonder did it F%@K up the display somehow because it was all glitchy and jerking about !

I think you meant 281 PiTool? Yes that’s correct, afaik it’s the last version that works ok with Matts software, it’s what I’m using. Tbh I don’t think software would stop your 8kx working alltogether.

I was running pitool 283 with the v2.1.255.2006 Firmware, which is the 120hz enabled version.

So I am going to try revert back to the earlier FW that was in either the 280 or 281 I think. And then just run pitool 281 if I get it working. That way I can try Pimax OpenXR with AMS2, hopefully !



You might want to try roll back to earlier version Pitool such as 280 / 281 with firmware version 2002.

If you don’t have the firmware file, please download from here.

Please let us know if this doesn’t resolve your issue.


Thanks I got a firmware and flashed using DFU.exe and it worked fine, then I installed Pitool 280 and it updated to the lastest firmware. I then Installed pitool 281 and now my 8KX DMAS is finally working again !

I am puzzled as to what was the cause of the DisplayPort connection error though … was it related somehow to the 120hz firmware or more likely that I was trying out Pimax OpenXR which is incompatible with pitool 283 which I had been on since last year ?

Anyway I had stopped using the 120hz mode and now I have only the options of 90, 75 & 60 hz. I find 75hz is optimal for my sim racing and playing virtual Pinball ( Zen and Zaccaria ).

I just hope my headset does not pop it’s clogs (die) after the warranty has expired ???!!!

@PimaxQuorra ~ Can you please tell us why the 120hz beta firmware was never fully released to the public ? I found it worked okay but I did wonder was 120hz putting too much strain on the panels ? I think at a lower refresh rate they may last longer … or is there other reasons ? It would be a good idea to share some reasons with us because it was promised for everyone last year but now … Crickets !

1 Like

the 20300 error might fix with a firmware reflash. The 120hz is essentially only an experimental mode. You can request access to the Firmware from pimax or @PimaxQuorra .

I would get a support ticket started in case you need it.


As Helio mentioned, the 120hz is essentially only an experimental mode. We are trying to figure how far we can push the frame rate limit.

The DisplayPort connection error shouldn’t related to the 120hz firmware tho.

I believed it will works perfectly even after the warranty. But did you try the Pimax Client before?

Yes my 8KX DMAS is now working as before. I had opened a support ticket and uninstalled the Pitool. Then I installed the Pimax Client 1.9 and the DP error 20300 went away so the video signal was restored.

This is what I do not understand though, how & why can the hardware suddenly stop working and say the DP is not connected when it was and there was nothing wrong with it, that makes no logical sense !?

I uninstalled the Pimax Client 1.9 as it looks to be a very bloated piece of software with a store/shop that I do not need. I cannot see any advantage over using the Pitool. So I went back to Pitool 281 and also reflashed the older Firmware without 120hz, which shows as 2002 now.

There is a newer Firmware 2003 for 8KX DMAS but I cannot find that anywhere. Support mentioned it and I requested it but no reply yet.

@PimaxQuorra ~ Could you or someone else please provide a link to download the 2003 FW so I may try it ? Thanks

Here you go the 2003FW.


I’ll ask the developers to identify the underlying issue and come up with a fix.

Thanks @PimaxQuorra but I am now bit confused ! I have the 2006 FW 120hz which I was using since September 2022.

But the 2003 FW you just linked, is that a newer version but with an older version number ?

I do not understand, what is difference between 2003 and 2006 ? I reverted back to 2002 from 2006 because I do not use the 120hz mode, however I think the picture is not as clear or sharp in 2002 FW compared to 2006.

That is why I will try 2003 FW to see is the picture better quality.

Sorry for so many questions but just trying to understand all this correctly.

Thanks :+1:


No worries.

This is the 2003 FW version you requested on the earlier thread.
It’s the latest firmware version that compatibles with 8KX.

Thanks and I have just now flashed the 2003 Firmware with DFU and installed the v284 pitool.

I think this 2003 FW feels like the image is better, more crisper and stable, could be just placebo but back to back compare with the 2002 FW I see a noticeable difference. Not sure about from the 2006 FW.

Anyway I will stick with this combination as I just tested racing Automobilista 2 at 75 Hz and everything in the 8KX looked very good and the video image was rock solid2.

1 Like

I don’t know if this will help anybody but I had a weird situation with my 8KX. I have the 2075 model and I played with it for months. With no problem then all of a sudden I started getting back screens with a buzzing sound in my left headphone. I was playing it for like half an hour to 45 minutes. I thought it may be overheating so I would turn it off and then come back 1 hour to 2 hours later or the next day, I don’t remember. It would play for maybe 15 minutes to a 1/2 an hour and shut off. Just go to black screen again and I got a weird noise in my left ear phone which was just a buzzing sound. So I left it off for about a week and started playing with my 5K super. And then I thought about it and I said let me try my little Y connector maybe It’s not getting enough power so I connected to it so I had the 3.0 and 2.0 on the usb port connected and it’s been working ever since.

1 Like

That is a little strange ! so you put both Pimax usb onto one Y connector and then into One USB Port ? was that a 3.0 port ? Because if that then stopped the 8KX from crapping out I would say the USB port on your PC is stuffed ?

I tried putting both Pimax USB plugs onto a powered 3.0 USB hub and it did not work as it would say my DisplayPort was not connected (it was) so that also was strange.

Not exactly this is on a fiber cable which only has 2 connectors but the Y connector had a 3.0 and a 2.0 itself so I used that on the 1 on the USB.

1 Like

Ah I see, well its good that it worked.

1 Like

Wow ! I put the updated 120hz FW 2003 onto my 8kx few days ago but just went straight to 75hz which has long been best for my use. However I was doing some testing of Pitool 280 vs Client 1.10 while changing different gfx settings in Race Room Race Experience, an awesome racing sim in VR btw !

So I decided to switch to 120hz and I also turned on smoothing in the Pimax client. I was astonished how much better it is now, it is a very solid clean & stable image with great clarity. Compared to the initial 120hz FW it feels great ! Users with the 2076 revision 8KX DMAS should definitely experience this and see, maybe I am crazy !?

I set SteamVR resolution at 2828 x 2828 and cranked my gfx settings in game really high. Using the fpsVR app I was getting a solid 120 fps when I was the only car on track. The astonishing thing for me was that with 20 other cars the fps was in the 60’s until the other cars panned out a bit. On screen though everything looked extremely smooth with very minimal artifacting and usually only at the start of the race.

I never liked motion smoothing in SteamVR or Pitool due to the ghosting & graphical artifacts. So something good is definitely going on either in the new Pimax Client 1.10 or FW2003 or bit of each. Without fpsVR turned on I could barely notice. Pushing the resolution up higher did start to impact but at 2828 it looks very good anyway.

Why have no other 8KX users been talking about this ? I guess because Pimax has not fully promoted the improvements that have been implemented and everyone is mostly focused on the Crystal.

What do you guys think ?

NOTE : @PimaxQuorra has linked the newer 120hz FW 2003 from February this year earlier in this thread. I used DFU.exe to update and it worked flawlessly. Be sure to install Pimax Client 1.10 as well.

@PimaxUSA - Finally Congratulations everyone at Pimax as this has really improved the 8KX in a huge way !


Do you only set motion smoothing in pitool and set it to off in SteamVR?