The Mysticle - The Most INSANE VR Headset I Ever Used!


Nice review. Though is unaware of the top usb port being blocked.

As he is using an Amd gpu it would be great to get more details on game settings and performance. Especially since in his setup I believe he said 5700xt opposed to a 6000 series gpu.


I also commented about the 90Hz firmware :slight_smile:


A nicely done review. Subscribed! :+1:


The one thing he got wrong was saying you need to have PTool running for it to work. While you do need to launch Pitool to change settings before launching SVR, you don’t need to run it to play Steam games at settings previously picked up by the Steam compositor if those settings are still valid for what you are going to play next. ie: I run most everything at PT 1.5 Normal 144Hz and only run PT to change PP setting mostly, when playing a game requiring it. In this respect, I very seldom launch PT. Mostly use it for Oculus games. Otherwise, I just launch SVR.


Sure, but you do have PiTool services running in the background as that is the way you have set up your specific PiTool installation.

No PiTool services, no hand-off to SteamVR, no HMD found.

When I don’t run PiTool, I don’t have services running. And afaik that is the case for the majority of Pimax user setups.


Wasn’t saying Pimax services don’t need to start which of course they run at boot, only that PT does not need to be started unless you wish to change settings. SVR will use the last settings given to it the last time PT was run before it was launched.

1 Like

They don’t. You can set them up to run at boot.

1 Like

I have PiTool 268 with firmware 271 on my 8K+ and they have changed it.

Before I didn’t have to have PiTool open to use the headset, now it will only connect if I open PiTool and if I close PiTool the headset and SteamVR disconnect.


Interesting. I will stay with PT 261 then.

1 Like

The services are the driver not pitool. Otherwise closing pitool would kill the pi servers. For example you don’t need Nvidia or Amd’s gpu suite to use the vendor driver.

Will need to check that out thanks was not aware of that change

1 Like

It does. This is now the standard behaviour to any new user that installs the curent version of PiTool.

1 Like

Still need to test this for myself. As it was usually quite the task to end the 3 processes.

1 Like

I can confirm.

I found out recently when I tried flashing the firmware manually using DFU.exe (“service not running”) after flashing in PiTool got stuck… :rofl:

I’ve recovered from stuck upgrades more times than I’ve had smooth upgrades.

Never really been a big problem though.

Just don’t be afraid of trying the different methods.

I doubt anyone has ever gotten their headset “bricked” (i.e. dead/non-working/as a brick)… :wink:

One time when I had issues with it I tried a different port:

Another time, I used a different tool:



Well done sir! It’s a great review and could we share your video on other platform?
:star_struck: :star_struck: :star_struck:


1 Like

I’m not the author… :wink:

Since You (Pimax) sent him a headset for review I would think You know him though… :rofl:


Nice, but I already posted this 3 days ago :slight_smile:
Edit: I just merged mine into yours since your’s gained more traction. :+1:


Wow another huge VR youtuber with an excellent review.

Good Job Pimax.

Check out these comments.

Im surprised he has no issues rocking that AMD GPU.

The fact that he not only got a review sample but turned around and said Pimax “Take my money”

Kind of weird he skipped over Pimax Experience.


I’m looking forward to a detailed review of in-game performance