Testing Flight Simulator 2020 In The Pimax 8KX And Yaw VR Personal Motion Simulator Live!

Playback starts at: 2:40

Tonight I am finally giving FS2020 a try in the Yaw VR Personal Motion Simulator. I have been trying to get this running for the past week and finally have found a good enough balance between performance and visuals in order to feel the game is playable. Also for this one I am once again going to use my Pimax 8KX since so far it is the only headset that I can get Motion Compensation working in… I don’t know what magic is in the Pitool software but the MC just works and does so very well!


Hi vrgamerdude,

Thanks for your share.
If you have any follow-up questions, please do not hesitate to ask.


1 Like

Isnt the picture vibrating too much, when you use it, when yaw vibration is enabled?

I have yawvr & use it with both yaw vibration &/or a buttkicker gamer 2.
The picture doesn’t vibrate at all

I mean with MC from the pitool, sorry hasnt been specific.

Don’t use PiTool’s MC, it’s close to useless.

I recommend using OpenVR Motion Compensation instead, works extremely well with SteamVR headsets.

1 Like

How do you guys make it to work with OVRMC and Pimax headsets?

I’ve tried everything, it detects the tracker, but the MC is totally wrong. It works with Index but never with Pimax.

Even Dschadu, the OVRMC developer told me that it was not compatible with Pimax, he told me that Oculus had this issue from the beginning and Pimax did something to their software that bypasses the OpenVR pose.

1 Like

I don’t use OVRMC… Pitool, has built in MC and it works really well! In fact I have never been able to get any other form of MC working for any of my non Pimax headsets using OVRMC or OVRIE! So, IDK what magic Pimax did with the Pitool but the compensation is rock solid and has never failed me yet! []-)

IDK what your talking about because the MC in the Pitool is all I can get working at all and it is 100% rock solid for me as you will see in all of the Yaw VR videos on my channel… I only use my 8KX and the Pitool MC in them because so far I can’t get either OVRMC or OVRIE to work at all. For me this method built into Pitool is so easy and makes games almost plug n play! [;]-)

Sure, PiTool MC does work but it comes with two major caveats:

  1. the tracker orientation has to be specific for PiTool MC to work with no way to adjust in software. This makes it impossible to set up reliably on some rigs.
  2. PiTool MC doesn’t allow for any smoothing to be applied, neither on rotational nor translational movement. This means vibrations and such cannot be adjusted for which for users that have BKs on their rigs is an important feature.

I‘m glad PiTool MC works for you.

1 Like

I know you‘ve been battling this for a while now.

I‘m using the latest PiTool and 8KX, StwamVR beta and the most recent version of OVRMC and it works just as well as with my Index.

I did pair the tracker via PiTool and make sure to enable MC via the desktop bat file just before launching the sim.

Dschadu told me as well that Pimax HMDs aren‘t supported but for me it works absolutely fine.


That’s great news! It must be great to use an 8KX with OVRMC and be able to use vibration without all the world shaking very badly in front of you. I hope I can make it to work as well.

I’ll try with the SteamVR Beta again and OVRMC 0.35

When do you open the bat file, when SteamVR is opened and with no game running?

Only once the OVRMC opened in desktop mode for me, it usually shows this error; Windows could not find Openvrmotioncompensation.exe, even though this file is in that directory. even running it as administrator doesn’t help.

Do you launch SteamVR directly from Pitool or from Steam?

So if you use the OVRMC layer in SteamVR instead it doesn’t works, only with the bat file?

Many thanks for your help, it is a shame that Pimax doesn’t care about this issue at all, even though the 8KX is the best for simulation, without this filter it becomes useless for motion simulation.

Right, so this is how I do it:

I start PiTool and wait for the tracker and basestations to be recognized.

I then launch SteamVR via PiTool.

Then I start the bat file in non-admin mode and activate Motion compensation by setting the checkmark and clicking apply.

Then I launch the sim I want to use.

IF the bat file doesn’t start when launching it (or showing the error code when attempting to launch via admin mode as you described), this means that the OVRMC addon and/or overlay wasn’t loaded together with SteamVR. In that case I go into SteamVR settings, Startup/Shutdown and make sure that Motion Compensation is activated in both addons (00vrmotioncompensation) as well as Overlays (Motion Compensation). If they are activated but the bat file still won’t launch, I disable both the addon as well as the overlay, restart SteamVR (this is prompted automatically), then go back into settings, activate them both again and again relaunch SteamVR. In 9/10 cases, the bat file then launches after a double-click.

If it doesn’t (1/10 attempts), I restart my PC and start from the top.

I also make sure to always have the most recent version of OVRMC installed as updates on the SteamVR side can sometimes affect usability.

BTW, using the bat file rather than launching via the SteamVR interface should have no effect on reliability. I just prefer to have everything launched and running before climbing into the rig and putting on the HMD.

I really hope you get this working; the combination of a motion rig together with an 8KX and having that motion compensated is pretty damn close to VR simracing nirvana.


I agree, I’ve tried that with the index and thats what I’m looking for with the 8KX.

Recently I’m having a lot of crashes starting SteamVR because it is blocking some addons, maybe thats why I can start the bat file.

The weird thing is that it actually works, but instead of moving the world to compensate the movement of the tracker, it moves the view of the headset, I mean the world stays still and it’s like if I turn the tracker to the left the headset camera follows this movement but to the oposite way, without moving the headset at all, distorting my view, and If I turn the tracker to the right, my view starts turning to the left

I’ll try it today following your instructions, many thanks for the help

1 Like

Best of luck with it.

When I tried OVRMC for the first time with my 8KX, I had that exact behaviour as you described; that is, every movement was actually exaggerated rather than compensated for.

I don’t know what did the trick in the end, but it now works just the same as it would with my Index.

EDIT: do make sure to set the two compensating values within OVRMC settings as little as possible in the beginning. I found that the stock smoothing was too slow for my taste and caused nausea.

EDIT 2: These are the settings I use.

Ah Ok… I do have a Vive tracker puck in a fixed position on my rig and I don’t use the vibration feature… I was just talking about the Yaw translation. So far I cannot get OVRMC with any settings to work for any headsets… the minute the simulator starts to turn it throws me out into space in whatever game I am trying… the other night in DCS it threw me so far out of the plane I was looking down at what seemed to be a globe as if I had entered orbit…LOL If you have any advice on how to get it to stop doping that and be as reliable as the Pitool when it comes to being rock solid for yaw movements then please let me know… I love my 8KX but would really like to use my G2 for the sharper visuals in some games.

No luck for me. I’ve followed your indications, I’ve been able to launch the bat file, but I get always the same result.

It is so strange. If I use the mirror on my monitor, there I can see that the MC is correct, if I have an object in front of me and I turn the tracker to the left, the mirror view goes to the left, and the object stays behind in the right, but in the headset I don’t see that, the object is always in front of me, the world does no turn, only my HAM or mask or fov is turning, is very different what I see inside the headset that what I see on the monitor mirror.

I’ll keep trying, I’m missing some step.

That sounds strange, VR monitor in in HMD view is different?

Do you have HMD and tracker swapped in OVRMC settings? One is the viewport, the other the reference tracker.

Yes very strange, I don’t have options to change the HMD in OVRMC, so there is not much I can do.

This is a simple 3d render to show what I see;

This is what I see on the mirror when I turn the controller left and right;

And this is what I see inside the headset when I turn the controller left and right;

Inside the headset the virtual world doesn’t turn with the MC, only the mask, and in the mirror I see it as it should be

Try OVRMC without having a controller powered up please.

Come to think of it, I never had a controller connected when using OVRMC I think.

Maybe the controller is replacing the tracker as reference in OVRMC?

EDIT: The view inside the HMD shouldn’t change in reference to controller position at all, only in reference to tracker position. I strongly recommend turning off all controllers and only have the 8KX and the tracker enabled before you apply MC.