SteamVR supersampling values does nothing - 5k+

Hi guys, I’m fighting a bit with the newcomer 5k+ for some issues. One of them is about supersampling.

It does work into the PiTool on his own home screen, but yet after SteamVR start it simply ignore that value: I can set on PiTool from 0.5 to 2 (with huges differences on his space environment) and SteamVR and games just look the same (blurry). But also I can crank or lower down the supersample value on SteamVR, the general one or per application, or set as automatic and I can’t see any difference visually or as performance. I tried to install OpenVR Advanced Settings, same scenario, I can set the compositor at 0,1 or 2.0, reboot SteamVR and just look the same and perform the same.

The only things than does work is in-game supersampling, from options if avaliable, but starting from that virtual resolution so ignoring PiTool values or SteamVR values.

Tried with SteamVR beta, not beta, deleting SteamVR ini file and the whole program, fresh reinstalling video drivers (1080ti).

My guess is than SteamVR is thinking that I’m using the Vive somehow, see this picture with a stunning 30.000x15.000 per eye rendering value than runs Google Earth smoothly but still kinda blurry. My Vive is not connected anyway, never installed Viveport.

1 Like

Disable pihome.

I generally leave pitool at 1.0 & leave steamvr video on auto. Then use in game adjustments first. Then try if needed steam’s per ap setting.

If you change pitool render or steam’s ss restart steamvr.


Thanks Heliosurge, this seems to work in some way. I’m now able to reduce supersample per app setting seeing some change, or increase it.

Where the result of a lower value is evident I’m not fully convinced about the higer values, because even at 500% happens to be not that sharp without the performance hit I expected. Any in-game supersample increase looks reactive, both for details than the framerate.

This leads to different problems, anyway, so I can start searching in different directions.

1 Like

Your welcome. Just keep in mind with more FoV means also more gpu needed to render the scene vs reduced FoV of the vive & rift.

Same here until my used vive arrives i can only speak for skyrim VR.

Pitool multiplikator + Steam supersampling does nothing most of the Time. So i set the rendertarget value to 2 in the SkyrimVR ini Files and bibedibob awsome resolution.

But sometimes via VorpX the steam and pitool does work well together.

1 Like

@rafport sorry one of ADV settings devs here, Stumbled across your post via google feed… please make sure you have updated to ADV settings 2.8.0

It can Be found here.

I did fix some issues with the Super-sampling in the 2.8.0. It should sync, just fine with SteamVR… as for beyond that it depends on pi max and their pitool.


Welcome to the pimax forums have upgraded your account for your convenience. :beers::sunglasses::+1::sparkles:

Thanks for all your kind replies, and I’ll try for sure the 2.8.0 of ADV.

Anyway I did some extensive tries tonight with a friend, and something is not working as it should about my Pimax and the supersampling multiplier. For example, if I put a 500% over Elite Dangerous it runs much smoother with the 5+ than with the Vive, this is a nonsense. The fact seems to be than with the Vive is actually multiplying the resolution to a such exagerate multiplier where with the 5+ don’t.

Another weird thing is than selecting a small FOV, medium or large does nothing on the framerate (but work as it should visually, reducing the field of view). I tried to do it in real time and reboot everything, on Elite, Everspace and Golf Club - all heavy stuff to render - I have no benefit in reducing the FOV and even that doesn’t make much sense.

I don’t know if I’m the only one experimenting those issues or it’s something common.


I think there is some sort of limit being applied, so the Pimax never reaches the specified resolution. That would explain these symptoms.

1 Like

Ok, maybe I’m starting to understand what’s happening here. Thanks @ykeara for the link, the ADV 2.8.0 actually works even if just in the same way as the per application supersampling, so with this strange issue than lower the quality no matter you try to crank.

I understood/read now than despite being immediately visible into the headset, if you don’t close and reboot not just SteamVR or the game but also PiTool you don’t get any kind of performance boost in reducing the FOV.

After that it’s clear than some kind of resolution limiter is happening here. The SteamVR white environment and windows, with a small FOV and PiTool rebooted, looks finally sharp enough where was kinda blurry/crappy before. Launching Elite cranked to 500% looks better now, but weird enough runs slower that with the large FOV!

So, something strange is happening about the rendering resolution than is limited at some point no matter how hard you try to crank it. If the FOV/res is smaller, you get a better image because this cap is not reached that fast. Anyway you can push PiTool at 2, SteamVR at 500% per app supersampling at 500% for a totally crazy resolution and still you get the same image and performance, because as soon as you reach this cap doesn’t grow anymore.


Nah, there’s definitely some fuckery going on with SSing these things.

OpenVR reports to the application different recommended rendering target resolution from what is shown in SteamVR UI and seems to be limited to 4096 x 3499 res.


Any gpu poking tool? Been awhile wpuld gpuz give some info maybe? @Sjef might have some ideas.

That is the answer, thanks! Added to Reddit Pimax Wiki here.

1 Like

Winii please add a link to Pimax redit wiki to 5k 8k Directory please.

Sure thing, done…

1 Like

Good to know. Many games, like Elite Dangerous, have the ability to set super-sampling in-game, which should allow you to increase the rendering resolution past 4096x3499.

1 Like

I found someone posted a thread on the steamvr bug report forums. It probably won’t really get fixed unless they know about it!


@Sean.Huang @anon74848233 I am sure you folks have been following the Steamvr/OpenVR limits on SS limitation.

Will need to contact Valve to increase this limit.

1 Like

Have you tried the SteamVR Beta?

SS doesn’t seem limited on my 8K with that. It has Video SS and App SS

Then there is the SteamVR HMD Identifier - the Pimax 8K being listed as Vive MV in the Video section. Something to also look into and maybe Pimax and Valve come together to have recognised support of the Pimax HMD’s in SteamVR but - given that Valve seems to be holding out on Pimax with the Gen2 Lighthouses, I don’t see much happening on this front.

1 Like