Setting up Revive

I just got the 5K+ and after discovering I can’t load Elite Dangerous (Oculus) from My Games I installed Revive 1.7.1. However in Steam Home I cant get past the welcome menu using my gamepad as clicking the trigger to activate the ‘next’ button brings up a grid on the floor but does not advance the menu.

Is this a known issue with a simple solution? Can I use Revive without Steam?


1 Like

Update: I’ve managed to get Revive up and running through the bottom right taskbar icon but while I can load my Oculus software just like Pitool (although I’m getting a double image until I figure out how to correct this) I still cant launch Elite Dangerous! It boots up on the desktop but doesn’t show in the headset!

I don’t want to seem a pain in the neck but am I missing something?

Can you download the steam version. You should not need Revive.
I just load ED from the desktop shortcut.

I bought the game on Oculus Home three years ago and was under the impression If I bought another copy or somehow managed to have my account transferred over to steam I’d lose all progress and have to start the game from scratch. As you can imagine I’m in no hurry to see three years play disappear into a black hole. I can start ED outside of OH but it just boots up on the desktop and doesn’t show in the headset.

Is it possible to have an account transferred from OH to Steam while keeping all settings/progress intact? Or, as I’m beginning to suspect, am I royally screwed when it comes playing Oculus Elite on the 5K+ !!!

Go to the elite dangerous forums and ask for help there. I do believe you do not need the steam version but need steamvr and might need to opt in to steamvr beta or something.

There people there that play and have multiple HMD’s including the pimax hmd so they should be able to help you get set up nicely and yes you need PP to be on.

1 Like

The double image. Make sure Paralell Projections in pitool is on.

@park might know some tricks as I believe he was looking to try & launch ED without Steam.

1 Like

go to frontier’s website ( (the developer of Elite Dangurus) you should have an account here with the same login as you use for the game.

find PArtner KEys under your account settings… there you shod be able both to see your oculus key and have an button for activating it on an steam account also…

then you do not need to use revive and as it are the same server… you can continue on the same games… the settings have to be adjusted again as it’s another client.


Thanks for all the replies. I’ll look into activating ED on a steam account.

A few thoughts regarding my initial impression of the 5K+

Apollo 11 HD runs a lot smoother in Revive (even with parallel projections) than it currently does in Pitool. Even with FOV set to small (I’m using a GTX 1080) Pitool gives a barely passable experience whereas Revive is almost as smooth as the Rift.

I was so concerned by Apollo 11’s performance I approached Skyrim with some trepidation but was pleasantly surprised to see it running very smooth. Even with FOV raised to normal it still ran as smooth as the Rift (it also runs smooth at large FOV but with a massive drop in resolution). Skyrim only seems to need parallel projections for the loading screens as in-game I haven’t noticed any issues with it switched off.

Getting the sharpest image from the 5K+ requires a bit of adjustment. And even when you’ve found the sweet spot just moving the headset up or down by a millimetre or two can lose fine detail. I think the Rift is definitely better in this respect. However despite previous reviews I was surprised to see the colours in the 5K+ are just as good as the Rift. The black level though is a curious thing. In some sections of Apollo 11 it seems to be almost as good as Oled (I have my brightness setting at -2 and contrast at +2) while in other sections you can definitely see the ‘greyness’. The jury’s still out on this one.

Overall I’m happy with the 5K+ (at least I will be if I get Elite up and running) but I wont be giving my final assessment of the headset until I get at least a 2080 Super to run it at normal FOV without issues/compromises.


I have the game installed “standalone”, rather than attached to any store launcher, and have never had any problems running it on any of a variety of headsets.

I assume that when the game is started from Oculus Home, maybe it is told to go VR by a command line option, but otherwise there should be no special “versions” of the game for different platforms, so I suggest you start it on the desktop again, using its own launcher, and hop into graphics settings. There should be a 3D option, where you can select HMD with headphones or speakers – after that you should be golden. (EDIT: No need for any hacks - the base game has native support for Oculus runtime, and for OpenVR (SteamVR) (EDIT2: It will check for Oculus being present first, before OpenVR, so if you have the OVR launcher service running, Oculus Home will open, even if the game then goes on to use OpenVR, after it has become clear no Oculus headset is connected) . )

Don’t know how much user data is stored locally, and associated with your installation, but your progress should be attached to your Frontier player account, so nothing should be lost there.


When you change the fov you have to restart steam(maybe pitool as well) or it will look blurry.

Here’s where I currently am with my Elite problem.

Using the partner keys suggestion I’ve managed to transfer the game to my Steam library. After booting up SteamVR the ‘Commander Deluxe Edition’, as originally bought on Oculus Home, is present along with a button to play the game in VR. Unfortunately when I press the button the game starts up on the desktop but, alas, does not show in the headset (only a Steam screen with the Web, Store, Library, Community buttons etc. Under the Play In VR button there is the following message: OPENVR APPLICATION Some detailed information on Elite Dangerous Commander Deluxe Edition on Oculus Rift is unavailable because it is a non-Steam OpenVR application. Steam will still manage launching the application for you.

On the desktop my account, avatar, credits, etc appears intact much to my relief but when I access the settings there is no option under 3D to select HMD (only two options: 3D Separation and 3D Focal distance) and there is nothing relating to a HMD under display either. This is strange because I have noticed HMD options when in the Rift.

If I try and boot up the game from Oculus Home I get a message telling me there is no Rift attached to the computer and if I try and start ED directly from the launcher within program files the following message pops up: Please start Elite Dangerous via Oculus Home.

So, I can get Elite to run on the desktop but for some reason it’s not being sent to headset (I have no problem starting Skyrim VR from Steam). I’m pretty stumped as to what else I can do so it looks like I need to contact Frontier and see if they can resolve the situation. Greatly appreciate the help you guys have given and I have just two last questions: Is there anyone on the Pimax forum who had Elite on Oculus Home and managed to get it running in the Pimax? If so how?


Strange that you didn’t have the 3D options.

I suppose you could try editing your file:

[YourSystemDrive]:\Users\[YourUserName]\AppData\Local\Frontier Developments\Elite Dangerous\Options\Graphics\Settings.xml

…so that it contains:

1 Like

Hmm… Try adding launch option I think



@Enopho & @neal_white_iii might also have some ideas.

1 Like

Unfortunately, I’m not sure I can help. I originally bought the Steam version of ED and later switched to using the Frontier launcher.

The entries under 3D really refer to using a 3D monitor. Under the regular graphics settings, you’ll see a HMD super-sampling option, which is the only VR setting that I know of. I leave it at the default (1).

Try this: First, make sure SteamVR is running, then try starting the ED launcher manually (not through Oculus). ED should start in VR mode.

You could try using EDProfiler. Here’s some info on that: EDProfiler - A New Display Switcher/Robust Settings Profiler/Switcher/Detector! | Frontier Forums


If you are not getting “HMD HeadPhone” show up in the menu, then elite is not seeing the HMD.
I have Two accounts (commanders) and My game is install in its own folder on MY C: drive,
I have a copy in steam folder but don’t use it, I just launch from desk top and steamVR starts on its own, I also dont use PiTool unless I want to mess about with the settings.
You could try and stop the Oculus run-times . Run this in a CMD as administrator.

sc config OVRService start= demand
net start “OVRService”
if %errorlevel% == 2 net stop “OVRService”


can you please try launching in this order…

Open Steam.
Open SteamVR
now manually launch VRMONITOR from here: Steam\steamapps\common\SteamVR\tools\bin\win32\vrmonitor.exe
Launch Elite Dangerous using the VR Button if it has not started.

Note: ensure that there are no switches in the game launch options as vrmonitor should do the work for you.



1 Like

Thanks for the suggestion but it hasn’t worked. When I follow your instructions and click on bin I am not presented with win32 but 2 folders called content and shaders. If I click on content I get a vrmonitor folder but it is empty.

If I follow the route Steam/steamapps/common/steamvr/bin/win32 I’m then presented with files and folders. One of these files looks like vrmonitor.exe (its 2.5 MB). When I either double or single click on it nothing seems to happen and when I then boot up elite from the Play in VR button it boots up on the desktop but doesn’t show in the headset.

If I follow the above route (having first completely shutdown and restarted Steam and SteamVR) but this time select the win64 folder and click on vrmonitor.exe Oculus Home now boots up. However starting Elite from the Steam VR button has the same result as previous.

I’m planning on asking Frontier if its possible to have progress transferred between accounts if I buy another copy of the game on Steam. Something tells me the answer will be no. Its frustrating the game in my Oculus Home library I most want to play in the 5K+ is the only one that isn’t recognised by the headset. The gods do like their petty torments (;

If I stop the Oculus run times could that have an adverse effect on my other Oculus games? I’m not a computer expert and I’m a bit wary about typing commands into CMD if things end up going pear shaped.

Surely I cant be the first person on the forum to run into this problem with Oculus Home Elite. Does every Elite player here have the game as either Steam or standalone?

1 Like

If you run that script once it stops Oculus, if you run it a second time it stars it again.

If you just install from steam your commander is saved online. The only thing you may want to keep is your settings, in particular you bindings, you will just have to enter your authentication code.

1 Like

What I am trying to say is, Just download the game on steam and use your login name and password and it will work.

I have one elite game folder on my C: drive, but use to different commanders on the same game, ( two accounts) If you have 10-20 different commander (accounts) names you will only need ONE copy of the game as your commander is stored on the servers.