Right eye blacks out at 114hz

When I use 114hz, after a short while the right eye blacks out. It won’t return until I do reboot HMD from pitool, or hold power cycle the 8KX.

I’m on the 264 pitool beta and the beta firmware .294.

Is this a known issue? Any fixes?

Prior to switching to the beta firmware I had the 118hz option but it did not look right (some stutter and flicker). 114hz looks perfect, about as smooth as 120hz on index, but has this black eye issue.

I haven’t ever seen the issue happen at full res with 75hz.


same happens to me on that pitool and firmware…


Have you gotten any version combinations to work?

1 Like

I know someone else reported ghosting on the right eye.


didnt try other versions

I’m having the same issue, seems to only happen in 114hz mode. I am using the latest 264 and latest firmware.


you guys can try PE version, but maybe it doesn’t address the 114 mode or firmware isn’t changed

they need to fix this…


I tried using PE, but it broke all my pitool settings, I removed all the pitool drivers and software and reinstalled 264 beta.

Works fine for me on PiTool 262

i think pitool 264 broke the upcaling mode on the 8kx and the oculus games

is the performance on 262 the same at 264? Or could you tell a difference?

I tried downgrading pitool to .262 as suggested (still with .294 firmware), and I had the same blank eye problem occur again. Has anyone who has seen the issue had luck in fixing it, and which versions of each did you switch to?

1 Like

I opened a support ticket about is 5 days ago. Still waiting to hear back, I’ll share what they say.

1 Like

It happens to me too with the last (same) pitool 264 and 294 firmware, the pitools with the “Pimax Experience”. PiToolSetup_1.0.2.084

1 Like

I’m having similar issues in 114 hz. It’s my left eye lens that blacks out, but the problem is the same.
Also, I’ve been having the headset just quit for a second, go black, and then come back but in a nonfunctional way- like the game screen is overlaid on the Steam VR screen. No way to get back to the game. It seems to happen mostly in Aces High. I have also had trouble with DCS- but my graphics card is underpowered for that game anyhow.

intel 9900k
32gigs ram
Nvidia 1080
PImax 8kx
CH Stick, rudder and throttle.

So far I’ve done this:
uninstalled ptools 284 and Pimax Experience.
set my Bios to normal clockspeed on my intel 9900k
reduced the video settings in the game (Aces High, DX 11

i think its a firmware problem,i hope…

This issue needs to be addressed. It’s becoming a pain. Every time, you change to a new resolution in upscale mode, the right eye blanks out.
This happens in the same game or when start the next game.
Will also raise a ticket so that this gets some priority

1 Like

Problem was solved by a firmware update from support. Anyone still having this problem please raise a ticket.


@Goosekr do you have the firmware version number? I haven’t been able to get a response from support.

edit: nevermind, they did respond to the ticket with an experimental firmware, I just didn’t get an email notification.

1 Like