[Resolved] Pimax4k With NOLOVR, SteamVR "Headset not tracking" issue

Hey guys,

Pimax 4k works fine without the NoloVR…
I just got my NOLOVR in the mail, set everything up and pairs my devices successfully. Installed the needed software and the Nolo drivers state everything is connected. I Uninstalled all Pimax software and reboot, I then installed pimax Version for Nolo from here http://community.openmr.ai/t/hello-nolo-piplay-nolo-customized-driver-beta-version-piplay-1-2-85/2311 and followed these instructions here https://www.nolovr.com/pimax/. Everything works fine until I get to steamVR…“headset not tracking”…I’ve added a screenshot.

Any advice/input is appreciated.

Thank you.


1 Like

PS i just opened a thread with NOLO support as well. Pimax4k With NOLOVR, SteamVR "Headset not tracking" issue - NOLO Forums

Ever since the PiPlay version you installed, Nolo is automatically supported. No need to go and get an older PiPlay version like 1.2.85…
If you don’t want to use 2.x and above, I recommend using 1.2.93 or higher because of the magnetic calibration.
And I recon you did install the camera on the 4K and have the usb for it plugged in? I’m not seeing a base station active on your screenshot too (which you should have). And it’s no problem installing the Nolo drivers, but the software shouldn’t be active when starting your PiPlay and trying to use your HMD. That might cause detection issues.


Hi Matt, have you tired the latest Piplay from our website?

If your basestation is plugged in via USB cable - try to unplug it and see if it works (it’s wireless)

Latest version of Piplay, Fresh install… Nolo Drivers are not running… Same results…

Thanks for the input.


Nolo drivers are a nightmare, I completely remove them and everything has worked very well. useful to check that everything works but nothing else …

Removed nolo drivers, reboot, tested and same problem…


Is the gyro of the 4K still on? Because you can disable it in PiPlay, but when I tried that, thinking the Nolo camera would do a better job with the headmovement than the gyro’s on the 4K, the headset lost tracking in SteamVR too. It seemed that the drivers still need or use the gyro data on the 4K.

Gyro is on and same issue… I’m super bummed out. 3rd day I have the nolo and I can’t even use it… No response from the Nolo team on their forum yet…

@Gilmore I reported this issue to our bug system, one of our engineers will assist you remotely through Teamviewer once China National Day finished, sorry for inconvenience

could you try to explain what is needed? i’m in the same position as gilmore…

@gilmore… is it working now?

Pimax support, thank you for the reply and i will wait until we are both ready to troubleshoot remotely… Nolovr support recently contacted me saying that they will soon look into the issue as well.

@Gilmore Hi, please send ID & Password of Teamviewer to support@pimaxvr.com when you’re available : )


Waiting for remote session.



1 Like

Hi there again… have they fixed it?

i donwgraded piplay to 1.2.75 this weekend and bought driver4vr to be able to play in vr…
it works but pretty far from my expextations… alot of drifting in both pimax and nolo hardware.

@Pimax-Support can you help me aswell?

The Pimax team did remote to my pc to try and resolve the issue. They did not find a solution to my problem and concluded that the Pimax works fine without the Nolo. The problem is the Nolo and I am waiting for the Nolo Team to get in contact with me for a solution.

I find it a wee bit strange though that there just are a few of us pimax + nolo owners that have issues. even the russian dude who also have problems doesn’t seem to have exacly the same issues… since he can start steamvr and turn the headset backa and forth… i only get the grey wall.

and now that i have it working with driver4vr i’d really like to be able to turn nolo off in the pimax driver… and use nolos driver with driver4vr with a more recent pimax driver…