[RESOLVED] Pimax Not Detected - AMD 5700 XT

Just received the unit a couple days back and just hooked it up. USB is detected and when I plug it in to DP it does cause my main display to flicker a few times, but the Pi Tool insists the devices are either disconnected or the list is blank.

I’ve just been reading that there may be problems with AMD cards and Pimax drivers? I picked up a 5700 XT a few weeks back (it is beyond return window) and it’s currently being a great card for me, but many reports are suggesting to me that the Pimax is simply not working for the majority of AMD card users? Is this information correct? (If so, I’ll have to return the Pimax during the return window, unfortunately).

If it should be working, then any tips (or pointing me to the proper article) about getting it to work would be great. Thanks!

1 Like

Hi @Lillo topic here on 5700 @PimaxUSA points out in July that the 5700 drivers are atm Alpha’ish.


Can you post your setup & pitool error messgage.
Windows ver
Gpu Driver Version
Pitool version.

1 Like

Windows 10 Home (up to date)
i7-6700 @4ghz (liquid cooled and over clocked to 4.4)
16GB Ram
Pitool V1.0.1.132

Actually, the AMD 5700 XT card is just a few days shy of the end of my Amazon return window, I thought I had it longer than that. But I would really prefer not to return it. The comparable card from Nvidia currently is $100 more (and is actually just a tad slower). I’m not a fanboy of either brand, I just usually go with best bang for the buck, and right now AMD happens to be the clear leader.

Are there any known fixes for this whole AMD / Pimax issue?

1 Like

Tbh at present Amd cards are working save maybe issues with the 5700 series cards not having mature drivers. It is true though Nvidia cards are currently performing better overall.

My old r9 390 8g amd card performs reasonably well on my other system.

Have you tried pitool 144 or 180? They might work better.

What error code comes up in pitool?

Check diagnose under Help tab in pitool.

Also ensure intel integrated graphics is disabled in bios.


I also have an old r9 390 (added liquid cooler), but upgraded when a card that outperformed it finally became available at a reasonable price. That was a heck of a card at the time.

Going to try and borrow an nVidia card today and see what happens. I’ve tried any series of AMD drivers, including the current beta, and PiTool versions including that current beta as well. I get no “new device attached” sound when plugging-in the DP cable to the AMD card. The USB side is working fine (audio device and volume controls work). I’ve also tried any number of USB ports, removing all other USB devices, and different “plug-in and/or power sequences” to no avail.

The error code, when Pimax is plugged-in to both ports is 10935. If I actually unplug them the error code is something different in the 10xxx range - seen several values there, and depending on the sequence of un-plugging and re-plugging that sequence may vary).

1 Like

Try your r9 390 card.

With you intel processor have you disabled igpu in bios?

I’ve heard the newest just released AMD graphics drivers have just reached first WHQL certification for XT 5700 series, have you tried these ?

1 Like

Just tested with Nvidia RTX 2070 and it immediately worked. So there we go. At least I know it’s not some other random issue. (Yes, integrated GPU is disabled, that wasn’t the problem). Bummer. Don’t know if I’ll even bother trying other radeon drivers since I’ve only got 3 days left if I want to initiate a return on the 5700 inside my Amazon return window.

1 Like

Yes it’s disappointing Amd doesn’t have there gpu driver for Navi fixed up.

They had the same problem last year. My r9 390 worked well. But Fury & up to vega had issues.

Could be worth a try…

1 Like

how is the 2070’s performance?

1 Like

I don’t really know about the performance yet. Feels “OK” so far, but I’m already encountering things I’ll have to figure out how to deal with before I can really make any judgements (for example, I went ahead and bought Skyrim VR so that I had at least one game made for VR - probably 80% of what I’ll eventually be doing will probably be using Vorpx. But Skyrim VR is for some reason stuck at 64fps instead of 90fps, so there is a lot to learn. I just need to get things working well enough in the short-run that I can determine if I’m going to keep all this stuff or return it and go back to regular stereoscopic gaming (which I’ve been doing for about 10 years).


Skyrim VR you should be able to get really good fps on as it runs on a 980ti & the r9 390 with nice results. Though may depend on number of Mods used. @Fresco would be one of a few with really good mod xp.

Yeah, I’ll probably mod the heck out of it eventually, but right now I would setting for figuring out why it’s locked at 64fps when I have the refresh on the Pimax set to 90.

1 Like

What do you have pi render set to?

Try Pi Render x1.0 & SteamVR in Auto.

I generally use PiTool on Normal FoV but folks have used Large even on I believe the 980ti.

Your running Skyrim VR & not Skyrim on Vorpx?

Yeah, Skyrim VR, just to make things “easy” (haha). Steam VR thinks my refresh rate is 64hz, that appears to be the problem. I can’t be the only one using a Pimax to see that problem, right? Should be 90hz.

1 Like

Pitool is set to 90hz?

yep, PiTool set to 90

1 Like

Hmm… Did you have pitool set to 64? If so you need to reboot service & steamvr.

1 Like

Yep, rebooted entire computer several times actually. But I’ll move that issue to a different thread as that makes more sense. We got way off topic here! If I try the AMD card again before returning it I’ll definitely stop back with results.