Problems with SteamVR after reinstall

Hello folks, I could use some help here. Hope this is an appropriate place to ask.

A power supply failure took down my system, and in the process corrupted the C drive to the point where a reformat and clean install of Windows was needed.

Before I turned my attention to my 8KX I reinstalled Steam. My Steam Library had been on another drive, so in the Steam preferences I added my old Steam Library folder and made it the default. I now have two library folders in Steam, but all my games are in the old folder which is now the default. That seemed to work as I can run non-VR Steam games.

SteamVR needed updating, so I let it download and install the update (it is now on 1.20.4). It installed to the new Steam Library folder.

I reinstalled Pitool ( and PE (0.86) and all that seemed to work OK, in the sense that the HMD comes on as normal and I can see the PE user interface in it. But PE says that there are no Steam games installed.

If I click on “Run Steam VR” from within Steam, SteamVR will start, and then stop with a “Critical Error”, and give me the option of quitting or restarting. If I restart, it will then tell me that two add-ons were blocked due to a crash. One of those add-ons is called “Pimax”. If I re-enable them, it all happens again.

When I first got my 8KX everything sort of worked with Steam, so I have no real experience of trouble-shooting. Grateful for any advice on where to start!


I see this problem too. Just unblock the devices in SteamVR, but do not restart it; quit instead. Reinstall PiTool. Version 270 didn’t have this issue, but doesn’t have the newest features. 90 Hz is enabled in the 8KX firmware, so keep your current firmware. If you reinstall version 271 or 272, eventually the “critical error” will reoccur. When you see it, just repeat this procedure.

I’ve installed 273, but I haven’t used it long enough to determine if it’s stable and hopefully fixes the critical error. So far, it seems to be working OK. Nope, it still has the problem, so I’m going back to 270.


Thanks Neal! I was hoping it would turn out to be something that simple. Releasing versions of Pitool that do not work with SteamVR does not seem a great idea to me…

Installing Pitool 270 over 271 failed with lots of “access denied” messages, so I uninstalled 271 and then did a new install of 270. I can now launch SteamVR and PE can see my Steam games - the cloud profile feature does not seem to be working, but it did not work well for me before anyway.

Now I have to remember how I turned off the SteamVR home “room”.

edit: performance (on a 3090!) is cr*p - time to start again at the beginning.


Goto your desktop SteamVR window. In Settings there you can disable SteamVR Home.

1 Like

Thanks @Heliosurge - I eventually worked that out.

But now I need some more help again, folks.

Before I reinstalled everything, things just worked. I would turn on the 8KX, Pimax Experience would open, I would launch a game, SteamVR would start, and the game would run.

Now the only way I have succeeded in getting SteamVR to run properly is to:

Power the computer completely off, wait and restart.
Start the 8KX and wait for PE to start.
Alt-tab out of PE and manually start SteamVR, either from the Steam client or from Pitool.

Anything else and either:

  • SteamVR won’t start at all - the “start” button in the Steam client turns blue and says "“stop” for a while, then reverts to “start”, and the SteamVR panel does not appear.

  • SteamVR starts, and the panel appears, but says “Headset not detected”, even though PE has started and I can see the PE UI.

If I then try and start a game from within PE, it just goes into a “game is starting” message that never goes away.

Very frustrated, grateful for any advice.


I haven’t ran pe lately. Though quite possible may need an update as last release was in Apr.

Maybe @arminelec and @SweViver can update us on the status of pe and the ipd wizard they said was coming soon.

When this happens, reenable the headset in SteamVR, but do not restart SteamVR; instead, exit SteamVR, reinstall whatever PiTool version you are using, and continue as usual. I’ve seen this behavior in the most recent PiTool versions. I think the last fully stable version was 270.

This issue seems to occur fairly often, at least for me.


I’ll try that, but 270 is what I am using…


What firmware are you using? Is it the same one that shipped with 270? If not, you might want to try an earlier version of the firmware.

1 Like It’s the only thing that I know hasn’t changed since before my rebuild.

I’m not sure, but I think that I was using Pitool 269 before the rebuild. I have tried reverting to that from 270 but it didn’t seem to make any difference.


Still getting nowhere here.

By going through all the palaver described above I can start SteamVR ONCE.

If I exit the game and exit SteamVR to get back to PE, that’s it. SteamVR will not start again.

I have uninstalled and reinstalled PiTool a few times without success.

Will try raising a support ticket, but meanwhile any assistance will be welcome.

Edit: OK, how about this for weird behaviour:

  • Start Elite in 2D mode.
  • SteamVR actually starts and stays running.
  • Turn on HMD, PE starts.
  • SteamVR shuts itself down.
1 Like

Still troubleshooting.

  • Without Pitool or HMD running, start SteamVR from the Steam client. SteamVR runs and sits there saying “headset not detected”.
  • Start Pitool. SteamVR continues running.
  • Power on HMD. Try and launch something from either Pitool or PE. SteamVR shuts down.


Support ticket #20637 raised.


Hello Troz,

Your ticket has been forwarded to our technical support.
Yvette will assist you in resolving the issue.



This is a weird case indeed. After closing SteamVR, have you checked the steamvr.vrsettings configuration file to see if its OK and not corrupted? Do you find any weird values added? If you temporarily move/emove the file, does SteamVR start as normal again?

Try also removing/uninstalling plugins to see if that could be the problem, such as OpenVR Input Plugin, OpenVR Advanced Settings, Revive and similar.

I would also suggest to try switch to/from SteamVR beta and see if this changes anything. Sometimes the Beta versions are just not playing well with PiTool (although Im running Beta as of now and no problems for a while).

@Heliosurge the work on PE has been on-hold for a while because of various reasons Im not able to discuss here. The project is not dead, but we need a plan how to operate it, keep it stable and improve and maintain all old/new features.


Cool Marcin. So is the team going to implement the ipd wizard directly in pitool for now as a stop gap til PE continues?

1 Like

Hello. It is still not working properly, but I can now get SteamVR to start most of the time.

This is what I did:

  • Uninstall Pitool. Power off computer and restart.
  • Delete Pitool folders.
  • Uninstall SteamVR. Power off computer and restart.
  • Delete SteamVR folders.
  • Reinstalled Pitool 270.
  • Reinstalled SteamVR.

Now when I switch on the headset, Pimax Experience will start, but I cannot start a game from there. I have to alt-tab out of PE, then start SteamVR from the Pitool UI.

  • The SteamVR menu then appears in the HMD. I select “exit VR”, then PE starts.
  • I can then start a game.
  • Sometimes the game will not start, and I need to start all over again.

Noting @SweViver 's comment above, I looked at the steamvr.vrsettings file and it looked OK. However I found a backed-up version from before my system rebuild and used that. No obvious improvement.

I am not using SteamVR beta.

@SweViver @PimaxQuorra

And now I got a response from Pimax on my support ticket that I do not understand at all:

Are you trying to run Steam VR and Pimax Experience at the same time? I am sorry to tell you that it’s basically impossible to allow SteamVR to be running simultaneously with Pimax Experience as they both use different render pipelines (PE uses Pimax SDK and native rendering pipeline while SteamVR uses OpenVR).

If the game is installed on Steam, please select Pimax Home as the main home, start Steam VR, and then start the game either from Steam or via Pitool (Pitool–>My Games).

Obviously PE is designed to run Steam games, as it used to on my system without any problems. Can anyone clarify?


PE runs before or after SteamVR.

I.e. You launch from PE, which starts games through SteamVR (or Oculus) and when You exit SteamVR (or Oculus) PE starts up again.

You could say they all (PE, SteamVR, Oculus) “occupy” the headset so only one render pipeline can run at a time.

Sounds like You misunderstood each other.


I.e. You launch from PE, which starts games through SteamVR (or Oculus) and when You exit SteamVR (or Oculus) PE starts up again.

Well that’s pretty much how I understood it. What the Pimax agent was saying, though, was that Steam games could only be started from Pitool with Pimax Home selected rather than PE. Which is wrong.

I’ve asked for an escalation so hopefully I will be able to talk to someone who will understand that all I want to do is be able to run games from PE every time, just like I used to.


Well my latest interaction with Pimax has been positive in that we now seem to be understanding each other.

But their current advice is yet another uninstall/reinstall of Pitool and SteamVR. Since this will be my 4th or 5th, can anyone suggest anything better than just using the built-in Windows uninstaller? Is there a 3rd party uninstaller that might do a better job? Which folders need to be manually deleted?