Pitool v1.0.1.274 Beta

Pitool V274 Beta

Release Notes:

  1. Optimized the IPD’s reference image.
  2. Fixed Tundra Tracker‘s adaptation issue.

Download Link :

If you couldn’t access the download link, please get it from Google Drive.


If you have any questions, please feel free to contact @PimaxQuorra / @PimaxUSA on our OpenMR forum as we are ready to provide assistance.

Either way, please comment below if you’ve encounter any unusual issue.

Your Pimax Team.

Pimax Website: https://pimax.com/
OpenMR Forum: https://community.openmr.ai/
Pimax Subreddit https://www.reddit.com/r/Pimax
Pimax Facebook: Pimax
Pimax Discord invite link Discord
Pimax twitter:https://twitter.com/pimaxofficial
PiTool: https://www.pimax.com/pages/pitool
Pimax Support: Support : Pimax Support


Hmm, I can’t seem to locate the IPD guide. Anyone able to tell me where it is located?


Does this version have the Pimax Experience baked in, or is it still a separate app?


When I chose PE in pitools it asked me if I wanted to download it. Which I did. IPD guide still said coming in PE which is the only place I’ve seen it referred to.


I would really like some more information about this new Pitool V1.0.1.274 Beta?
I mean the last 273 was not the most smooth. Perhaps, some indication that 274 is fixing some of the obvious problems from 273.

I can see it is a Beta and may have some bugs and probably needs fixing. I do not even mind helping out with Beta fixes. But do not give me the 273 problems that you have not tried to fix.

Anyway, more information please.


Hello Trevor,

It’s still separate app, the cake is still under “baking” progress.

1 Like


It’s only a optimization for the IPD’s guidance image.
It was a description mistake made by the team.


So, to confirm, this doesn’t fix the issue with SteamVR where it cannot detect the headset until I reinstall PiTool, correct? If that’s the case, I’m going to skip this version.


What about the bad firmware that 273 was pushing? Are they still having problems with detailed released notes?


I don’t know what they did with this 274 beta but it finally works with mine.

  1. Upon new pitool 274 installation and launch, automatic firmware update process made my 8KX brick.

  2. I gave it another life with DFU upgrade with the latest firmware m299.

  3. Surprisingly everything works perfectly since pitool 270. What a nice Christmas gift.

Oh No… After PC reboot I am getting the same Steam VR addon block error again. Going back to my old friend v270…


Good evening, I own an RTX 3090 Founders Edition and a Pimax 8KX, I downloaded and installed the new Pitool 274 Beta and finally everything works perfectly. Really nice Christmas gift


So, I tried. Unfortunately installation of …2.274beta STILL with buggy firmware.
Need to manually update the firmware to 299 with DFU.
After that, Whirligig and Large FoV Native resolution 90Hz worked well. 非常感谢!


fw299 90hz works with old Nvidia,
but the new Brainwarb is not konstant,
i have sometimes judder.
I will the old FW back,
75hz suffices.
With the Old Brainwarb i have the self Quality how the Hp Reverb G2,
but with many more Field of View.
Please i need Old FW with old Brainwarb.


Because the software is mostly beta versions, there are usually some issues with each version. Pimax needs a download area with the various versions of PiTool and the FW all in one place.

Here’s a (personal OneDrive) link to an earlier 8KX FW which worked well for me (and supports 90Hz): Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

You need to use DFU to manually flash your headset. Here are some instructions: Firmware Related : Pimax Support


You could rewrite that as “because Pimax are crazy, fly by the seat of your pants mofos, there are usually some issues with the various versions of Pitool and Firmware”. Lol.


@PimaxQuorra Do you have any idea when they are going to release a Pitool version that does not flash the wrong firmware?


And even better. Backs up current firmware and allow roll back within pitool.


@PimaxQuorra: Unfortunately, this PiTool version does not fix this issue I’m having with SteamVR not being able to detect the Pimax headset (sometimes). I can still fix the issue by reenabling the headset in SteamVR, after reinstalling PiTool (any version).

I sent you a log a while back. Has the team made any progress towards fixing this annoying issue?


Yup. Same issue here. Had to roll back 273 and now 274 otherwise SteamVR goes FUBAR.
Went back to 271.


I just retried PiTool 271 and 270. Both report “Disconnected Diagnose10600” and cannot find my headset, so I went back to 274.

It’s a pain to keep reinstalling PiTool 274 (or 272), so that SteamVR can find the headset, but at least it’s functional.