PiTool .245 FW255 Discussion/Questions/Features/Bugs/Etc

Just wanted to start a general discussion thread for the December 2019 update to PiTool and corresponding firmware updates since the announcement thread ( https://community.openmr.ai/t/pitool-1-0-1-245-fw-255-dec-18-2019/24499 ) is locked.

I’ll start it with these two questions:

  1. The release notes say this “This version temporarily disables Backlight brightness adjustment” without specifying which brightness level the HMD will default to after the update. (I’ve generally found I prefer the bright setting thus far.)

  2. Rolling back the PiTool itself is pretty straight-forward. Can I also roll-back the firmware in the HMD, or like (far too many) firmware updates will I be locked into the most-recent firmware if I do the update?


You can always roll back firmware using the DFU tool, follow swevivers pimax for dummys guide. It’s a bit of the pain to put the pimax itself in DFU mode (i had to have my girlfriend help me with the power cable, i couldnt do it with just two hands lol), but its nothing to be afraid of. Firmware p2.dfu files are located with their corresponding pitool if you decide to downgrade.


Moved your topic to Pitool\Discussion


Does the FW work with 5K+ SN 204 headsets ?

No reason it shouldn’t that I am aware of. FW with exception of P1:Series headsets(P4k/B1…) Should be in theory good on any P2:Series Headset.

Some users like @hooligander have experienced an issue with firmware updating that seems to be related to Windows DFU driver(?).

1 Like

Thanks for the response. FYI, just found this:


He states that FW 255 bricks the 5K+ headset SN 204. “Blocked on Diagnose 10600”. So, no compatibility to 5K+ SN 204? I’m really hesitant to risk it. I’ll turn from a fan into a hater if this bricks my 5K+ just like the last one.

Can you or anyone specifically confirm that 255 works with 5K+ SN 204 headsets please?

P.S. Last FW Update I repeated the process 3 times, re-downloading a fresh 248 each time, and went back and remained with 244 eventually. 248 would reliably brick my headset each try.

1 Like

@hooligander & @drowhunter(?) Had a brick issue seemingly related to Windows new DFU driver.

Hooligander had a support session & upgraded firmware.


Okay I’ll give it a try. :pray:

1 Like

The new PiTool 245 does not recognize the headset being connected to DP. As a result, I cannot even get to the FW update process.

1 Like

Ya if it breaks/bricks just reflash it on another machine. I’d do it again knowing this now haha.


Try running DFU tool manually as per @SweViver tutorial video.

Latest Pitool does not work with my SN 204 headset but I have no idea if it is because mine is SN 204. However the Latest firmware does work on my SN 204 headset with Pitool 197. It is only Pitool 245 that will not connect to my headset on either a 5700XT or a GTX 1060.


I did, used DfuSeCommand.exe with 255. I does NOT work. My headset is bricked, red light only.

255 is incompatible to SN 204 headsets.

Again. Just like 248. Just like for @virtualboy72 , like @Virtual, the only other guys who have tried this with a 5K+ SN 204 yet.

This is incredible. If this was not so sad I’d be laughing. How am I even having the 8KX ordered???

P.S. What to do? Delete the damn new PiTool and 255 from the Forums until you can release a fixed version that works for people. There is no place for it here. It’s not even Beta, it bricks headsets. I know it’s not your fault personally, but this thing has to go just like 248, that’s the responsible action.

You might have the same issue as @hooligander. He has posted what support did. Try & reproduce steps he posted. As I recall it involved only having Usb & power hooked up.

Hooligander was your headset serial 204?


I do not even have the Guillemot Controller… if this thing busts my new Surface’s only USB port trying this…

I think you might have missed my edit to my post. I have been able to install 255 to my SN 204 headset and it even works on an Nvidia fitted PC with Pitool 197 but it will not connect to Pitool 245 on either machine. Nothing I have tried has been successful in getting my headset to connect to my 5700XT PC.

1 Like

A firmware update shouldn’t harm the surface. It should either update the headset firmware or not.

1 Like

I did the dfu update already and the bash threw out success. That wasn’t the point. PiTool doesn’t recognize the headset.

I’ll try PT 197 now while keeping R255.

1 Like

Hopefully they can get a tech to setup a skype Teamviewer session soon with you. Will see if I can get this bumped for you.

Maybe need to bump the 5700xt user on getting more info that has it working.

Jo might be an idea to fill out a Report Bug in Other Topic there. Leave blank things not needed as this pitool install issue. Ie Steamvr version. Etc…