PiTool Discussion

Topic to discuss this Pitool Version




Who is embarking on a test!!! with the problems that I encountered during the last update, I am a little cold
Are these versions optimized for 5k+? I have doubts


Given most of the hassles lately seem to be felt by 8KX, it sometimes doesn’t seem optimized for them either. :smiley:


I’ve installed it, but haven’t really tested it yet. I’ve had connection issues with PiTool 274, so I’m hoping to have a better experience with 275. Previously (v. 274), I had to reinstall before every play session, so that SteamVR could find the headset.

Also with 274, PiTool didn’t show that the base station had connected, even though it had. Version 275 seems to have fixed that problem (which is the only test I did: Did PiTool find my 8KX?).


I dont really understand the amount of problems you guys have with pitool , 275, 274 or whatever version.

I have no problems at all with any of the latest pitool versions, neither on my 8kx nor on my old 5k+, maybe 273 give you less GPU usage and worse performace than previous versions or 274/275 that
BTW runs perfect…

Always uninstall , restart computer , delete files on c:program files , and on c/user/appdata on all folders …

Restart,. Install , restart…play …no problems.

90hz on a 2080ti since they said It was going to work on a 2080ti.

Honestly i can not replicate most of your problems , and with me tons of.people that never write a word when they dont have problems.

Nice work pimax!!


Good for you. The thing is, every PC has a unique Windows environment, which affects running programs. Even if 2 people are running the exact same hardware (motherboard, CPU, and graphics card), installed software, driver versions, app versions, peripherals, BIOS settings, etc. will vary, which leads to inconsistent behavior. Considering that hardware usually differs too, it’s no surprise people have different experiences.

For whatever reason, SteamVR can’t seem to detect my 8KX on a consistent basis. I’ve found a simple solution: I always reinstall PiTool before a play session. Since I started doing that, I haven’t had any problems with SteamVR detecting my headset. I’m a programmer and to me, it seems like there’s a PiTool setting or state somewhere which is set differently when the app is installed vs when it’s shut down.

Note that I only use VR once or twice a week, so I normally keep my headset disconnected from the PC. Why? When I boot my PC with the headset connected, the USB keyboard is not detected. I get a warning from the BIOS, even though (later) the keyboard works fine, and I can use it to log into Windows. It’s clear my PC setup differs from yours.


I did an uninstall and cleaned my appdata areas, before installing 275 (again). I still have the problem with SteamVR not detecting my headset. A reinstall (before each VR session) does fix the problem (temporarily).


Do we still have booth 75Hz and 90Hz with this potool/firmware?


What might be helpful is to post your system details:

CPU: Model and if Over clocked.
Motherboard: Model & Bios Version.
Windows Version with last update.
GPU: Vendor and Driver Version.
Power Supply: Model.

As @neal_white_iii said there are a very broad number of configurations with different chipsets unlike a gaming console it is often harder to develop for pcs. Every problem reported has merit.

Sometimes a hardware and/or software mix cab create a variety of problems. That can also include OS, Steam etc… Can break things.

Which is why it is important for pimax to expand testing methodology like there planning with Pitool with a user group. Which will be important to ensure a wide variety of configurations vs how the m1 test group was during the Kickstarter(only Nvidia GPUs).


Yes, the 8KX is supported in both modes.


Just out of curiosity, what motherboard do you have? Sounds like one of the old MSI usb issues…


It’s an ASUS TUF Z390-Plus Gaming (Wi-Fi) LGA 1151.


I would like to install this, but past experience suggests that the old adage ‘if it works, don’t fix it’ applies here even more so than usual. So, I couple quick questions before I make the leap:

  1. Will this automatically flash my 8K-X even though I don’t want it to? Flashing should always require manual confirmation. I had to download a special firmware version and manually flash my HDM to get it to work properly at 90hz. Under no circumstances do I want my HMD flashed automagically, because far and away the most likely outcome of that scenario is my 90hz not working again.

  2. I see reference to the ‘updates to the labels’ on the compulsive smooth features. along with bug fixes. Can anyone confirm that this will allow 1/2 frame-rate without enabling 1/3 frame-rate, as that’s my single biggest issue with 254? (My fps will tank to 1/3 mode when it’s absolutely, completely, and utterly unnecessary to do so, and I find 1/3 mode to be unacceptable. Therefore I cannot turn smoothing on at all. I must always run with it off.)


I installed 275 last night and have been using it today. I’ve had no problems at all. Everything seems to be working fine. My firmware is on 299 and installing 275 did not update it.

I did have problems with 274 where I was getting intermittent BSODs especially when playing After the Fall. Reverting to 273 eliminated the BSODs, and I verified that with a week of usage.

I’ve been playing After the Fall on 275 today with no BSODs yet. Not definitive until I have more fly time on it. But 274 would typically have had a BSOD at least once or twice by now.


You contradict yourself in the last sentences of paragraph 2 and 3. Perhaps in the last paragraph you meant 274?


You are correct. Thank you. I have edited that post.


This version does not work on my system either. the same steamvr addon-block error while everything works fine within PE menus until I start SteamVR.

Pitools ver. and firmware P2_8KX_M298_EngineerTest.dfu are only working version for me,

Ryzen 5900x
Asrock B550 Taichi
Palit 3080ti
Samsung 32g ram
Windows 10 the latest ver.
Micronix 1050w gold power


Our systems are pretty similar in terms of hardware and yet 275 works fine for me:

Ryzen 5900x
Asrock X570 Taichi
Gigabyte 3080 Ti
32GB ram
Windows 10

1 Like

I notice that you’re only running 16g of ram: imho, 16g of ram is not enough to run your OS properly (without constant hd caching). If you can, up your memory to 32g and see if that fixes your issues.

Interesting. I’ve heard of Asus usb issues but that’s the first actual incident that I’ve come across. Have you tried running one of the addon pcie usb cards?

The reason I ask is that I have confirmed that the OS is not detecting the headset thru the video card, it’s seeing it thru the usb ports. I recently did a rebuild/upgrade and had my 8k detected while my video card did not see it. I had to play whack-a-mole on my card ports (I had to do this originally, when I first got my card, as well, I just forgot to label which ports worked this time) to get a display, but Pitools saw it just fine without it. (rtx2080ti)
If you haven’t tried an addon usb card, at about $20, it might be worth a shot…


Thanks for the tip. but it was typo. I have altually been using 32gb of ram.