Piplay won't find my Pimax4k

Hey everyone,
my Piplay won’t find my Pimax4k. It just stays in the mode “Searching device…” but it won’t find anything.
I tried 4 different piplay versions (including Version 1.1.92 ) nothing worked.
I completly wiped my pc and reinstalled win10 + all software needed but still nothing worked.
I even reinstalled several different graphics driver versions.
The computer makes a sound when i plug the usb in and the green light of the pimax stays on but the screen stays dark, not even the backlight is running.
Motherboard: Asus Rampage 4 Formula, CPU: i7 4930k, GPU: gtx 780ti, RAM: 16GB
Thanks for your help

Did you just install either the Creator’s Update, or Oculus 1.14? I did both yesterday and I am having the same problem.

Nope, i’m back to a clean installation of windows now…still nothing. Green led always on but black display and no connection to piplay.

Hi, did you both insert HDMI cable of headset and PC monitor cable into GTX 780ti? Did you use USB hub or adaptor?

Please add our skype: support@pimaxvr.com.

Hey,
the HDMI of the Headset goes directly into the gtx 780ti aswell as my monitor which is connected via DVI.
The USB of the Headset is also directly plugged into the motherboard.
I’m not using any adapter but i’m going to test a Displayport to HDMI adapter next…and i just tested the hdmi of the gtx 780 ti with another monitor and it just works fine…

I maybe found out something interesting.
If the Headset is connected to the pc and turned off, it shows as disconnected in the oculus configuration Utility. But when i switch the headset on and the green light comes on, it shows as “powered off” in the oculus software. Maybe the Headset signals that it’s turned off when the Hardware is turned on and it signals that it’s on…when in fact the hardware is off.

I fixed mine by doing a clean install, wiping everything, rebooting, reinstalling. Then I switched between extend and Pimax modes and it worked.

Well…i allready did that. Right now i have a clean installation of windows 10 with steam, piplay, chrome and some software (java, flash) installed.
But there is no way for me to siwtch between extend mode and pimax mode because piplay won’t even find my pimax4k…what actually is the point of this Forum post… ;D
Or am i missing something?!?! Can you tell me how to witch modes without a conection to piplay?

with what version of Piplay ?

I was on the latest version, but I prefer 1.1.92 so I went back to it but it wouldn’t work, until I did a clean install. Now on 1.1.92 and all is good again.

for me i have the same problem wih the 1.1.92, the only version who works for me is the 1.2.53

well i wait thecnical support of Pimax on skyp but no respons from 3 days.

i don’t knwo what i do now.

i FOund this page :

http://translate.google.com/translate?sl=zh-CN&tl=en&u=http%3A%2F%2Fbbs.pimaxvr.com%2Fread.php%3Ftid%3D811%26fid%3D8%26page%3D1

with some iformation like :

  1. Piplay has been searching for the device
    Cause : No USB or HDMI signal detected or other software has caused the piplay driver to fail
    Solution : 1. Check if HDMI and USB are connected to the computer at the same time
  2. Check
    whether HDMI is connected to the computer’s discrete graphics, the
    monitor is also connected to a separate graphics card (if the computer
    graphics card is only one HDMI port, then the monitor can be connected
    to the DP or DVI port. Desktop computer to ensure that the integrated
    graphics do not work and Not connected to any other display device)

Check whether the installation of Piplay in the process of anti-virus
software to open, the current anti-virus software will be mistakenly
killed Piplay can not connect, please turn off anti-virus software to
reinstall Piplay
4. Check the “Task Manager” → “Service” → “PiserviceLauncher” is running, you can restart the service
5. Check that the USB driver is working properly and that there is no device installed in the device manager. Install the USB generic driver try, download the link: http://pan.baidu.com/s/1miFat8O
6. Update the latest graphics driver
7.
Check whether the installation of OC drive, if installed, you can
uninstall the OC runtime and then re-plug the small USB to see if the
normal connection
8. The lower right corner of the small icon to switch the mode to small mode to see if it is normal

Well…nothing of that works for me…
Thanks anyway…someone else got any ideas or help?

Hello,
what driver do u use :slight_smile:
i think u have to try all piplay version to found one Working

or wait Pimax technical support to found what is the problem with u config

sorry

Try to remove some suspicious software that might be able to interrupt Pimax signal. I did install a program that I found it was later after uninstalled many others . Trying to remove all version of java and reinstall again might also help. The only version works for me is 1.1.92. Good luck and know well how you feel.

Thanks for your help…i sort of allready followed your advice. As i mentioned earlier I reinstalled windows and only drivers + pimax software 1.1.92 abd still no connection.
No other programm was installed not even a anti virus software…

Is there any downloadlink for the firmware and is there any way to update/refresh the firmware of the pimax4k?
Maybe that’ll help…

Did you ever try with another PC, that might validate your headset if it’s still ok! I did once and found out that one of my DP port to HDMI is out of order.

Well…the HMD is fresh out of the Box. But i tested the HDMI of my gtx 780ti with another monitor and everything worked fine,so no problem there. Can’t really check if the HMD is damaged on another computer but for such a pricy item i would expect that they get tested at least once before beeing shipped out.
Thanks anyway ;D

Hi Heyho

I was running version 1.2.75 which install and fired up no bother but I had SDE which I was not expecting. I looked this up and others was saying 1.1.92 had better resolution, so I tried 1.1.92 and I got the same problem, constantly searching for the headset. I realised I had not turned off the antiviral ( which I didn’t do for 1.2.75 and that worked ok ).

I turned off the antivirus and did a fresh install and it worked.

SDE was no better on 1.1.92 ( don’t know if there’s something I’m missing ) so went back to 1.2.75

Hope this helps someone

Well I was using Piplay 1.2.75 and after updating Windows to Creators, started having problems. So I decided to completely uninstall ALL Pimax software including shutting down everything Pimax including Task Manager and all stuff in directories.

I then turned off the pc, unplugged Pimax restarted the pc and installed Piplay1.1.92 to see if was any better than 1.2.75.
After the install, I plagged Pimax in again and everything worked as it should.

I ran Elite Dangerous to compare the video quality and also a few 360 Videos and video quality was pretty good as I remembered for 1.1.92, but in my opinion the ghosting was worse than 1.2.75.

Now having nothing to lose, I decided to uninstall 1.1.92 with the same procedure as above and install Pimax latest release 1.2.85, same version as for Nolo.

Again after the install everything worked as it should, however this version of Piplay is the best so far and in my opinion has the best quality video with the least ghosting so far.

The install also automatically updated the firmware in the headset. In fact when I plugged Pimax into the PC this time I thought something had gone wrong because the LED on the HMD was flashing all colours very quickly and Piplay was searching for the hmd, but this only lasted several seconds and then Piplay found the HMD it all worked as it should but with new firmware now version 1.0.0.265.

This must be what was happening when the LED was flashing.

Nowt apart from a consistent bug in Piplay that makes it lose it’s downloaded library content, everything works very well so far and so I am happy and will be sticking with this version.

I don’t see any point in going back to a lesser in my opinion 1.1.92 again.

I doubt very much that Pimax will be having a parallel development for the current and past versions of Piplay just to please a few. I certainly wouldn’t if I was the head of Pimax.