Pimax4k stuck in video mode?

Greetings 4k users.
I have an interesting issue that I can’t seem to get around. When I connect my 4k HMD, PiPlay (or the new one), sees the USB and HDMI as connected, but wont show the device farther than that. AS in, it will not allow me to change from video mode to PiMax(direct) mode, because it is not fully identified, so I don’t get the option to switch because PimAx can’t “see” it properly.

I had this happen once before, and disconnecting it for an hour, correct it, or got it out of its fit…
That isnt working this time.

To try and kick it into gear, I ran thru the complete reset (all 3 buttons, then leave off power, then vol down, etc). Getting it into firmware mode, but I cant recall if there is another way to re-set it.

I am getting the same behavior on two separate computers…so its something with the HMD being stuck, and not software. I have tried 3 different versions of PiMax and PiPlay on both machines, with the same results and no change.

Any suggestion to re-set the HMD?

The last time I used the HMD, it was working just fine, and I was racing in RF2 with no issues, so this is really weird. I don’t keep the device connected all the time, but have had weird issues with it getting stuck in certain modes before. All of which I have been able to recover from.

Any suggestions are welcomes. Also, I ran thru all the relevant things I found on the fourm, but its still not properly identified like it used to be. I am sure its something simple, but I cant seem to get it going.

In device manager, it shows as a generic plug-n-play screen, and I am almost sure it used to show as a RIFT… I can install Oculus home, but dont want to just to trick a driver.


1 Like

You may need to file a ticket. I will check and see if we have a p4k post with Firmware. Reflashing the firmware may work.

I beleive newest firmware was 265 for the 4k.


Thanks for the quick reply.
I hesitate to upgrade the firmware when software (or firmware) has not changed since last week when it worked. However, I am not opposed, but…

I’ll keep an eye out, and thanks you. Always great support.

I’ll give that a try as soon as I exhaust all other “messing around” with it :slight_smile:
Thanks so much.

as always, ill report back once I have it squared away.

1 Like

Here is a topic with the 265 firmware


Yes does seem odd. But a reflash will likely resolve it. If not support can fix.

Awesome, I will give the firmware a shot today, and again, thank you for the very quick reply and assistance!

You must know how much I want my PiMax back!! :slight_smile:

1 Like

Looks like the links in that article are dead, but I will search out the correct location to grab the 265 firmware and go from there, no problem (just wanted you to know)

Indeed still have my old 4k around; more for Nostalgia now though.

I would reccommend the Artisan as a worthy upgrade that isn’t too hard on the pocket.

Would love to find some new screens to try out with the 4k lenses and such.

The ole’ 4k has worked well for years now, I dont wanna see her go. I’ll get her goin, eventually.

1 Like

Okay maybe @Century can help out with 4k firmware 265

Once I have a copy of it will get it added to pitool download links.

1 Like

I am scouring, but not finding one at this time.

If anyone has the 1.x.x.265.dfu firmware version available (For the (P1) Pimax 4k) , or a link to DLing it, please let me know.
Thanks for a great support community!

Hopefully I can get to this today sometime.

( and I apologize, I didn’t see your reply above before I posted!!! )

Yes, I have this firmware :wink: :beers:

1 Like

Got it and thank you. I will give her a try as soon as I am able.

Thanks again to all!! Great community.


Bad news…
I am already at .265 firmware… .265 (Picture link)

I also posted a video of what it is doing (since I am already at 265). Check it out and see what anyone thinks? Cycling mode (Video Link)

Thanks for your suggestions and support.

1 Like

Did you try reflashing 265? If so file a support ticket.

Will do, and thank you!

1 Like

Reporting back, it seems I neglected a very key feature:
As it turns out, I failed to state that I recently upgraded my video card from an RX 480X (8g), to an RX 5700 XT MECH OC (hoping that the PiMax would SHINE better than ever before)

For the fun of it, I went back and removed the 5700 and installed the 480X, and dropped back to AMD driver ver 20.2.1 (I know it worked well with the 480x-as well as this was the config I had last week when the HMD worked), and the HMD worked instantly, like magic. :slight_smile:
I then upgraded the gfx driver back to 20.2.2, and it stopped working again.

With all that, I now know it is a hardware and/or video driver version issue. None of which is a PiMax issue.

Now that I am satisfied, I can at least stop thinking about it because I was able to prove my theory.
When I attempt a new gfx driver versions for the 5700 when available, I will try the PiMax again. Heck, I could get lucky and all will start working on the NEW card.

Who would think a hardware upgrade, would keep my HMD from working… I am just not willing to go back to an old card, to use my beloved PiMax 4k. :slight_smile:
Thanks again for all the support. Problem “solved” in theory.

(and the cycling I reported previously, occurred on another computer, which is blocking the PiService (a GPO’ed work computer). Hence the connecting and re-connecting, the service was cycling due to lack of permissions.

1 Like

@Alex.liu can you have the team look into the p4k/B1 firmware to see about updating it for the Amd 5700 cards?

If pimax is still moving forward with Opensource @PimaxVR should maybe consider Opensourcing the p1 series firmware.

I realize that I am working with a P4k series that is likely very close to EOL (or already there), so there are no expectations on this end. If it ever becomes an option to include the 5700 series, I will welcome it with open arms, but I understand there is likely a small benefit small benefit pool.

No hard feeling either way, this community has always been great.

1 Like