Pimax4k stuck in video mode?

It would be nice if it would at least work with the old PiPlay

The p4k will work with the old piplays. I believe @enopho still uses piplay.

Gpu wise it will be firmware related as the 4k at one point needed a specialized firmware for Vega cards.

I still get the blanked out peripherals in PiPlay as well, and Steam VR shows headset not detected on PiPlay and Pitool. :persevere: :disappointed:

Then Firmware likely needs a new version as Newer gpu driver structure maybe causing issues.


I’ll be watching this thread…just in case the firmware gets updated, or the 4k goes open source.
I would love to see the 4k working with the 5700XT, I am certain it would be glorious :slight_smile:

1 Like


You tried the version 20.2.1 on 5700X? Its a driver problem or vga card compatibility problem?

I’m back! I managed to make my Pimax 4k work with my RX5600XT with the latest Pitool software, not the old Piplay 3.0

Need some adjustments and the resolution is stuck on 1440 (too high for this card on DCS), but now, I known its work with latest AMD cards.

1 Like

I tried my P4K with the new software and I still get the grayed out blinders… :roll_eyes: :roll_eyes: :exploding_head: :exploding_head:

From what the PiMax folks said, it is a compatibility issue. It might go open source at some point, or they may update firmware to properly identify the new hardware (5700xt), but as it is older hardware, I am sure it is not a priority, and I understand that.
No worries either way, but with their confirmation, I stopped trying to find the perfect combo. For me, it was more “wonder of this works with the new hardware”, and it does not seem as it does, so I moved on.
:slight_smile:Be well!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.