Pimax Pitool software not functioning. I need vc.zip

Pimax diagnose told me that i need to install VC repair. How can i install it, if i cant download it?
Somebody have this file?

Welcome to the forum!
You need Microsoft VC Redistributable ?


1 Like

Your link is dead too.
But i have this installed.
PiTool diagnose cant see KB3033929 and KB2670838 that i have actually installed, and it cant see usb 3.0. How to make it works?

What is the problem exactly, headset not detected?
System specs?

Had the same issue a week ago.

I uninstalled Pitool / deleted all pimax folders and reinstalled pausing antivirus.

Now nothing missing.

1 Like

Everything is starting ok. Headset conected, tracked. But when i start games/ steamVR, steam says to move my headset to wake it up. On headset i can see only Pi sybol and stars. Nothing is moving.
Strange thing that i see Pimax USB plug looks like 2.0. Only 4 pins inside.
Bez tytułu

Pimax 8K
Vive base stations
Asus geforce 2060Super gaming 8gb
Ryzen 7 3700x
32GB 3200mhz
msi b450 a-pro max

Ive got both KB installed by DISM, because automatic install not worked.And Visual C++ says its the nevest.

@Heliosurge do you remember if win7 is supported?

1 Like

Win7 has had mixed results. Was said before to be supported.

You may need a different vis c install. Did you try clicking on vc repair in pitool diagnosed?

I think another user installed pitool 144 than installed latest.

I dont know from where i can download other versions of pitool. All sites are dead. Clicking in vc repair ending on dead site as i said.
I wrote to support and now i have file from them. I’ll try to install it now.
I bought this pimax yesterday as used, so i dont know if its 100% works. Today i try to go to friend and test it on other pc.

1 Like


1 Like

Just tell me, is this link works? Maybe my internet cant connect…

You want this topic there



After i installed VC from support, diagnose said it pass. But still steam says the headset is in standby mode and i need to move them.

Now after i installed 144, steamVR works, bluetooth not working with pimax (with Vive works)
Base stations connected. I cant pair controllers on pitool, because it says instantly “not found”. On steam vr bluetooth is not detected.
GPU graph says 10.5 of 15,6ms , but i see slideshow.
USB 3.0 still says its not detected. Both KB patch same, not detected.

You will need to turn off power saving in steamvr. Pimax hradset doesn’t have a bluetooth for lighthouses.

Have you ran room setup in pitool? You also pair controllers in pitool

I may loose connection as am travelling

Thanks for all reply.
I turned off power saving. Bluetooth works now, and i paired controllers by PiTool.
Now the last problem is that i can see only slideshow.
Next ill try 212 PiTool. And maybe next other versions. If slideshow wont stop idk what to do then.

1 Like

Nvidia drivers up to date?

1 Like

nvidia drivers are new.
After testing all versions i can say only 144 and older can wake up headset, but i see slideshow.
Newer versions cant wake up headset.
New versions connecting with headset without any problems. 144 and older connects only once after restart windows.

Game says its on 11FPS, but in GPU graph was as i said 10.5 of 15.6ms.
Everything on pc slows down. Every animations on desktop looks like in headset. Same FPS.


Open a support ticket, maybe @Doman.Chen can help you

1 Like

Ok. I’ll try.

One more thing that is strange. Pimax VR home works same like all apps on steam VR looks like 5FPS.
Other thing i saw that is when i open beat saber, i can see in my monitor on beat saber window that is more FPS than on steamVR viev from headset. That is strange too.

Is my graphic card to slow to work with pimax?

I dont tested it on other pc yet. Maybe tommorow.