Pimax 5k+ framedrops/stutter regardless of settings and version. About to give up

Hi guys!

My system:
Asus z270E Gaming MB 1302 bios
Corsair dominator 32gb @2800ghz 15CL
Asus Strix 1080 TI @2000 Nvidia 411.66 and a whole range up and down.
I7700K @5ghz
Windows 10 1909

Im about to give up on ever getting a stable frame rate on my 5k+ Its always dropping or gaining 2fps 64 62, 70 72, 88 90 and so on, not all the time but enough so its a real nuisance. Steam VR SS settings has no effect on it I have tried with 0 overclocking and full OC and there’s no difference. Fresh install of windows 10 has no effect. Tried all FOV’s. I have never had any issues with Rift, Vive, Odyssey

I have tried pitool 144 180 197 249. Some are worse, some better but none clears it
180 with pitool app off, no change.

At this point i dont know what else to try.


There could be many causes

Any thing that might be causing it from that point?
Depending on the game my 2080TI is also quite busy… but with latest PiTool, the 12288 value most games run good → smart smoothing and FFR might help also

Edit Update use 16384 to be 8k X safe


There’s also been reports that PiTool itself can cause stuttering. There’s no need to run it while a game is running (since the driver actually handles the headset). Try quitting PiTool (or don’t run it at all, if the settings don’t need to be changed).


Thanks for the reply but sadly ive already ruled out just about everything listed above. It does not care if Steam SS is on 20% or 70% and gpu use is 20% or 70% Its going to frame drop the same way on all my sims. Mainly Iracing Assetto corsa, Rfactor and a host of others. Everything is also on SSD. The smart smoothing ghosting is so terrible its not usable for racing. Hopefully they will sort this out to something with less artifacts real soon. If it happened on my other hmd’s (i dont have them anymore) id say it was a HW issue but i have no issues there so its hard to say.

No clue what resolution 12288 is or where you are supposed to set it? Sounds massive? I highly doubt it will make any difference though due to the reasons mentioned but everything i worth a try

As for pitool itself being the culprit i mentioned that ive tried that in the org post. Does not make any difference

It does feel like its mostly where there’s a lot of geometry but at the same time its quite random which also makes it hard to say why or what

1 Like

For iracing I have found that all the versions newer than 144 are a little jittery. For that particular app smart smoothing is a big help and make sure SPS is checked in the iracing in game graphics options. I have a 2080ti with pretty high in game graphics options, and my settings are pretty stable on normal FOV. Not sure if you use a GPU overclock app, but having one and allowing for maximum power is also another thing that seems to help. There is a thread in the iracing forums called the vr bible which also has some pretty helpful tips for settings in nvidia control panel, as well as I game options and how they individually effect performance.


here are all the settings I use. Steam vr set to 88%


I had no stutter beyond what would expect from a sim like DCS in games but terrible flickering of many game loading screens.
When I went from PT 180 to 245 I did a clean install deleting all Pimax folders in program files and (all 3) Pimax folders in the appdata subfolders. reboot pc
The flicker stopped in most game menus and reduced in others.
My games run within expected parameters. I run PT 1 Normal fov, No Smart Smoothing, Mask ON, 75Hz, PP as needed.
I only run PT for Oculus games and to turn on PP. Otherwise, I just launch Steam.

I5 6600@ 4.5, Gigabyte GA170XP mobo, MSI GTX 1080TI Gaming X, 16 gog Corsair Vengeance 3200 DDR, 4 ssd, Pimax 5K +, Oculus Rift, HTC Vive.


I have terrible flickering on my hands/controllers, never had that before

If You have installed ASUS Aura, uninstall it… It seems to poll the USB bus heavily which causes something that sounds like Your issue… :wink:


So ive heard ye. Afraid its not that either but thanks for the tip. I have only the absolutely necessary running on the comp and its debloated etc. Its really annoying the crap out of me tbh as ive fiddled with this thing for 3 months off and on with the different Pitools and tried every tip and possible setting however unlikely out there. Its just aint happening.


That is a tweak for SteamVR to reduce blurriness, mostly when running with PP on. It’s not related to your stutter problem, but you can search the forum for “maxRecommendedResolution” for more info.

I mostly play Elite Dangerous on my 8K, but I do play Assetto Corsa, and I’ve not seen any stuttering, but the reported complaints mostly seem to involve the 5K+. Oddly, my current framerate in ED is only ~60 fps according to fpsVR, while my refresh rate is 80 Hz, but my in-game experience is very smooth. I have an i7-8700K, 32 GB ram, and an RTX 2080. Like you, I have an ASUS motherboard: the TUF z390-Plus Gaming wi-fi model.

Honestly, the following is a list of long-shots, but you’ve ruled out most everything else.

Go to https://www.userbenchmark.com and download and run their free tool. It has been helpful to discover PC issues in the past (like mis-configured RAM).

In nVidia control panel, try setting Power Management Mode to Adaptive. Prefer Maximum Performance can cause framerate fluctuation, when thermal management kicks in.

Have you removed everything possible from your USB ports? It might even be worthwhile to unplug your steering wheel (just as a test). It’s possible there’s some sort of USB bus contention.

Try plugging your headset into different USB ports, sometimes these are shared internally, so some work better than others. This has been a particular problem for MSI motherboards.

In your racing game settings, try setting Performance to Max Frame Rate, as a test.

Try setting PiTool Render Quality to 0.75 or even 0.5. On my 8K, I’ve found that 0.75 with SteamVR at 100% yields the best clarity of text in Elite Dangerous.

In PiTool, turn on FFR with Conservative mode. That significantly improves my framerate in ED, even though I don’t leave it enabled due to shimmering at the edges of the view.


So that was the culprit!! For months I’ve been stressing my (insert body part of choice here) off because of the damn stuttering and how nothing I had tried could fix it. I just stopped the Asus “LightingService” and wouldn’t you know it, the headset now tracks smoother than a buttered ferret up a Teflon trouser leg!

Much relief.


That’ll do too… :wink: That’s also how I found out. Stopping unnecessary services/processes one by one… :+1:


Just don’t confuse this with the GPU utilization issue though please.

That problem remains, until we get the slider in the next PiTool version, as promised by Pimax.


Tried it every which way today and there’s no change so ive officially given up. As much as it hurts me ill probably just sell it at this point and go trough a new hassle of trying to get an Index to Norway.


Well they mentioned we’ll get a GPU utilization slider in the next PiTool, which will solve the problem.


my 5k+(serial 204) firmware 244 pitool 197
run at 120htz large fov and pitool 1 steamvr 130
but 100 its a little better 3092x2620

no problem +++


Still no change but i really don’t notice unless i drive a super fast down-force car. I just love the fov to much to sell this thing. Hopefully it will all work great when i upgrade my system when next gen comes.


Still got the issue even on the 255 Pitool. Its such an odd thing and im considering changing my motherboard to a different brand and see what happens.

Adding a video, maybe that helps to figure it out fps drops - YouTube

1 Like

Just looked at you video, it sort of “jitters” to me that does not look like framedrops.
Are you using lighthouse tracking or just the 5K+ the gyro ?

1 Like