Pimax 4K and Linux

Hey there,

I have recently installed Linux Mint because I don’t like Windows at all.
Before the installation I could test Mint from live CD. I was happy that my glasses worked like second monitor, so I could use them for watching movies (I don’t play games at all). But after the installation they stop works. It doesn’t recognize them. They light green. If I change drivers from Nvidia to the open source one - nouveau they start works again but my PC lags very hard with that drivers.
So, does anyone else have that kind of problem?

Can I use glasses as second monitor with the official Nvidia drivers?

1 Like

Hi not sure on this. As a fellow linux user; i haven’t tried my 4k on my linux install.

Pimax atm doesn’t have official support. I would however recommend trying Manjaro as it will be potenially more upto date than mint.

They have A few flavors for desktop. I myself use kde & deepin flavors.

The manjaro hardware installer works well & has a kernel installer for ease & latest use.

I’m using latest Nvidia drivers and if the problem is in them that means glasses won’t work on Manjaro as well?
Actually I know that Pimax doesn’t support Linux atm but I was hoping that I can use them as secont monitor atleast. : (

Not necessarily but maybe. With manjaro you can use a newer kernel than mint. A newer kernel may improve performance with nouveau & may allow the headset to work with propietary nvidia driver.

When you can post your system specs.

System specs:
CPU: Ryzen 5 1600x
GPU: Nvidia GTX 1060

I’m not sure that I want to do everything from beginning (install and set up a new OS) only to see that glasses doesn’t work again. I’m not sure but probably I have to write in Nvidia forum because this is probably more related with their drivers?

Also, I’m not Linux expert. Actually I’m beginner working with it. I thought there is some terminal command for detecting the glasses but nope :smiley:

1 Like

I used to use a variety of Ubuntu based distros like Mint.

The Kernel is the main part of an os & has hardware drivers baked.

But something that might work. Fire up your Windows Pc launch piplay connect headset & switch to Video Mode. Disconnect headset & try on your linux mint pc.

Reason I reccommend Manjaro is that its a rolling release & will often have newer updated linux libraries. manjaro’s hardware manager makes switching from opensource to restricted drivers a breeze & vice versa.

It might take me a day or 2. My one motherboard died that was running a Nvidia 760 (4gig) card. Be replacing mb sometime on the weekend & when have time will test pimax 4k on it with Nvidia Propietary driver.

Ok, I have installed Manjaro KDE. Actually I like it but it’s strange because I was using Debian destributions till now.
However, the glasses doesn’t work again. :smiley:

1 Like

Did upu try the nouveau driver and/or the wimdows to switch the headset ti video mode?

Manjaro will have a 2 settings mamagers. 1 will be normal stuff. The orher will have a Kernel manager.

Another trick may work if not tried is boot wirh headset already connected. I might have a manjaro pc setup sometime tomorrow to testvon my end. There forums is good to join as well as the community there is quite good.

Yes, the situation is same as Mint.
When I’m using the open source drivers the glasses works but my PC laggs. By lags I mean that animation are lagging, even sometimes GUI crashes.
And when I switch to Nvidia-390xx drivers, glasses just stop works. Its light green all the time.

I’m using the last kernel, the experimental one.

1 Like

I will test once i get my linux pc up n runing. I would reccommend joining the manjaro forum & post there lots of great folks there.


I registered in their forum and I’ll post a thread soon. :slight_smile:
I’m not sure that they could help because I still think it’s a driver problem - the nvidia drivers…

1 Like

Still having some issues to debug on the new mb (no post) working today so not sure if i will get time to revisit.

With the forums in manjaro there maybe a way to poke the headset for eid? Info & with some commandline stuff get it working & recognised as a reg display with proprietary driver or setup nouveau driver for better perf.

Hey there,
is there any progress about this issue?

Finally got my linux machine running. When I get up will see if I can get the headset to connect in Vid mode. But truthfully probably going to have the same results.

There was a project using a Raspberry Pi that had the headset working in some form.

Here is the link that has thr raspberry pi project link. It might help but can’t say atm


I’ll install Win as a secondary OS at a pinch just for a watching movies and playing some games…

1 Like

I have tried p4k on nvidia driver with like yourself no luck.

Bino3d player can play sbs video & more. I would reccommend trying it.

But atm Windows is the better option for now. There are guides for optimising your windows settings for Gaming. With Dualbooting or having multiple pcs can work well. Multiple PCs is what I have & find it easiest way.

My Windows Machine is used for gaming only. I only use steam on it. All other internet use & such I do on my linux machine. I also run steam in linux (just not VR yet)

I’ll will install Windows very soon (I’m waiting my new SSD).
It would be only for Gaming and VR, Linux for everything else.

Thank you. :slight_smile:


Your welcome. I do long for day when Windows can be mostly put away. Lol

Steam for Linux, It looks like there was a big update recently.

1 Like

This look nice. I was reading an article about that but it was just a rumor and now it’s official. :smiley:
I’m waiting them now to enable games that I play like Path of Exile, PUBG, etc. :smiley:

1 Like