Newly arrived 8kx does not work, really frustrated (Solved, working with his RTX)

I just received my new 8kx. Unfortunately, it does not work. Reporting DP unconnected (code 10936) no matter what… Googled it a lot and found that it may be caused by the crippled firmware (V. which the new headset shipped with.
So I thought I will try to roll back to the previous firmware, but where I can find them?, and how can I roll back the firmware? Many thanks! It is really driving me crazy…

Have you asked @PimaxQuorra ?

1 Like

Apparently your hmd is not compatible with non 2001 firmware.

What is your GPU?

1 Like

I’ve broken the headset when refreshing the firmware…
Now it is even not possible to connect via usb…
Is my headset totally dead? :face_exhaling:

Pimax headsets generally are not perm brickable.

Try filing a support ticket. Links below.

PimaxVR Support

Main Site
  • Self Help Database
  • Submit a Ticket
PimaxVR Forum Support

This group consists of PimaxVR Staff Specialists for assisting PimaxVR Consumers with resolving Ticket.

Please follow this Procedure before Requesting help.

  1. File a Support :tickets: At
  • PimaxVR
    You should receive a response within x Business days.
  1. If you have not received a response after x Business days or Support personnel is having difficulty understanding your request. Please Direct Message(PM) PISupport requesting assistance.
  • Please provide the following Information:
    Support Ticket # & Details of issue.

if your support issue is Tech related please explore:

  1. Use Docs in Left menu to explore 2 & 3.
  2. Pi-Guides & Troubleshooting. (#guides )
  3. Community Support - review Solved and post question if needed. (#vrcentral:helpme )

Thanks, I have filed a support ticket.
Is the DFUupgrade tool still work if the windows do not recognize USB connection?

1 Like

Here is my ticket with all informations you need. I had the same problem. Your headset has a special firmware and does not work with earlier normal firmwares.


Thank you, but I cannot open your ticket, could you please take a screenshot for me?
And, where I can download the firmware?

1 Like

8kx firmware


Oh, that is helpful. Thank you very much! is that possible to send me the 2001 firmware as I cannot find it anywhere… could you please upload the firmware or send it to my email:
Many thanks!!

1 Like

Email sent. :slight_smile: Good luck!


Received! I will have a try and upload the results here, thanks!


I successfully reflashed the firmware back to v2001, the headset is not bricked anymore. Thanks, trollTraktor!!
Although still no DP connection…Is that because I use a USB-C to DP converter (with laptop 3080)?


Quite possible as usb-c to DP can be finicky.

Is the usb-c port your using a Thunderbolt?

Maybe post your laptop model

Where possible best to use a DP on the laptop


The laptop model is lenovo legion R9000K (with 3080). I use the CableCreator usbc-to DP converter (No Thunderbolt), It works perfectly fine for my old 5k+ though, so I thought it should be ok for 8kx.
P.s.: I tried my old laptop with a built-in mini-DP port, but still the same problem. So I think it is not likely the converter problem.

1 Like

Okay not sure as it worked with the 5k+. Though the adapter might not support the higher Res of the 8kX.

Your old laptop what is the specs?

Support might be best as they can try a remote session to get more data and possibly resolve.

Not sure with 2001 FW. But with 298? There was a few different versions and iirc required Desktop as they were having some issues with laptop support in that version.

1 Like

My old laptop is legion Y740 with 2070 card. You mentioned FW298, is it compatible with my 8kx?

No only 2001 is compatible with these new 8kX revisions that ppl recently received.

Looks like I am out of luck…

Ok, What is ppl BTW?