Newly arrived 8kx does not work, really frustrated (Solved, working with his RTX)

My apologies. Ppl= people.

An issue you might be having with the Usb-c to DP is bandwidth limits as it is not a Thunderbolt usb-c. But honestly that is just a guess.

Hopefully Support or another user can help.

1 Like

Support seems to potentially have more than 1 version of 2001 FW so maybe they might have one that works.

Ok, thanks though, when I get contact from the tech support I will post feedbacks here.

1 Like

They have many 2001s? It looks a bit mess…


It is very likely that laptops don’t have native DP 1.4 connections (using USB-C or HDMI) and those that do often don’t support DSC. Those that can fully support DP1.4 often lose the capabilities when converted.

In addition to the issues above your error can be caused by your integrated graphics card being seen *before your discrete one. If your laptop has an actual toggle switch (recent laptops often do) you can use that to disable your integrated graphics. Otherwise you can look at your BIOS CMOS and see if you can disable it there.

Also you need to make sure your usb-c → DP1.4 converter converts both DSC and HDCP signals fully.

So to summarize to give it a try:

  1. disable your integrated graphics adapter
  2. get a high quality signal converter and use that, it can help in multiple ways
1 Like

Thanks for your reply.
But (1) The integrated graphics is already off by MUX switch.
(2) When I use mini-dp to DP , same issue remains.

Anyway, could you recommend a workable usbc to DP converter?

1 Like

I just looked at the specification for that Laptop (nice one by the way):
The usb-c on the right side will not work.
The usb-c on the left side will work.
The usb-c on the Back will work and looks like the intended one (best)

Page 3, 4,5 - PDF Page 9, 10, 11

Both are:
“DisplayPort 1.4. Supports a maximum output resolution of 5120 × 3200, frame rate of 60 Hz, and more Color depth 24 bpp (bits/pixels)”.

1 Like

Thanks for uploading the info :grinning:
Yes the back one is labeled as DisplayPort. It is the one that I used. But I tried all the three usbc but my 8kx works with none of them :face_exhaling:
Plus I tried with the miniDP port on another laptop (with a 2070 card), same issue there.
Plus all the two laptops and converts works perfectly with my 5k+

Conclusion: it is more likely a cable or a firmware issue

1 Like

Is this the one you are using:
I think that should be fine.

1 Like

Exactly. This is the one that I used. Thanks for uploading it (again)!

1 Like
There was no conclusion to that, so it could just be need reinstall of Pitool.

I use to get not connected error, or dis connected error, all the time.
Pull the power from HMD, and start again.

This normally works:

  • Wait for winDos to fully start,
  • Start pitool - wait,
  • Long press of power button on 8KX ( power on) wait.
  • Wait for TWO usb plug in sounds from winDos ( one on screen, one on HMD)
1 Like

This is like plug and prey :joy:
But I tried with those “standard solutions”, no luck there :face_exhaling:

With using a laptop are you using a powered usb hub? As you may need more power. The 5k+ had separate power adapter where as the 8kX uses usb power.

1 Like

This is a good point. I’ve tried all the 3 available usb 3 ports. One of them is labeled to charge external batteries so i suppose it should have enough power.

But is the power usb cord in the 8kx only transmit power and no data? If so, how about try a outlet usb of external power?

I don’t have one at hand, but will try later

1 Like

Yes the black usb2 plug is power only(thinner cable)

The Pimax support replied that the 8kx is only compatible with desktop PC…
Indeed, their website specs now are

Did they change something, I suppose the old batches support laptop?
Is there any workaround, or this is a hard request, so not compatible with any laptops no matter what? If that is the case I will have no other way but return it…damn

1 Like

I have some problem. anyone can send me firmware thanks (email

I have senttt to you

1 Like

Yep that is changed. Likely recently. The pre 2001 firmware models also support GTX 10series GPUs. A fellow had support tell him it doesn’t support them.

So whatever they changed messed up/limited compatibility it seems.

1 Like

Oh looks like I am fxxxed.
I have requested a change to a pre2001 model, not sure if they agree…