Need firmware 2.1.255.2001 for Pimax 8K X DMAS, serial number 2076*

I just got my Pimax 8K X, serial number 2076*. I believe this is the DMAS version.

I accidentally “bricked” it by installing PiTool beta 280, which auto updated the firmware the second I launched it, and then my headset did not work anymore (red light, display port cable unconnected). I have tried a number of firmware versions I found on various forums, but none have worked. I believe I need the 2.1.255.2001 firmware for the 8K X S/N 2076* model, see this thread.

The log files in AppData\Local\Pimax\runtime also show that the first firmware my headset had was “2.1.255.2001”.

I checked Playa’s repo and 2001 is not there.

Could someone kindly post a link to the 2.1.255.2001 firmware?

2 Likes

Please recheck serial. 200 is original 8k. Your serial for the 8kX (Revised)DMAS should be 2076*

Rechecked, sorry the serial number is 2076*. Updated the post.

1 Like

No worries. @PimaxQuorra @hammerhead_gal can you assist and provide firmware 2001 for @pimin314 & @Playa (so he can add 2001 to his data base) please.

2 Likes
2 Likes

Hello,

You might want to try this debugged version.

It’s compatibles with the SN2076 model.

Regards.

3 Likes

Bumped your user level up.

Thanks so much, that worked! I used the firmware provided by PimaxQuorra.

Since my headset was soft bricked, I had to use the special DFU mode to flash the firmware.

Once I reset the firmware to 2001, the Pimax 8K X DMAS was detected. I had to unplug and re-plugin the USBs, and wait a bit for it to be detected. I did a reboot to be safe too I think. I am using PiTool 277, the latest official release.

After this, PiTool was still giving me the “DP unconnected” error. I was using a gtx 1000 series card. The website says it requires RTX 2000 or higher, so I swapped to an RTX 3000 series card and boom, the display port connection was detected, and it worked! I was able to load up steam VR and play games.

Thanks so much for the help!

3 Likes

I just got a secondhand 8K X model 2076, had a yellow light so tried updating the firmware via DFU (was on .2001 but still yellow light), somehow it now says its an 8K plus 260 with a different serial number. Everytime I try to put on a new firmware with DFU it says “The firmware version number has not changed!” Any advice @PimaxQuorra or anyone else? Thanks.

Edit: Installed the Pitool beta and it is trying to upgrade the firmware but keeps failing. :confused:

Still the same, also the HMD is showing up as “none” now in DFU.exe but with the .260 firmware and a random serial number that doesn’t match the headset. (When I originally plugged it in, it showed as .2001 8K X with the correct 2076 serial number).

There should be a link in the forums from a guy who did upload all the versions, as far as i can remember.

3 Likes

@SmallBaguette checkout Playa’s site linkef in his topic below.

2 Likes

Thanks! I eventually got it sorted using the physical button DFU method, also had to unplug one of my monitors but I think that might be a limitation of the new GPU I got (3080 FE coming from a MSI Ventus 2x 3070)

1 Like

Did you got the older 8kx also (model 2075)?If so do you see a differance in the panels?

1 Like

I didn’t do too much side by side testing but 2076 definitely seems a bit brighter and better colours. Not a massive different though, I’d be more than happy with the 2075 and it may just be buyer’s bias making me think 2076 is brighter and more vivid.

2 Likes