My 4090 can't connect my 8kX - Change Refresh Rate outside of Pitool

Hi All - i’ve gotten myself into a weird spot where PiTool won’t properly detect my headset. I believe its because of the refresh rate. My 8KX has always been a bit weird about 90hz mode and I upgraded to a 4090 and it gives me error 10934. I’m betting it’s because 90hz mode only works on 30 series, but because it wont “detect” the DP cable, I can’t get into PiTool’s settings to change it.

I know the cable is just fine as with my 3090 everything worked normally. Also, I can still use the pimax max as audio output device with the 4090 so I know the cable isn’t broken or anything. I was thinking bout flashing firmware to see if it would reset that, but I think I tried that last time I had a weird refresh rate issue, and it doesn’t change anything. Plus there’s always that thing where you get stuck in yellow light mode and I’d rather not add that to my problems

This is unlikely to have to do with refresh rate. That’s not going to be something that the headset “remembers” and consequently can’t talk to Pitool because of that.

Looking at your issue without that assumption, the problem you’re having goes like this:

You previously had a 3090 working with your 8KX. You just upgraded to a 4090, and it’s not connecting with Pitool on the 4090 with error 10934. The 8KX’s audio still shows up as an audio device, however. And that still works. (Which implies the USB portion is still working)

What specific 4090 is it?

You said you were running on a specific firmware build that Pimax support sent you. What specific build is this? (ie. what’s the filename of the firmware file they sent you)

What version of Pitool?

Is this a new 2076 8KX or the older model?

Is it the standard or fiberoptic cable?

The title of this thread should really be something like “My 4090 can’t connect to my 8KX”. That’s the real issue here. The 4090 is very new and raw and running into these kinds of problems at product launch has been expected. (Though so far it seems to be working fine for most people that have been posting)

Also you should definitely open a support ticket with Pimax support for this. Besides getting yourself help, getting them data about 4090 issues will help everyone.

1 Like

Hi! Thanks for the help. I have the MSI Gaming X Trio. I mentioned the refresh rate because the pimax support person mentioned it, but didn’t give me any helping troubleshooting steps. I had had an issue previously where, and I can’t remember the exact details, but I think it was the firmware I was trying to use wouldn’t let the headset sync up in 90hz mode but I couldn’t get in to shut off 90hz mode. I believe I ended up using the dfu utility to get it to a firmware that did let the 90hz mode work again.

As for the rest of it, firmware is P2_8kX_M298_EngineerTest.dfu. This is because every other one I tried since then has some form of glitchy/flickery something or other at 90hz. I have the older model 8kX. If it matters, I’m also using the upgraded display port cable, I think it’s fiber optic.

I can update the title, but I guess I was trying to just toggle the refresh rate thing first to see if it made a difference. It’s almost like the headset works and just wont do a HDCP sync up (if that’s a thing in DP) so PiTool wont do anything because of that.

4 Likes

90hz works on RTX Cards even 20 series models; typically from what I recall 2080 and 2080ti.

There is a topic on Reddit with someone having the same problem your experiencing(unless of course that is your topic).

In his case it might related to Gigabyte card as there seems to be something changed in Gigabyte Variant of Nvidia reference design.

Another user there has posted he has 4090 Asus card working and with 90hz.

iirc if you put your hmd into dfu mode and reflash the firmware manually it might reset to defaults?

1 Like

I’m trying to do that now. Of course it didn’t work right and so now I’m stuck with the yellow light problem and having to google the process for that again. :frowning:

3 Likes

Very strange , here it connects without a problem on my Inno3D GeForce RTX 4090 ICHILL X3 and running on 90hz

2 Likes

Found it! I had to flash my bios yesterday and it re-enabled “multi-monitor for IGD” otherwise known as integrated graphics. I found an old post from PimaxQuorra about making sure all integrated graphics stuff was disabled. After disabling and rebooting. I’m going!

6 Likes

Thats great! Now post your impressions with your rtx4090😉

1 Like

Is there a megathread for that or anything?

So far I’ve only tested out ACC and there was a mega kick in the pants even from my 3090. I had my graphics tuned to do 80 to 90fps when I was all alone and now I get 80 to 90fps in a pack of 20+ cars. The frame time goes all the way down to 6.7ms when I’m all alone (140+ fps calculated)! I haven’t started to turn up anything, but I’m already massively happy.

3 Likes

Glad to hear about connection issues and solutions with the 4090. Even though all of the models are based on the same reference design, they’re not the same in terms compatibility issues and bugs and such. Helpful to know if there are models to avoid and how to get around any problems that occur before I buy a 4090.

I made a vague effort to buy a 4090 on launch day, and I actually did have an option to buy a Gigabyte 4090, but I didn’t go for it specifically because I was concerned how compatibility with the 8KX would pan out for the AIB cards. So hearing about what specific cards are working and which are having problems with the 8KX is useful. It sounds like maybe everything so far is working except the Gigabyte? I haven’t actually heard of anyone testing with an FE model yet. I was figuring on getting the FE specifically because it was the most likely to work without a hitch.

2 Likes

My eyes are full of tears… Because I do not have 4090. But I am happy for you. Pls try another games and report. That will be like porn on FM radio…

I can at least confirm the TUF works flawlessly with the 8k X, where I needed the LINDY repeater on my 3090 TI. It seems like the 4090 is largely fine and solved the DP issues the 3090 TI had.

I’m on a 12900k and have had no need to disable the igpu stuff too.

1 Like

I do own the TUF OC same goes for that model.
i have to admit i only use KF processors.

1 Like

I’d love to, but to be fair, my only accurate comparison would be the racing sim I play 99.99999% of the time. I went from barely holding 90fps and only when I was alone on track, to the only time I went below 90 was when there were 40 other cars around me. When I was alone on track, I dropped to 6.8ms frame time which is about 140FPS! I was able to crank the graphics to make it even sweeter and sharper and tuned it to about 10ms when I’m alone and I’m around 13ms at the start with 30+ other cars. The starts aren’t fun, but I’m used to getting through it.

4 Likes

Interesting to see success reports with 4090s and the 8KX.

Varjo HMDs are experiencing game-stopping stutter with 4090s for now.

1 Like

Just some questions out of couriosity:

What power supply are you using for the 4090?
And what are your average and minimum power consumption when playing with the 8K-X?
Did you UV the 4090 or limit it to 400/350 Watt?
If not, could you perhaps do such a trial, set the power limit to i.e. 350 Watt and monitor the impact on FPS? :slight_smile:

I’ve read in a german review that limiting the 4090 to 350 Watt just costs about 2-3% of FPS, but indeed saves a lot of power and potential compatibility issues with older or lower power supplies.
But they did the benchmarks with flat Monitor gaming / 4k only. So I am wondering how large is the impact when playing VR.

Thx already :slight_smile:

3 Likes

I got the Zotec Trinity 4090 and my 8KX is acting as the dedicated monitor. When i open pitool my monitor blacks out. Has anyone experienced this before and know off a fix? This is an earlier model 8kx.

i7 9700k
Rtx Zotec Trinity 4090
32gb ddr4 ram 3600
Asus z390 mb
1200w ps

Pitool version 1.0.1.277

Windows 10 has been updated and drivers are up to date. Thanks in advance for any help.

1 Like

I’m trying to figure out what this means. 8KX as a dedicated monitor? Do you mean that when you open pitool, your regular monitor blanks out, and then the desktop appears in some form as the VR headset display?

Also, this seems like a very different issue than OP and should probably start its own thread.

Thank you as I have an MSI Gaming Trio coming in a day or so, so I would have crapped if in that spot myself! Thanks for the suggestion!

Problems here.

RTX 4090 ASUS TUF gaming OC

Windows 11

Pitools 277

8kx 2075 series

Tried both optical cable and standard two USB+DP cable

Displayport connection is not detected unless firmware is 296

But this firmware does not appear to allow 90hz.

Firmware 298, display port not connected.

Help please. Frustrated.