Issues with new PiTool and Firmware

Continuing the discussion from Pitool v1.0.1.272 Beta:

So just to follow up on this new PiTool and m299 firmware

After doing a clean install of windows + PiTool and M299 firmware on my 8KX I am now seeing garbled iimage on screen with several flashing patterns of pixels.
Flashing the P2_RELEASE_8KX_M299_t20210922093742_r6066b70.dfu
This resolved most of the issues, but there are still alot of visible defects in the image, this was not the case for me with previous 90Hz firmwares and previous PiTool versions.

Seems you should have used your Alpha / Beta testing users here on OpenMR before releasing this. (Hint Hint…) :wink:



Thank you for the feedback Martin.
We could have a better result after flashing the M299 firmware on 8KX.
But it’s good to hear some issues after our users run tests on these Pitool/Firmware.

This would definitely helps our Engineer Team to figure the root cause and comply an improvement on this.



Hi Quorra

I think you maybe misunderstood me, the issues where not present with prior M298 Firmware and PiTool v1.0.1.270

But with PiTool V1.0.1.272 and the included 8KX firmware that it auto flashes + the P2_RELEASE_8KX_M299_t20210922093742_r6066b70.dfu there are problems with garbled images on screen in the HMD.

Feel free to pass this along to the Engineer Team, and they can reach out to me for further testing.




I do understand that you are having garbled images with Pitool 272V and M299 firmware.

Will pass this message to the ET.



same here , screen flickering

try to flash fw again, fixed for me


Same issue here, 90hz isnt working well at all, like its resetting every second with various messed up pixels. 75hz fine.


Will look at re-flashing firmware that @godiz suggests.

EDIT: I should have read the patch notes clearer. It lists the 299 firmware but pitool did that for me anyway. However it seems 299 is not the same as 299… Who would have thought!

Manually flashing the firmware appears to have solved it!


I also had strobing with 90Hz.
I had to reflash it with C:\Program Files\Pimax\Runtime\Dfu.exe = info for others, who forgot how it goes nowdays :wink:


after the installation a firmware upgrade came immediately. Firmware upgrade failed. now it only flashes blue green red and is no longer recognized, not even in the dfu.

Change of USB port not successful
Installation of the older pitool also not successful


Try a reboot from your pc,that worked for me


i got a bad performance now,i tried saint and sinners but it runs terrible now,somebody else got this too?

it’s working again.
restart did not help, but these instructions here:
of course with new firmware and a new PiTool


Can anyone comment how this new “compulsory smooth” locked 30 FPS mode works on a demanding flight sim like FS2020?

It sounds like a great fit. I’ve been running fs2020 using the 60hz HMD mode with smart smoothing on (ie it’s ‘smooth’ when I can maintain >30 FPS in the sim, albeit with the artifacts of smart smoothing). I’m hoping this new mode will be smooth at 30fps, but without the visual artifacts of smart smoothing.

I won’t get to try myself for some time, curious if anyone else has yet?

Can somebody else check if they have some strange behaviour with this pistool and firmware with Saint and sinners


After a few hours of “Off time” for my 8KX and powering up my PC the 8KX seems to be working fine now with the new PiTool and Manually flashed Firmware…
Will test this some more when I get some spare time.
Dang… I swore that I would not touch my 8KX again before I could complete it with the DMAS…


Sorry, don’t own Saint And Sinners unfortunately

1 Like

i’ve tried 1/3 with smoothing at 90hz

it wasn’t smooth.

1/2 with smoothing at 90hz felt alot smoother.

tried on random games


90Hz on PiTool 272 and the M299 firmware linked in the patch notes so far seems to be stable with the Titan RTX on NVIDIA driver version 471.41.

Since people were reporting issues I decided to manually flash the firmware linked in the patch notes first with DFU before installing PiTool 272 to make sure that the auto-flasher didn’t interfere.

I need more time to test it out to make sure it doesn’t have any longer frequency black outs and update the graphics card drivers to the latest but so far it’s a big improvement for me over the 298 engineer test firmware which was giving me sporadic black outs every few seconds, so good job on sticking with it.


Running the Newest Pitool and M299 Firmware on 472.12 drivers. 90hz feels a little less stable than when I was on the old Pitool and firmware. That is to say, I’m still experiencing intermittent flickering and blackouts. It’s not that much worse and I need to do some more extensive testing. But preliminary looks is that it feels so/so right now.

On an RTX 3080 and i7-10700k

After installing PiTools the firmware was updated automatically and I had the flickering problem, so I flashed this:

and the problem was completely fixed. Tested for hours, seems pretty stable. I tried No Man’s Sky, where it seems perfect, and American Truck Simulator, where there is still a slight ghosting, but it’s much better than smartsmooting, which I found unusable due to the artifacts on the moving traffic

8KX - RTX 3090 - I7 8700K