Index causing problems

I’ve created a lot of topics recently about my troubles with Index, but Pimax thought it was a good idea to not let people delete their own posts…?

Anyway, I solved several issues, but the underlying issue remains: The HMD on it’s own works fine. When tracking with the valve 2.0 basestations, it still works fine. The minute I connect and try to use Index controllers, my computer crashes with a “CRITIAL_PROCESS_DIED” error message.

I’ve tried updating windows, underclocking my GPU and RAM, updating USB drivers, completely WIPING my drive and REINSTALLING windows, yet I still have this problem.

Sometimes it’ll work for just under a minute before some things (Either my hands or the walls) go pink and black squares, if this helps.

I am desperate for help as I’ve been waiting to use these devices for over 2.5 years

It sounds like a buggy driver (not necessarily Pimax’s or Valve’s) or some sort of incompatibility between components.

Are you using a beta version of SteamVR? If so, try the non-beta version.

Unfortunately, there’s not much I can suggest, other than reviewing the error logs using the Windows admin tool “Event Viewer”. It can be really hard to interpret the info, so I’d recommend triggering the issue and making a note of the exact time and then search for problems just around that time. Then try to identify which component is triggering the problem.

Since there aren’t a lot of complaints about the Index controllers on the 'net, I assume this is some sort of compatibility issue between your specific system and the Index controllers. The few reported issues I found were nearly a year old.

You might want to review these links to see if there’s anything you haven’t already tried:


Thanks for your very quick reply.
It’s very temperamental, the other night I got it working and celebrating. Tried this afternoon and it looks like I’m back at square one.
I should mention that the headset, controllers and basestations all work on other computers, both Intel and Ryzen, so I agree its my computer and not any of Pimax or Valves products.

I’ll try a different version of SteamVR


One thought…so the PC bluescreens by the sounds of it? If so, try a BSOD viewer like BlueScreenView, which will view the dump file which is (hopefully) created on crash. It should list exactly which critical process died Blue screen of death (STOP error) information in dump files.

When you know which process is at fault, then you’ll need to figure out why…eg is it out of date / corrupt / essential or not / does stopping it, or uninstalling the related software allow the controllers to work etc etc

And before you even do any of that, have you checked the Windows Event viewer on reboot to check if that recorded any problems before the PC crashed? There might be something logged in System or possibly Application, but not always in a severe BSOD crash:

Hope that helps, good luck!


Hey, thanks for replying. Yeah it’s a blue screen crash. I’ve tried looking into event viewer but this is what I get.

I’ve sorted by level so don’t be alarmed at how many critical errors there are.

Am I looking in the right place?

How do I use BlueScreenView?


I have checked you only have 1 deleted post that says author withdrew. Please pm me with topic deleted as no activity is showing.


Yeah that’s the right place, is that the first timestamped error before the crash occurs? Unfortunately the pic error just states that there was an unexpected crash, which doesn’t enlighten us much :slight_smile: You can sort by Date and Time, and then also filter the results for only Critical errors under the search option. But don’t worry too much about that, there’s probably not much there.

For BlueScreenView, download from the link I posted - it doesn’t install, you can just download and run it. Do scan it with AV software first just to be extra cautious, but should be fine. I also see from Neal’s links that some AV software can in fact be the cause of the problem in the first place, so try to temporarily disable AV and run the controllers at some point to test that as well.

OK, as the instructions say, first check that Windows is set to record minidumps (the main dumps are very large).

For XP, 7 etc there’s a link: NirBlog » Blog Archive » How to configure Windows to create MiniDump files on BSOD

For Win 10, to get to the same option

  1. Right click the Start button, and choose System.
  2. Way over in the top right, there’s System Info. Click on this.
  3. On the old style menu that pops up, choose Advanced System Settings.
  4. Under Startup and Recovery, choose the Settings button.
  5. Under System Failure:
    a. You may have a tick box option enabled to Automatically Restart. You can untick this if you want to see error messages before a reboot, but as you get to see the Critical Process Died error already, it sounds like you can skip this.
    b. Under Write Debugging Information, switch the dropdown to Small Memory Dump (64k). This also sets the folder location, which by default is C:\Windows\Minidump, depending on where Windows is installed. Check as appropriate.

Hopefully after a crash, it will successfully record a minidump file. It’s not always guaranteed unfortunately, depends on the severity of the crash. But I think Win10 should handle it better than previous OSes.

If you find one, you can run BSV and drag and drop the file in to read the details - and hopefully you get some meaningful info about the process having trouble.

" Version 1.55:

  • Added Drag & Drop support: You can now drag a single MiniDump file from Explorer into the main window of BlueScreenView."

Fingers crossed, good luck! Depending on what you get, someone here (or perhaps even Valve or Pimax) can help you troubleshoot why the identified process is triggering this.


This actually sounds a lot like a problem I was having: My system blue-screened, only when playing Borderlands 3 in co-op mode. Stress tests ran fine. Single player ran fine. The problem was sporadic, but annoying.

I was only able to diagnose the problem once I started running Folding@home. I used to run it on my previous system and the F@H team recently added some work units specifically for COVID-19, so I thought I’d help out. Now my system would blue-screen within minutes of starting F@H.

It turned out to be my system clock settings (BCLK), which my ASUS gaming motherboard wanted to run at 103%. That’s a minor overclock and I had a hard time disabling it. (The BIOS really wanted to run it at 103%.) Anyway, everything was fine, once I set it to 100%. I now have it at 102% and haven’t had a problem in weeks.

The strange thing was that it was so specific as to when it crashed. I was convinced it was a B3 bug.

I know that Ellik8101 said he even tried underclocking, but I wonder if there’s a part which is failing under high loads.


Could you describe, how exactly do you “connect” the controllers?

Also, it is not very clear from your post, but are you using anything from Pimax (headset, PiTool), or are you just having Index kit (headset, basestations and controllers)?

1 Like

perhaps reverting to windows 10 1903 or forward to 1909 etc, also are you allowing windows to discover and install chipset and mobo specific drivers or are you stricly using the mobo drivers from its support page. Both of those paths would be worth testing along with different win10 versions. Sounds like its a one in a million bug between your hardware and steamvr lol that would drive me nuts. Best of luck my friend :v: :crossed_fingers:


I’m trying to uninstall one update at a time, but keep in mind I did a fresh install the other day so there’s not much to roll back to.

As for chipsets and drivers, the mobo manufacturer websites have nothing for drivers, only chipsets. I’m not sure how to do that bit.

Thanks for your advice, not sure how to take action on it though lol

1 Like

I had trouble pairing the controllers in the beginning but it’s getting better. I’m connecting them through pitool, wirelessly. I assume they’re tracking via the basestations which repaired to my PC via Bluetooth.

I’m using Pimax 5K+, Pitool, valve basestations and valve controllers

1 Like

I tried underclocking my GPU and RAM because that helped on my other computer. How do I underclock the motherboard? I didn’t know that was a thing

1 Like

Unfortunately that’s the only critical error that pops up. It’s very vague and unhelpful.

I’m using AVG, how do I disable it? I’ve tried uninstalling it but Windows defender takes over automatically doesn’t it?

1 Like

Capturing the BSOD minidump is a better bet for bluescreens than Event Viewer.

You can temporarily disable AVG, I used to do it for testing. I’m not using it any more, switched to BitDefender but this should do it: How to disable/turn off the antivirus : Support

1 Like

I’ve been doing this as well. I noticed I had to manually assign additional work units to the GPU, if left to work automatically it only seemed to assign work to the CPU.

I let it use full power when idle, can get kinda warm in the room when I get back to the PC :smile:

1 Like

No worries what I was referring to was rolling back to entirely different versions of windows 10 itself not specific to updates. The vendor for the motherboard should atleast provide chipset, audio, and storage controller drivers in some platforms those are all conveniently rolled into one chipset driver. Alternatively you can allow windows to search itself using windows updates to find Microsoft equivalent drivers this process sometimes requires a little time and a few restarts to engage after a fresh OS installation. For a proper process of elimination you would need to attempt both paths ie. Let windows find them all vs installing your vendor ones. Also wouldnt hurt to try fresh installs of gpu drivers from varying dates, if Nvidia choose custom then clean install, if amd use the driver removal utilily.

1 Like

If you really have the basestations paired to your PC, you may want to unpair them. They do not have to (and should not) be paired in order to work correctly. But this is probably not the cause of your problem.

The crash you experience looks like a hardware problem, especially if everything works on another PC. The puzzling part is that “connecting” the controllers should add only insignificant additional load, in terms of power.


I’ve tried a few different Nvidia drivers, I downloaded my mobo chipset driver last night.
How do I get different windows updates?

I can almost guarantee the basestations being paired isn’t the problem as they worked while paired to 2 other computers. I’ve tried a power saving mode, I’ve tried high performance mode, I’ve tried the balanced power mode, I’ve tried interlocking GPU and RAM.

I’ve tried reinstalling Windows so it has to be a hardware issue. My PC has the same GPU as my friends PC and a very similar CPU to my other working computer. A few error tutorials I’ve read point towards a faulty hard drive but I can’t seem to find any problems via automatic repairs and troubleshooters.

Either way I’m picking up a small SSD this afternoon to boot from to see if that fixes it (i work in IT so it’ll be nice to have as a spare anyway)

1 Like