Has anyone got the Oculus games working since recent updates, Lone Echo, etc?

I’m running the new beta but had this same issue in pitool .95 really. Every time I start any Oculus game through Pitool it just crashes. I have also tried revive directly but that has never worked for me.

The pitool Oculus implementation used to work really well, I wonder what happened?

This is the error Lone echo shows:

1 Like

Surprisingly echo combat booted up for a second. I turned it off them because i realized it needed parallel projection. Started it again and got this error:

It only seems to start when I turn off parallel projection but then you get double vision.

1 Like

Having issues with pretty much every recent oculus game ive purchased


What i tried so far (using Pitool to launch):

  • Lone Echo - Works but FPS is very low and i can´t use the grip buttons (so i can´t pass the tutorial)
  • Luckys Tale - When starting, gobble all my ram and then crashes (yes, it use all the avaliable ram and then crashes)
  • Robot Recall - Crashes
  • Bullet something - Crashes (Robot recall demo ?)
  • Edge of nowhere - Playable, but VERY LOW RESOLUTION, unbearable.
  • Chronos - Works but gives me “Entitlement failed” Check your privileges ! (maybe i offended some SJW ?)

Anyone knows any fix to these errors !?

1 Like

Hmm robo recall and lucky tales both work great for me

Really sad to read this. I bought Lone Echo months ago and have been saving it to play with the Pimax (coming from Vive OG)


Yes. I have the same issues for a while. I said to @Sean.Huang but at this moment I don’t have more information.

We are still waiting for a fix.

In Steam UE4 I get it working down Sampling Pitool to 0.5. But Oculus games don’t work with this fix.

1 Like

Absolutely the sames issues.


Yeah, with the older pitool versions just about everything worked but the newest versions I’m getting crashing on most of the games I play regularly… going back to the Odyssey+ for now until the pimax software is fixed again


Anyone achieve to get working Robo Recall in .103?

Weird tests

  1. Go back to 91 PiTool
  2. Put your GPU back to standard clocks (i.e. not overclocked, especially memory) and see if this helps

Let us hope that Pimax will say something about this and solve the problem as soon as possible.

1 Like

So my 5k+ landed yesterday… love it.

Got up at 5am and tried lone echo. Worked first time, zero issues or errors. Pitool 91.

Only had time to play half an hour. Seems like an awesome game. Will try the climb tonight…


My 1080ti is overclocked - no issues for me so far.

It doesn’t affect everyone but different gcards have different memory issues. Worth a shot IMHO

1 Like

Good info.

Everything worked ? Grip buttons etc ?

Did you pass the tutorial (pulled the lever) ?

1 Like

Yeah - everything worked fine. About an hour in.

The only issue is at some point you are asked to open your visor by pressing a button on the side of your head. As the game is clearly meant for rift headsets which are nowhere near as wide as the Pimax, the side of your head where the button is in only just accessible by pressing the Vive wand at a certain point to the Pimax casing, a way in from the edge.

Also - the game must be a lot better with touch controllers, the movements seem pretty poor with the Vive wands. Nothing like as smooth as say Climbey.

1 Like

All I did was from turning on PC:

Start my headset and wands.
Start Pitool,
Start Oculus App.
Exit Steam VR if running.
Change audio to use Pimax usb
Pitool -> my games -> start ‘lone echo’

1 Like


I believe you played with Pitool at 1.0 ?

It’s impossible to play Chronos or the Climb for me. Lucky’s tale works perfectly. Since I don’t have a Vive Base station (HMD only). I am uncertain where this is causing issue between PiTool and Oculus Home. I am keep getting error that some hardware is missing but yet the game runs in the background.