Flight Sims not work since last upgrade of SteamVR

It’s been about 2 weeks since SteamVR has updated from version 1.15.19 to 1.16.8.
Since then it doesn’t work for me in VR:
MSFS 2020
DCS World
Xplane 11.
If you select to use VR, they standby for many minutes and won’t start.
Only a beta version of VTOL VR works.
I have written to Steam to tell them the error, I have sent them the login and they have responded:

  • The errors we are seeing in your report seem related to the Pimax wrapper driver, which is used to send information from your headset to SteamVR.
    We also encourage you to contact Pimax support to ensure that their software is compatible with the latest version of SteamVR and the games you would like to play.*

Has it happened to someone else?

(In my name appears 4k, but I have Pimax 5k+ for a year).

Updated title.

Can you post details

System specs
gPU and driver version
Pitool version & firmware

Things should be working as your the first to post an issue.

1 Like

I have the 8Kx and payed yesterday with no issues.


DCS, IL2 and Aerosoft FS2 all ran fine today for me.



Intel I7-9077X
Motherboard MSI Z390-A PRO
24GB Ram
Gigabyte Nvidia RTX 2070 8Gb
Windows 10 Pro x64
Version Driver NVidia 460.89
PiTool version:
Headset Version firmware:

In mode normal, MSFS 2020, DCS World, IL-2 and Xplane 11.work fine.
If i select start in VR, the startup image remains on hold for a long time.

1 Like

Last Thursday, i suscribe to Betas in SteamVR.
Friday night SteamVR was updated to beta 1.16.9.
I wanted to try, and I work without any problem to IL-2 and XPLane.
But today I have tried play DCS and XPlane, and it does the same thing again.


Try opting out of SteamVR Beta

1 Like

I have noticed a problem in MSFS 2020, where it hangs for 1-2 minutes any time a USB connection is changed (connected or unconnected).

This is a real problem for me, since my USB stereo headset has a flakey connection. It happens in VR and flat-screen modes. Is it possible you have a USB connection issue? If so, wait for a minute or two and see if the game starts working again.

FWIW, I’ve ordered a new stereo headset, but it hasn’t arrived yet.


Of course though, SteamVR has a terrible track record for even fixing things they broke in stable versions, so if the beta is broken for anyone, for any reason, we should be very concerned this will be a problem for everyone soon enough.



Presuming it is SteamVR beta and not some other update or change conflict causing the launching issue.

1 Like

If SteamVR latest version does not work with any recent version of PiTool, then it can only be a SteamVR problem. I inferred and reasonably assumed as much from the content of this thread.

That this specifically affected multiple flight sims also seems far more likely to be a SteamVR problem. Aside from their CPU single threading, the main difference with these applications is not being based on the ‘big’ Unity/Unreal/CryEngine game engines, and the SteamVR interface they communicate with directly has vastly more things to go wrong.

Seriously, @Heliosurge stop debating and defending every point with regard to SteamVR. Reasonable conclusions are being drawn here, and more often than not, SteamVR is a huge problem.

If is a keyword. 1 report is not conclusive. Any troubleshooting it is recommended to opt out of any Betas in case the problem is caused by a beta. Whether it be a gpu beta driver to a program.

Atm we only know 1 user has reported an issue vs many others using the beta branch of steamvr.

Best not to jump to conclusions.

Yes you should stop letting your bias jump to conclusions. Have you even tested your theory on your system with described titles?

Have you tried opting out of the beta?

1 Like

I select Beta because the “stable” version 1.16.8 not work for me.

If I have gone to test the beta it is precisely because the stable 1.16.8 did not work.

1 Like

If I have gone to test the beta it is precisely because the stable 1.16.8 did not work.

1 Like

I think I have a solution.
If it can be called a solution.

Start my PC.
Run VTOL VR beta. In VR run fine.
If i try to start any other flight sim, it hang at the start. (That problem)
Restart my PC.
I start SteamVr from PiTool. Or start VTOL VR and load SteamVR.
… and all the sims work without any problem.
I don’t know why, but it works.

Thank for all the people for the replies.

1 Like

Have you tried starting SteamVR again, not from PiTool? My experience has been that launching flight sims directly from PiTool can cause permanent changes that cause these problems not to appear again.

1 Like

I am on SteamVR Beta - I even just finished updating my MoBo and 3090 card bios and enabled resize Bar. DCS - Elite Dangerous - IL2 works nicely. Like you explain, I never launch Sims from PiTool and I use PE for making use the SteamVR Config settings are set only.

PS; The only hassle with IL2 is I have a simpit with 14 controllers and I have to turn off a power USB bank so IL2 seeing my HOTAS LOL. So Far SteamVR beta is not causing any problems running with the recent nvidia drivers.