Firware for 8kx serial starting 2075? (Headset won't track / show lighthouses)

I’ve got an open support ticket, but the suggestions provided didn’t help since I had already tried them from other posts. I have an 8kx that I got last year, but have not used since just after I got the headset. It will not track at all or register the base stations (v2).

Currently running firmware: V2.1.255.298. Wondering if there is an upgrade to this firmware, or another one that works for my version of 8kx?

The screen does show up if lighthouse tracking is turned off, although the 90 Hz mode does not work - black screen when enabled). Thanks for any suggestions.

Note - I also see a similar problem to this post (Pimax 8kx, lighthouse only tracks when at least one controller active) , the lighthouses do not show up unless at least one controller is also active and the headset seems to not really track (stuck on the postion of one of the lighthouses rather than with the controllers). Kicking myself as my headset may have been problematic from the get go (think this hasn’t worked since trying to update the firmware earlier last year to unlock the 90 hz mode, but I put it in a box and haven’t touched it since summer 2021…

2 Likes

After 298 there are some variants of 299. Myself? I had to fallback to 296 debug. However 298 was working for me. However 299 is broken it seems for GTX cards like my Zotac 1080ti.

Did the Lighthouses ever work on your 8kX? Sometimes the Lighthouse headset driver doesn’t initialize.

Also have you ran Room Setup after enabling Lighthouse Tracking?

if you have controllers do they see the lighthouses?

1 Like

Hey Helio, thanks for the reply. Honestly I am not sure if the lighthouse tracking did work correctly since it has been so long since I last used the headset (can’t recall if the reason I put it away at the time was having trouble getting it operating and never got back to it). I did have version 1.0 of the lighthouses before, but recently got v2 lighthouses (they were out of stock for ages) and that’s when I re-installed PiTool software and ran into these issues. Is there a list of firmware somewhere? I searched around but did not see a download section. I’ll try an (even) older version if that’s helpful. Oh yeah, I do have an rtx 3090.

I also edited my original post above, the lighthouses do not show up unless the controllers are on, and then it appears the headset is locked in the relative positon of one of the lighthouses and the controllers are 5 feet away from where they should be.

3 Likes

Just downloaded the beta PiTool version of v1.0.1.283, it auto updated the firmware to V2.1.255.299, everything setup, but the headset positioning is still ‘stuck’ on one of the base stations so tracking is completely borked. Looking like it is pretty useless at the moment, I wonder if the tracking model is bad?

1 Like

Not sure about a direct list. 296 was prior to 90hz release. 298 Engineering was the first 90hz FW release As far as I know 299 was the last FW released for non revised 2076 8kX.

Ay a guess it is likely the Lighthouse Pimax 8kX driver is not initializing. They will likely need to perform a remote session to verify and might be able to fix it remotely.

Share your Ticket # with @PimaxQuorra & @hammerhead_gal can look into your ticket status.

1 Like

I’ve had this happen before. I don’t remember the steps for resolving it exactly, but I think it’s unplugging the connections between the headset and the PC, rebooting the PC and starting Pitool again to show it that it’s gone, and then plugging it back in and rebooting again. Something like that.

The main thing is that the driver needs to see the headset no longer connected and then connected again so that it thinks it might be a new headset now. I believe this kicks it to internally rebuild its map of the tracking devices again.

This issue is not related to any hardware problems with the headset. If it’s able to work as you have described, even though there’s a wrong offset, that shows that tracking is actually working at the hardware level. The state you have it in now is a software problem where it’s confused about which device is which.

Check your v2.0 lighthouse channel as both might be set to the same channel. There is a pin hole on the back of the lighthouse to change channels.

1 Like

I’ve been able to confirm the lighthouses are on different channels.

1 Like

That’s a good point (about tracking working, just incorrectly). Unfortunately I’ve tried swapping the headset to every different USB port I’ve got, re-installed PiTools, Steam VR and rebooted, each a dozen times, plus deleted all the Pimax lighthouse tracking info (and the SteamVR lighthouse jsons several times) but nothing seems to reset the headset to the correct position.

1 Like

i’ve had problems with pitool being able to detect my basestation. Usually swapping plugged in usb ports solved it, but last time a cmd prompt sorted it.

You may have already tried this, but if not, in \program files\pimax\runtime is lighthouse_console.exe, run this so it looks like this :

You should see 1 of the lines displaying LHR (something or other) EE9 if your lighthouses are being detected correctly, mine wasn’t.

So, like in the image, enter the command “dis” without the quotes. Try it a few times, i had to. My LH was detected then, it’s been ok since.

2 Likes

Pimax support helped me resolve this issue via a screen share. Great customer support though the program they use for screen sharing was a bit difficult to get setup since it was only partially localized in English so getting the share started was a slight mystery. That said, the support team was super and joined promptly at the time I requested (Beijing is 12 hours ahead so I had to schedule at 10:30 pm EST). They had to run some executables that appeared to reset something pertaining to lighthouse configuration along with a firmware update to the headset to ensure it wouldn’t happen again. So…if you have issues like the above and you try all the troubleshooting elsewhere I recommend you reach out to Pimax customer support.

4 Likes