Firmware updated failed last pitool

My firmware update failed with latest pitool and cannot do anything.
led is just bright white, but I can get those artisant back to dfu mode with blinking led and so on.

Just cant get windows regonize those glasses anymore.
A request for the USB device descriptor failed. is what i see device manager all the time.

I’ve seen that too (but on my 8KX). I just unplugged the headset completely (i.e. no power) and reconnected it.

1 Like

Did pitool say there was a new firmware?

If not then not recommended to manually flash a new firmware.

1 Like

tried that quite many time tried different usb ports and so on without luck

1 Like

pitool said that there is new firmware and used pitool for that


What color is the power light on your headset? Is it still just solid white or is it blinking?


Led is solid white. i can get headset for that dfu mode with buttons but windowns not regonize it.
When its solid white power button not doing anything before i power off and bring it to dfu mode. there was that tutorial what to do after firmware update failed but cant do that because headset is on A request for the USB device descriptor failed on device manager


You can uninstall the USB device from device manager then quickly unplug the headset from the USB. Wait a moment and plug it back in and allow windows to detect it again.

If that doesn’t work you can install pitool on another pc. (PC does not need to be powerful etc. for this purpose). Once pitool is installed plug your headset into that pc, it will try to reset the internal hardware setting. Once done you can plug it back into your primary pc.


tried that first option but need to try with another pc then.


The only way I can update my firmware is to use a different PC. My freshly built PC with Asus motherboard fails every time.

1 Like

Which Asus Mobo do you have? I have an Asus b450 itx board and so far so good.

Tracking which boards might help identify usb chipsets that might be problematic and/or give Pimax some ideas to test on.

I have the ROG MAXIMUS XII HERO. I have an MSI laptop that updates the firmware in DFU mode.

1 Like

I kept having BSODs until I plugged everything out of my motherboard USB plugs except the headset.

This last 8K-X firmware or Pitool has something funky going on.

This was the case for me as well on my MSI Z97 Gaming3 mobo.

Always had to switch pc’s to updste firmware. Even on fresh installs could never get firmware to update.

Pimax should really get to the bottom of what our pc’s have in common to cause this.

Im scared to update now. I dont think I’ve seen so many reports of failed updates in a long time.

1 Like

I updated pitool to V1.01.268 then commenced firmware upgrade, I had the same issue where the firmware would not install successfully but my device was still useable after unplugging all the cables and plugging them back in.

I took a risk and did it a second time, same result. Was looking forward to 60Hz native mode.

Motherboard is a Gigabyte X570 AORUS MASTER (rev. 1.0), I also tried using a separate PCIE USB 3.0 controller card for both USB connectors, the firmware upgrade still fails.

1 Like

Did anyone notice the same thing without pimax experience installed?

tried to use another computer wont help headset is still non regocnized with another computer so that wont help

I tried an old desktop, not recognized. An old surface laptop, not recognized. Mines was finally recognized on a MSI gaming laptop and I did the DFU update on it. The headset was already in DFU mode from my main PC and blinking red green and blue. Every time I try to do the firmware on the main PC, the headset goes into DFU mode and gets stuck there. I then take it over to the MSI laptop and do the update there. I do not have Pitool loaded on the MSI (or any other PC than my main for that matter). I just do the CMD prompt update procedure and then I am back up and running again.

yeah tried that method with my gaming laptop and my work laptop without pitool installed and still same problem that windows not regocnize those glasses

1 Like