Eye Tracking Module Reviews

Dear all,

If you got the Eye Tracking Module recently, please try to update the Pitool version to 263. You may download it via this page.

Besides that, we wish to gather some feedback from our users on this module. If you got any questions or suggestions, please kindly leave a comment below.

Much appreciate on your spending your time writing it out!

Your Pimax Team.


2 questions

Is the glass lenses that are part of the eye tracking module a nessecity for it to work?
There are reflexes from the displays In them that are distracting.

Prescription lenses, how to mount in eye tracking module ?


@PimaxQuorra: There’s an ongoing discussion here:
How's the eye tracking experience?


I haven’t tried mine yet, but I got in on the first batch of eye trackers.

Does this mean I will need to flash the firnware, because I’ve seen a few people having problems. If so, where can I find an updated firmware?

1 Like

It doesn’t work at all. The calibration app is extremely broken.

1 Like

I think you guys are missing the instructions for the eye trackers, and ppl are having difficulty setting it up.

Hard to give a review without it up and running don’t you think?

same, installed the 263 pitools, the calibration tool do not work at all.

tried to install. shows as droolon pi1 in device manager. Calibration does not work. ir leds don’t activate.

1 Like


We will release a setup procedure later, this will helps you to resolve the calibration issue.


1 Like

Later? Does that mean you guys didn’t even know how to setup the eye tracking properly till now?


We do know how to setup,but I’m extracting the latest firmware on my PC. Will release it once the loadbar is finished.



I got mine set up but seems fairly slow. It takes a few moments for the image to update. I’m assuming that this is the eyetracking, as it seemed the same with the calibration test. ie. the circles would be blocky until I looked at them for a moment or two.

If you are having trouble with the calibration (example, green dots disapearing before calibration starts) try changing your frequency. I changed mine from 90hz to 120hz and the calibration started to work.


Just tested it yesterday and … Can’t say I’m impressed so far (hoping for some improvements).

I had the do more cutting of the face bracket than I planned, basically severing it at the top, because keeping even a thin horizontal part would press the ET cables, and raise the ET inserts. Even like this, the left insert isn’t perfectly stuck to the lense / ET bracket.

After that, calibration.
I had to put the headset uncomfortably high on my face for it to start (without talking about not being aligned with the sweet spot of the lenses anymore). Even like that, the calibration was stuck after a few dots.
Eventually, managing to restart it and complete it several times, the tracking lacks precision since I can see i’m a little off from the 7 dots that appear after calibration.

Then the game. I only tested Alyx, putting it in aggressive mode, with Large FOV @ 90Hz.
I must admit I wasn’t bothered with the refresh rate. At least, I didn’t noticed any lag in the shading update like some have experienced (the ET module is plugged directly into the top USB port of my 5K+). I even doubted fovated rendering was running at first, but then I would notice it on far edge of the screens, and it seems that the ET cannot track that I’m looking that way to shade this part at full res.
This is disappointing when we know the offered ET eventually became a discount because Pimax had to change their plan to make the ET module compatible with the wide FOV of their headset … which is not.

Due to the way DFR works, low res aliasing at the periphery of the vision is still distracting, but way less than it was with FFR (that I ended up disabling because of that).

I will have to do more tests, with different settings (FOV, FR mode, Image quality) and different games.


as a 5k+ user you might have it connected to the upper usb port and the module is only running at 30 Hz
i used the pastic cap from the original packaging to cover the usb und preventing it to get in contact with the headsets usb (2.0), when connected to the side port directly to the computer it is possible to get the full performace out of the eye tracking module (120Hz)
also on my setup with 120Hz it seemed that i could use the headset lower on the face, the calibration worked much faster and better and the tracked area seemed to be bigger

I don’t think it is related to the refresh rate at all. I’m talking here about the calibration, and where I have to put the headset on my face for the calibration to work (and even then it is not very accurate).

It would be more related to the lag in detecting the new eyesight direction and make the driver change the position of the sweet spot. But as I saif in my review, despite being aware of some people complaining about that (some even saying it take akmost a full second for the change to take effect!!?), I didn’t notice such a behavior … at least on Alyx.

1 Like

just try it with 120Hz, i had the impression that there where some more limitation like maybe running in lower resolution in usb2 mode (and havon more detection problem because of this) or not using the whole picture, in my tests it was more then just faster response with 120Hz

Just an idea here even if you’re using the same image resolution having 30hz refresh mean less resolution in time not just input lag. You have less data per second to extrapolate next eye movement so less precision no?

Installed yesterday and back in its box today.

I managed to do the calibration after installing the thicker foam. At the end during the test the eye tracking is very bad. Just 2 dots turn green.

The eye tracking module is not functional.
I ordered a cable to connect the module directly to the computer. Hopefully the module will work.

Very disappointed.


they are testing 120Hz mode for usb2 (aka 5k+/8k), might be not in the next pitool but still

maybe the whole thing is a dead end as it is now, blocks part of the fov, blocks correction lens adapter, camera sticks out

integrating it directly offers much more and will also push up the amount of users having it, resulting in more support
when fixed in the unit by production it might be usable for auto ipd and alignment guidance for the user

the way it is now is just experimental and will not see much response from developers
maybe eyetracking might come later in a package with face expression recognition, so the cam’s tracks not just the eyes, most vr users might be more interested in the social aspect and squeezing out the last bit of performance might not be that important (maybe that will be more important with wireless vr)


I have been fiddling around quite a bit:

  1. Sometimes I lose the ability to calibrate - It seems to happen when I switch around the USB ports or update PiTool - not 100% sure. But only way i can get it back is resolved by de installing aseevr and letting pitool reinstall it.

  2. The Cable Provided does not work or with reduced quality

  3. The port in the EyeTracker is sensitive to the direction the UBS C is plugged in

  4. If I use the HMD’s USB C and a Samsung SSD USB C Cable, I can get a good connection and it’s also working in games (Dirt, Skyrim, …). Using it this way I get 640x480 @ 120hz shown in AMCap. I am not sure if this is also the case in games - it’s just the read out from AMCap – in game (Skyrim at night is good for a test) it still is noticeable where I focus and sometimes it takes like half a second to adjust) FPS at fluid 75.

  5. I also ordered a USB3.2 Cable (Occulus capable) - Using this cable I also can get 640x480 @120hz (USB Port Picky on the Mainboard side) – BUT I have not managed to get it working that way for tracking.

Also, I applied the GearVRCfg.ini hack: (remove all but the following)


exposure = 371