Euro Truck Simulator 2

Is it possible to import ETS2 into Pimax Experience and launch it from there?

I’ve sort of managed to get it going in VR, but only by launching it from Steam (that is the Steam desktop app, not Steam VR - it doesn’t appear there).

It works. You must import it and add the command line parameter “-openvr” to it as you did with Steam.
Then, normally, when launching it from PE, it should open Steam, SteamVR and then ETS2.

Alternatively, you also can start it with “-oculus” if you follow the YouTube-video PIMAX WITHOUT Parallel Proj. Best image and smooth with a 1080TI! 4k Video Through the lens! - YouTube, but at least for me, it doesn’t make any difference. In contrary, in Oculus-mode, I have a very subtle and slight stutter although the FPS are on the same level.

1 Like

yeah i found the same when doing it for ATS. Even though it doesn’t require PP in oculus mode I still didn’t get the increase in performance that I would normally expect to see when being able to turn PP off. The engine simply isn’t optimized enough for VR. I still really love playing the game anyway but it would be much nicer if I had the headroom to turn up the resolution a bit.


Thanks for the help.

I found the ets2.exe file in SteamLibrary/steamapps/common/Euro Truck Simulator 2/bin/win_x64. Then in PE I went to “import” and navigated to that .exe file. I entered -openvr as the command line parameter in PE. It now appears in my “imported” section in PE.

When I try and run it from PE, I get a dialog (on the 2D desktop) asking me to confirm that I want to start it with -openvr, but when I click OK it opens in 2D anyway. Tried both the x64 and x86 versions.

Hmmm, more investigation needed.

If you are playing it in VR the first time, it might you have to press “F11” as soon as you are in the menu to see the image in your HMD. I had the “problem”, too, at the beginning.
In general, the game then is shown always in your HMD, and your monitor image turns black - ETS2 and ATS don’t support any mirror so far. By pressing “F11”, you can switch the menus between HMD and monitor, but only the menus, then. The driving itself should be displayed in the HMD anyway.

1 Like

Thanks! That seems to have got it working.

Now, since you guys seem to be quite knowledgeable on the subject, I have another question. I find that in VR, the navigation panel is sitting right in front of me, blocking my view of the dashboard, instead of down and to the right as it appears in the 2D version. Is there any way to move it out of the way?

Not as far as I know, but I have turned it off anyway. Sorry, there, I can’t help you.

1 Like

I found a solution - there is a mod available that moves the route advisor to the top.

1 Like

Hi I’ve tried this and cannot get ATS/ETS to work. ATS will give the same prompt then load on the monitor in 2D. On reaching the menus F11 does nothing. I’m unable to get ATS to work natively in SteamVR or through OpenXR.

Could anyone offer some advice here?

I haven’t got an 8kx anymore and my memory is hazy but iirc you have to disable steam “theatre mode” from within steam settings. Also try launching it from steamvr. You are opted in to the vr beta branch in steam launch options I hope.

Thanks for the reply.
Yeah I’ve done all of those things - Unfortunately no luck.

Did you add the command line parameter in Steam game options? => -openvr

I played after updating to ETS2 V1.45. I had a little trouble at startup. (Resolved)

My steam startup option is -openvr -nointro.
I tried to boot using OpenXRToolkit, but blackouts and 2D startups occurred frequently.

So I lowered the Pitool settings to RenderQuality to 1.0 and switched to steamVR. steamVR launched fine, so I restored the in-game options to optimal and restarted.
Switched to OpenXR again and the trouble was resolved.

It seems something in VR was affected by the ETS2 update, but a solution was possible.

1 Like

How did you manage to get it work with OpenXR?
I thought ETS2 wasn’t compatible with that.
How large/significant is your benefit over SteamVR/OpenVR?

Do you have any detailed installation guide for OpenXR with ETS2?

Thx :slight_smile:

OpenComposite Compatibility List updated by mbucchia.
The information is kept up-to-date based on user reports.

ETS2 requires opencomposite.ini and the addition of “invertUsingShaders=true”
Please read more about .ini storage locations and options.
This page was a big help to me and I encourage you to read it.

Install necessary tools and replace DLLs

Shut down the running steamVR, start OpenComposite and PimaxXR, check the option to switch to OpenXR, and start ETS2 normally.
If you see the VR screen and press ctrl+F2 and the OpenXRToolkit options appear, you have succeeded.

ETS2 graphics settings recommend 100% scale, occlusion off, and anti-aliasing off.
I have the OpenXR NIS scale set at 110% oversampling, which is not recommended.

Thanks for that :slight_smile:

Do you get larger performance and FPS improvements with OpenXR compared to SteamVR/OpenVR ? Or only a slight amount? Is it worth the work for ETS2?

As for performance, it is considerably faster.
I get a comfortable drive with 8KX + Pitool 2.0 + PPon with no stutters.
Of course I use NIS for optimization.

At least with OpenXRToolkit you can fine tune the world scale and color tones.
For that reason alone it is worth installing it.

It’s a must have for me, and for 8KX users as well.
It is switchable and I see no reason to hesitate.

Does OpenComposite really need to be installed, since this seems to be the system-wide installation?

Shouldn’t it be sufficient, to install the corresponding DLL only, if I’d like to use it for ETS2 and ATS only?

I don’t know if that is necessary as I use toolkit for multiple titles.

Okay - it generally works without having installed the OpenComposite system-wide.

But the image is turned upside-down.
I suppose this has to do with the settings in the ini-file - but I cannot find any opencomposite.ini anywhere…

Normally, it should be located next to the DLL in the game directory

… but there isn’t any…

Where should it be located?
Or from where may I download one in order to copy it next to the DLL? Cannot find any on GitLab, either, so far - or I am just blind :wink: