Elite Dangerous without Parallel Projections?

Hi guys, I have tried to run elite using the method first realised by @park (many thanks for this find) which uses the steam app id of the game in a text file, along with the oculus SDK files to run games in native oculus mode directly from Pitool.

Now I’ve tried it with elite dangerous and can confirm parallel projections is not needed and the image is correct. The only problem is when in game just as the main menu is about to load, I get “login failed, make sure to load from the game launcher”. I have tried with and without the game launcher based off the steam version of the game and can’t get past this login check. I’m wondering if anyone knows a way around this because if so, then I’m pretty sure we can all enjoy elite dangerous without the need for parallel projections and hence a nice frame rate boost just as we have for other games using this method such as Project cars, Dirt rally etc as found by @park


perhaps @park has some thoughts on this.

1 Like

Whatttt, wonder if Project cars 2 works on this too??

1 Like

Maybe the same problem as mentioned here?

1 Like

I’ve tried a variety of things, but have not yet solved the login failure. :sob:

1 Like

your efforts are very much appreciated :beers:




I’ve been waiting to play Dying Light in VR for a long while, and you made it happen. Wish we could get GTA5 in VR other than using Vorpx

1 Like

Could this be combined with the launcherless script to make it work?

This powershell script makes a shortcut with your login details so you can start the game without going through the launcher.
It has been around for years and as far as ive seen no one has reported any issues other than having to rerun it every now and again because frontiers maintenance will break it.

Also, do i need to have the actual steam version of elite?
Ive been playing since before it was even on steam and never rolled over to a steam key.

If not, can anyone share the steam app id i need?

1 Like

RAF says it does not work because the gtavr mod launches another instance of steamVR and pimax can not pick that up

1 Like

I think we need some way of adding "ServerToken YOUR_TOKEN as a launch option.

(non steam) Elite can launch in Oculus mode through Pitool, no need for parallell projection but it doesnt log you in.
Elite can be started without the launcher by appending "ServerToken YOUR_TOKEN at the end of the target line in a shortcut to the executable.

Ive managed to get the dlls and found the steam app id, Elite now launches and display correctly without parallell projection on and i get to the same message as OP.
No need for the actual steam version.

Ive ran the launcherless script and tried to point the pitool import onto the shortcut output by the script but it still just starts the exe without passing along my TOKEN.

Ive also tried to manually edit the file for the pitool game entry in C:\Users\USER\AppData\Roaming\PiTool\manifest
But im guessing it breaks because there is a quotation mark that needs to be in there.

The command that needs to be ran (and is ran by the shortcut created by the script) is:
PATH\TO\DIRECTORY\EliteDangerous64.exe "ServerToken MY_UNIQUE_TOKEN

Anyone know of a way to get it passed along to the EXE on startup through pitool?

ADDITION: i dont know json files well at all but i looked up how to deal with quotation marks and saw that i could try to use use one, two and three \ before the "ServerToken to try and make it get passed along but it either doesnt get passed along, no change from OPs reported behavior or breaks the shortcut.

ADDITION2: i tried using opencomposite and then starting elite via the working shortcut, no dice, it spits out an error about openvr_api.dll.


Are you certain that you have the command right? That is an odd command line format. The character " usually is the start of a string literal and you need another " to end it.

I would expect the command to look like:

*.exe “ServerToken TOKEN”

As you mentioned, in JSON to put a " character inside a string you need backslash. So, \" is what you want. If you use \\\" it will turn into \" so that is not what you want.

Have you tried:

*.exe “ServerToken TOKEN”


*.exe ServerToken TOKEN

The first would be written like this in the JSON:

*.exe \“ServerToken TOKEN\”

Edit: Fixing the back slashes so that the forum displays them correctly…

Edit: Ignore the * characters in the post. I didn’t want to clutter it by copy/pasting the executable path and name everywhere. It represents the executable name and folder.

1 Like

I’m sceptical because at PC2 we havent any frame boost, it’s quite opposotive.


Good info! but opencomposite is for oculus rift only.

Slightly off topic.

I just saw some patch notes at the Frontier froum about the April 23 patch. They claim they fixed 800 bugs but only mention the big ones. They mention 2 VR related rendering bugs. I doubt they fixed the need for PP. Link to Patch Notes

After the patch if the need for PP isn’t fixed, someone could create an issue report using the new issue reporting system and post it here so that we can all confirm it. Then maybe we could get them to fix it. This might be another way to try to get Elite without Parallel Projections.

Here is the link to their issue reporting system: Report Issue

After I have a chance to try out the April update I will create and post the issue link here if one is not made before that.


@manzilla Im absolutely sure that the shortcut created by the no-launcher script only uses a single ", i too thought this was odd and have double checked.

Of your suggestions i have only tried the one without the " mark.
*.exe ServerToken TOKEN

After the servers are up again i will try some of the other variations and report in again.

Ill join in on any mass reporting suggested.

@Yata_PL as other have said/guessed the pimax/oculus compatibility seems to be an internal revive variation which that could definitely mean a performance loss but we gotta get it working first to see if that is the case.

@park I realize opencomposite is meant for rift but i thought i would give it a try anyways, most of this stuff is too advanced for me to fully grasp anyways :wink:


What you see in the properties dialog is not the full line, it truncates it. You can print out the the token easily in Launcherless.ps1 which I guess you used to generate the shortcut:

$info =  Get-WmiObject Win32_Process | Where-Object  {$_.Name -like "EliteDangerous[36][24].exe"
$path = $info.Path

if ($info) {
    if (!$path) {
	Write-Host "Failed to get the path to the executable from the process" -ForegroundColor Red
	Write-Host "Please copy and paste the full path to the EliteDangerous32.exe here and press Enter" -ForegroundColor Red
	Write-Host "Example > D:\Games\EDLaunch\Products\FORC-FDEV-D-1003\EliteDangerous32.exe" -ForegroundColor Red
	$path = Read-Host "Fullpath > "

    $token = $info.CommandLine -split "ServerToken"
    $desktop = [Environment]::GetFolderPath("Desktop")
    $WshShell = New-Object -ComObject WScript.Shell
    $Shortcut = $WshShell.CreateShortcut($desktop + '\Elite Launcherless.lnk')
    $Shortcut.TargetPath = $path
    $Shortcut.Arguments = '"ServerToken ' + $token[1] + '"'
    Write-Host 'token: ' $token[1]
    $Shortcut.WorkingDirectory = $path | Split-Path

} else {
   Write-Host 'Error: Launch Elite Dangerous first.' -ForegroundColor Red

I have already tried, without success. Maybe you’ll have more luck.


All that is far beyond me, ive got no understanding at all of powershell, only what i could see in the properties window of the shortcut.

ADDITION: Ive opened the shortcut in notepad to see if it would tell me any more and it doesnt look like there is a second quotation mark in there.

Here is what i think is the relevant bit:
C:\games\EDlaunch\Products\elite-dangerous-64\EliteDangerous64.exe . \ E l i t e D a n g e r o u s 6 4 . e x e - C : \ g a m e s \ E D l a u n c h \ P r o d u c t s \ e l i t e - d a n g e r o u s - 6 4 À - S e r v e r T o k e n MY TOKEN
There isnt an À symbol at the end of that line and the full TOKEN is displayed unshortened in the shortcut properties.

Anyways, the Elite server are supposedly back up, gonna have some dinner and then do some testing

ADDITION 2: ive tried *.exe \“ServerToken TOKEN\” and that doesnt do it either.
I also tried to start elite from .bat file using
EliteDangerous64.exe "ServerToken MY_TOKEN
EliteDangerous64.exe “ServerToken MY_TOKEN”
None of those log in correctly which i do not understand, i thought stuff added to the shortcut target line was the same as starting something like above in a command line/bat file.


I asked pimax if could import a shortcut containing a token into pitool, but I still have not received an answer :sweat_smile:

How do you get the token?

edit: Ah with the github script, sorry for not looking first.