Double Vision when moving, PP off, 8KX, 6900xt

Have you try to set your GraphicCard in Compute Mode?
Maybe this helps.

Well, I did not know there was one.
I have looked, i can not find it on my Radeon.

Looked ad AMD found it on their site for old Radeon

So I think they must have removed it.
That was a good try, i thought you had it then!

important update

1 By turning down in game settings, mainly track detail, i get stable imagine. still under utilized GPU. It does not say i am pushing the CPU, but the evidence says i am.
Next overclock CPU. or play for a bit with low settings.

2 smart smoothing is out of focus. When stationery, not moving hmd; It looks like two imagine side by side, slightly apart.

3 SMART smoothing, when moving; has double visions - same problem with Pi Experience.
Is it possible, there is some smart smoothing on pi experience?

1 Like

It’s certainly possible that PE uses smart smoothing.

I think that there is some code in the drivers (unrelated to smart smoothing) which attempts to insert frames based on your head position, when the fps is low. This would help reduce nausea. In the low fps situation, I sometimes see double images and also (if I turn my head quickly) some black areas at the outer edges of my vision, which I think is “empty” areas that the previous image frame did not calculate, but which have now angled into view.

That is, smart smoothing takes depth into consideration, to synthesize new frames. I think this is something different, which simply shifts the last frame, according to your current head angle.

For me, this only happens when the frame rate is very low.

Thanks, good input.

What is the settings to make PE higher fps?
When i am in PE only, my gpu and cpu are very low utilization.

oh, will that be: common settings, gpu ?assessment - can not think if the name.

I don’t use PE, so unfortunately, I cannot help you troubleshoot that.

Just updated motherboard Bios and update AMD Radeon Adrenalin 21.4.1

Looks like it is working now.
I still have very slight double vision in PE (but nothing like before, and I could probably not show it here. I only know it is there, because I am looking for it.
It is fine.

1 Like

I am not sure this is the same issue, but probably is or related; If my FPS is lower than Hz there is jittering. e.g. Project Cars2, or DCS.

I may be able to put up with it at the beginning of a race, 18 Cars ~ 80 FPS with Jitter, then after the first corner 90 FPS no jitter.

1 Like

I have the exactly same problem in DCS, smart smoothing makes everything blurry, like there are 2 images superimposed on eachother. And also for me without smart smoothing I can get 80-70fps but with smart smoothing turned on it drops to 35ish fps this is with a 6900XT.

1 Like

yes, that sounds the same issues i have.

let make a ticket, and discribe it better?

i think the ss frame is not in the same position as the original frame.

I’ve had a ticket open for about a month. Been going back and forth trying things. So far no luck.

can i access that?
can i read it?

basically, where i am now is:
must hit hz with fps.
if even slightly lower fps than hz, bad.

Yea, same exact problem here, and if I try to use Smart smoothing to… smooth it out, the performance drops 80% and double image blurriness + huge stutters. But turn smart smoothing off, and bam, instant 80% increase in FPS, double image gone, and only sutters when fps dips below refresh rate.

I suggest you make a support ticket as well, maybe they can help you. So far they had me update my mobo bios, edit a json, and try a different USB plug. Smart Smoothing problem still persists.

1 Like

i have read, here, that Nvidia users can brop below the hz with smoth fps.

i have told pimax about it, abd they blanked me.

i should make a new ticket, and try again.

today, i maxed out all settings, on project cars 2, but reduced reselution to 60% in steamVR. hit 90 in rain at night. i really enjoyed it.

it seams to be a ss or drop frame issue.

if i turn on ss, i get two imagines, ofset, next to each other, very frustrating. beacuse, it is obvious, it could be fantastic;IF.

I can’t help you fix your AMD issue; but I CAN help you fix the PCars2 issue, by telling you how to get rid of it:

  1. If you don’t have it buy Assetto Corsa (NOT ACC)
  2. Pay to support the full SOL project, which includes nights, lights, rain, fireworks, you name it. It’s effects are 3X better than the PCars2 equivalents.
  3. Learn how to use Content Manager
  4. Enjoy vastly better physics, vastly better FFB, vastly better performance, vastly better graphics, and vastly more content.
  5. Realize you’ll never need the blurry, lame physics, lame ffb, poor performing PCars2 again and delete it from your drive.

It really is orders of magnitude better. Wide FOV, 100% or more Steam SS, eye-candy all the way up, and you’ll still get better performance than PCars2 will give you at Small FOV.

It’s a bit of a learning process to get it all done, but it’s so worth it. (Note, I’ve also found I can tolerate 60hz no problem in Racing Sims since they are seated. I run AC at 75hz most of the time for more fluid motion anyway, but if you can tolerate 60fps you may be able to crank up the SteamSS or PiTool quality.)


I have Nvidia 2080ti, and smart smoothing is working mostly. Especially if I just turn on my game and just start to play it.

But if I have long ladings (some games, like IL-2, with big maps and many players), or if I let my HMD on table a few minutes (steamvr pause is disabled/enabled, it is same), then smart smoothing does not work good, it has strange effect, like looking trough fluid, with many artefacts. Also my tracking then behave bad, like lagging a lot.

My conclusion, it is much better with nvidia (when works, then it is excellent), but for some cases I just can not use it.

I agree about AC vs PC2, i have both and AC with SOL and CSP and a load of other mods (mainly cars and tracks). I love racing around in cars that i’ve owned irl. The mods make AC shine.

Thanks for the info. Since then, I have got Assetto Corsa. Played only a bit. I was having trouble getting the response time down. I do not have any mods (yet).

But really this is about Smart smoothing.

Just thinking about this:
It may all be different with the latest pitool and firmware? Meaning maybe the problem is fixed. The issue with updating is, I will not update until it is working better. Not much point updating from something I can use (but with problems) to something that has a lot of new problems.
I am still using has its own problems.
Oh, I should update!

I just updated to
Different problem.
Still smart smoothing is not working. but it is not like i described before.