Disable 1/3 Smart Smoothing

I’m running PiTool 280 and still there’s no option to disable the 1/3 smart smoothing? Even when my GPU is at 60% usage the system is dropping me to 1/3 smoothing which is horrific. Without reverting to 270, how do I remove this?

What sucks even worse, is that the smart smoothing at 1/2 is MUCH cleaner in newer versions than in 270 (when 1/3 didn’t exist). Why does it exist at all? Why can we still not disable it despite EVERYONE on the forums asking for it? @PimaxQuorra @PimaxUSA @PimaxEthan

2 Likes

@TFB Because Pimax desperately wants to stop selling us HMDs and convince us to buy from other companies instead? I’ve been 95% satisfied with Pimax up until this 1/3 rate crap. Now I frequently search for other news of wide FOV HMDs that might be coming down the pipe in the future and will hop off the Pimax brand first chance I get (assuming this remains unfixed.) The 1/3 rate forces us to use no motion smoothing at all - it’s completely broken. It’s as if nobody at Pimax bothered to test it, even briefly. It’s absolutely intolerable that it hasn’t been removed. It should never, ever, have been implemented in the first place. Take note Pimax; your software is now in a state which is so awful that people like me, who have owned 2-gens of Pimax hardware over a number of years, are now actively looking to leave the Pimax market. That’s some seriously bad software. @PimaxUSA @PimaxQuorra

Trying to understand: what do you expect the software to do when 1/2 is not achievable due to too high frame times? Should it just stop doing smart smoothing and drop frames? I’m not quite sure what the alternative to 1/3 is.

Yea, you literally just drop the frame. Its 1000% better than what it does to drop to 1/3 smart smoothing. That being said there are real issues with the system as is. I, at less than 70% GPU usage will regularly drop to 1/3 smart smoothing. This means when I’m easily able to keep 50 to 60fps, the game drops to 30fps instead of 45. If you revert back to PiTool 270 you’ll see that smart smoothing can work just find at 45fps with some frame drops and its night and day better than dropping to 30fps and doing 1/3 ss. The bummer is that the implementation of smart smoothing is actually much smoother in newer pitools. This may just be an effect from having the gpu horsepower of 60+fps when you only need 45, but that’s something for Pimax to answer. In any case, what is defintiely not a solution is 1/3 smart smoothing. it helps no one.

Lowering one’s expectations? :grinning:

1 Like

in 283 there is a selection for 1/2 and 1/3 and from the description it depends on the frame rate set for the headset, so if it uses 1/3 even when 1/2 is selected it would still be possible to set the headset to 72 or 64 Hz, then there should be no need to 1/3 if the frame rate drops below 45 fps
(72 hz is barely usable for me and 64 is a flickering mess but that depends on the user and its also possible to get used to it after a few minutes)

1 Like

I feel your pain. If you can, you might try using PimaxXR (which also requires Open Composite for non OpenXR games), it does have an option for forcing only the 1:2 motion smoothing. You do have to click the little picture of the PimaxXR logo as it is entirely an advanced/developer option and can have negative results if not used properly.

Keep in mind that even then it will be dropping frames when the frame rate is less than 1/2 of that of your HMD, but perhaps that’s preferable. You’ll note that it also has sliders to adjust how quickly the rates are triggered as well.

The key advantage of PimaxXR is that is has correct timing of whether to use 1:3 mode at all, as PiTool/SteamVR forces the 1:3 motion smoothing mode FAR too early and stays there for far to long. It is a known bug, and one that the devs are looking into. As an example with PiTool/SteamVR currently you can have a stable 50 FPS and it will trigger 1:3 motion smoothing mode.

See this post for how it went down: Pimax Motion Smoothing - Possibly Fixed (via PimaxXR)! (Originally Titled: Something changed with Pitool on version .271 and forward)

In either case, I’ve messaged the Pimax’s support team to encourage fixing the timing and/or allowing us to disable 1:3 motion smoothing.

wait does .283 have the ability to disable 1:3 motion smoothing? Perhaps I bailed on that version too quickly

I think it says a lot about a company’s software team when the community starts to write code to fix holes in the system. I’m pretty pessimistic on their future now. :frowning:

1 Like

Hey, I have a great relationship with Pimax, they gave me a device free of charge, and I’ve been having a lot of fun writing code for it. It’s been a great learning opportunity for me (even though I already work in that industry, it’s presented a lot of fun and interesting challenges to me).

Please choose your words kindly when you make this type of statements because 1) they don’t reflect the reality (the things behind the scene that you don’t see), 2) they make me look poorly-intentioned, 3) nothing positive comes out of it.

Motion smoothing/reprojection is a divisive topic for literary every vendor. It’s a technology that I’ve concluded is impossible to implement in a way that will make everyone happy. It’s also a technology where users do an extremely poor job at managing their expectations and communicating their grievances in words that engineers can actually translate into actionable changes.

Having debugged some motion reprojection issues in WMR and some motion smoothing issues in my PimaxXR project: 9 times out of 10 I cannot understand and/or reproduce what the user tells me is happening. Every single issue is “soooo obvious” for the user, but believe me being on the other side, nothing is obvious.

This is why I asked earlier: what should happen if you can’t maintain 1/2? I understand there is an issue of 1/3 kicking in too early, and this is more likely the issue that needs to be addressed here. Adding more settings isn’t always the best way to solve issues: it creates more configurations to maintain (this is why all my motion smoothing related settings are hidden in a secret menu) and it confuses most users (typically the users who wouldn’t ever care for this setting). At this point the best people can do is collect specific scenarios where the wrong behavior is happening. The other thread started doing this, and it’s much more useful read there!

5 Likes

I appreciate your thoughtful response. Its excellent they sent you a device and are encouraging you to write your own code. It’s great that they are allowing the community the ability to write things that are for the betterment of everyone. My previous comments certainly did not mean to pull you and your experience into my own. However, I have to disagree based on the premise of my post. I reported the 1/3 smart smoothing issue back in 271 when it first started. Pimax’s project management team, despite seeing post after post on many different forums about it has elected not to address the issue.

What should happen is if there is a clear issue with the system, it should be fixed within a reasonable amount of time. In this specific case, you are providing (what I’m guessing is free) work to create the only viable workaround to a functional issue they created in their system and have failed to address. This is NOT an appropriate use of community-based development and honestly not fair to you. The smart smoothing feature is so core to their high end headset working, it could be considered barely usable without it depending on the games you play. The fact is that their HMD far outpaces the foundational hardware to drive it to its limits and smart smoothing and compulsive smooth is the only viable options to make it work. With the oncoming release of the crystal and 12k, this will be even more of an issue.

What should happen if a device can’t maintain 1/2? Like you, I think there is likely no perfect answer, but what is probably best, in particular in the niche market of high-end power users is to give a choice. Allow me to disable 1/3 smart smoothing. It’s not like there are 400 options in PiTool that all don’t make sense. This one is clearly a big deal to a lot of people and has gone completely unaddressed for what, 10 or 11 PiTool releases?

I actually agree with you on the user-reported issues. I work in a company that does end-user support and you are 100% right on your 9 out of 10 times there’s not enough information for anything actionable. In the case of 1/3 smart smoothing, this isn’t the case. In fact, I’ve reported it at least 4 times between support, reddit, and openMR. Support left me with no answer other than to go back to 270. Reddit, the thread was dropped by PimaxQuorra. This might be my second post here with the last going no where. I’m actually really excited to see the response this got and I’m excited to try out your PimaxXR system.

Please don’t take any of my annoyance with Pimax as a person hit against you or what you are doing. In fact, you are definitely helping them in more ways than they are likely to be thanking you for. I appreciate your work as well. I think if life were fair though, you wouldn’t have had to spend time writing code to fix an issue that Pimax should have fixed itself.

Thanks again!

3 Likes

looks like this in 283
image

not sure how it looked in 27x, from the dialog it implies as if you choose 1/2 it would use this and nothing else

1 Like

Well i will say this, 283 is the first version that the firmware other than 298 engineering test works for 90hz on my headset!

Yeah it’s just renaming of the compulsive smoothing I think.

I do hope the Pimax devs are still pursuing this and my bump in their tickets was polite.

I have not fully tested .283 or the pimax Client for the timing issues listed above and would like to this week for fun, but rather I assumed that because there was no changes to the GUI in Pitool that it wasn’t resolved overall.

I do think Pimax cares, I understand that there’s a cycle and a ton of testing that needs done and motion smoothing has it’s limits and it’s a knife-edge to get it just right.

I wish nothing more than that it is not ignored. Pimax has a ton of development I’m sure that must take priority such as tying in with Tobii and such. I really just would like to see them grow their development team, and retain the talent they have.

I appreciate Pimax’s efforts, but I also wish to ensure that this medium-level issue is not ignored.

Did you turn on Smart Smoothing and 1/2 at the same time?
image

I can’t tell you how much this has made things better for me. Thank you so much for letting me know about PimaxXR and thanks @mbucchia for doing the hard work to make it happen.

Yep the above doesn’t work to disable the 1:3 smart smoothing, unless something else changed in the last two versions of Pitool I currently stuck with .280. (there are two bugs with the newer versions - one is that the GUI doesn’t scale to the desktop scaling properly (I use 150%); the second is a glitch mentioned by @mbucchia that the menus get handled differently). They keep suggesting the above in the ticket as well. It misses the fact that if your frame rate is less than that of the 1/2HMD refresh rate, we want it to simply skip frames instead of go into 1:3 mode. It stays there too long and looks far worse. More importantly, Pitool currently seems to measure the timing wrong such that it induces the 1:3 mode way to early as frame rate decreases.

I can attest to it going to 1/3 mode even when you are no where close to 1/2 frames. I’ve run through benchmark to verify the frame rate never gets below 55fps (45fps is 1/2 for me) and yet still, it will suddenly drop to 30fps. Its not just bad its really badly misinterpreting low fps.

1 Like

Even on the 4090 this ‘feature’ kicks in way too early. I can now play many titles at 90hz, never dipping below 90fps. Turn on so-called ‘smart smoothing’ (just for testing) and it will drop all the way to 30, repeatedly, instead of staying at 45. It’s absolutely insane that Pimax has left this ‘feature’ in their software.

1 Like