DCS high CPU Frame Times in Pimax 8K X, Pimax App Software with AMD 5950x (or similar) and 4090 RTX

I watched (and the other recent ones)

and have noticed that since I have upgraded to the RTX, updated Pimax App, Drivers and DCS (2.8) and what all comes to gether, I have very high frame times compared to Ismael.
He has around half with the same CPU (mine is about 30-36ms in similar scenarios with identical settings in DCS) and again minus 2-3ms with the 5800x3d.
Now I know there could be about 1000 reasons, but since I count myself rather PC Tech affinitiv I wonder where his comes from. My I tried the Ryzen Master Settings for OC and Gaming to see if they change anything - nope.
I also have since I build the systsem RAM at 3600MHz and the correlating bus at 1800MHz.
So since its a diffrent HMD (similar Resolutions ) I would like to finde the cause for this large differenz. Especially since


It’s DCS 2.8, especially weather settings. I am on 12900K OC to 5.3, 4090 OC 2950Mhz, noticed CPU frametimes increased after openbeta 2.8, especially when flying through rain.

1 Like

Seems likely related, but I did wonder why there is such a large increase and bad comparison, I dont see it equivalently worsen e. G. In this video

It seems more like a 2ms increase in those conditions.

For me it’s like 34ms instead of 15ms

Yes, since Today, first Multithreading activ in OpenBeta!

1 Like

Do you have HAGS on or off?

1 Like

HAGS ist like a handbreak for me in ST - I have to turn that off - causes stutters and enormous FPS reduction).

I have not tried how this behaves in MT - will give it a try now.
MT is definetly a gain for me, but now its the GPU that is limiting often (Small, 8K X, 4090, Using DCS Native OpenXR). But its like the first time that I can use it with almost 90 FPS in lots of the Instant or Training Missions.

EDIT: ______________________________
FPS seem stable with HAGS now - but in flight I have extrem stutters - head tracking and also e.g. the FPS display of open XR flashes even though I get 90 FPS.
Is there a Pimax issue with Tracking and HAGS or is this rather OpenXR or DCS?

Guys does openxr DCS multithread (mt) version work for you? For me not, and for some others. Non multithread version works.

I have older pitool (pitool 271, fw 298), might that be my problem? I do not want to change it, as it is fastest and most stable one on my systam.

1 Like

I currently have it running with pimaxXR 0.3.2 . Was a bit difficult, Windows itself blocked DCS functions.
If I were you, I wouldn’t change anything. MT is still pretty unpolished and with the 8kx brings me at time not enough pros over the cons.

Wait for a few more updates (DCS + pimaxXR if you’re not necessarily interested.

Edit: @BrziJoe - Oh yes, the fact that it doesn’t start for you could be because you have to expand the start parameters of dcs.exe.
( X:\xx\xx\bin\DCS.exe" --force_enable_VR --force_OpenXR )

1 Like

I have those parametars, same like before, but it does not start. I will try latest PimaxXR, thx

This is my thread in dcs;

1 Like

small tip, if you can start, activate OpenXR Toolkit. You can switch off everything in it. Just because the software is running in the background makes the picture quieter. Maybe a framecap or something.

At the moment MT gives me slightly better FPS with identical settings.


But a few weeks ago I had more in 2.8.


Still have to experiment. But I’m still a long way from the 85FPS from DCS 2.5.

But, overall with MT the picture looks sharper. Less Ghosting. Only the side view bucking is a little more. :frowning:

Yes piserver sucks with HAGS on…always has …causes mistimed frames. Interestingly if I turn it ON for Luke Ross’s mods, (at least for cyberpunk) which use oculus runtime, Improvement is 30% better! More oculus based game testing to come.

It works with a new version od PimaxXR 0.3.2, I will write on DCS forum for others. Thx guys for help! :slight_smile:

1 Like

I am using the DCS native via “\Eagle Dynamics\DCS World OpenBeta\bin-mt\DCS.exe” --force_enable_VR --force_OpenXR and did not need touch PimaxXR (its still on 0.3.0)…

1 Like

Are you using a shortcut and not launching from PiTools?

1 Like

From Desktop Shortcut

1 Like

Exactly, Purple is MT

1 Like


F18, Caucasus Map, on the Ramp (Singleplayer)
Shadows high, MSAA 2x, Ingame PD 0.9, Pitool 1.0, Normal FOV, OXR Toolkit: only NIS Sharpen 20 and FFR Standard
(10850@5.0, 3600c15, 4090@2850, VRam@1500, )

Alternative - with Ingame PD 1.1 - Avg 73 FPPS and Sideview stutters.


Update for me:
I installed the 0.3.2 PimaxXR Version - its unplayable for me - it keeps the frame Times almost the same but strangely only produces 8 FPS - I have no Idea why. I deinstalled it and reinstalled 0.3.0 and it was “fine” again. Only the Menu Sections are behaving strange (stutters) normal game is ok. Fog is bugged for me in Game - its a intransperent white layer in cockpit but fine whe doing outside view.

Now I need to get the DCS Update and see if that has changed anything . (HAGS still off - is it need on for 0.3.2 ?)

Hags off!

Hmm the last patch stole 10-15% of my performance. :cry:

1 Like