Can Pimax PLEASE just make one topic that lists the latest stable PiTool and PE versions?

Here’s my problem,
I re-installed windows the other day for a nice clean reset so am busy installing my essentials.
So I come to this forum to find which PE and PiTool I should be installing and 30 mins later I’m non the wiser.

All I seem to be finding is old stuff and no clear direction of where I should be looking.
Is there actually one place I can go in here to get the download links?!

If not can we make one please, and make it so there are no posting privileges in there to keep it nice n tidy? Just the patch notes and links. There seems to be 100 threads where we can yap.

Cheers all.
P.S. Hows the Pimax “In-House” version of the all-in-one PE + PiTool development coming along? It’s things like this that need to be well in place before the next headset comes out. At the moment having these two apps separate is clunky and very messy.


Unfortunately, it is a mess. We need more than a link to the latest. We need a page with links to older versions too, along with GOOD release notes. Why multiple versions? The latest PiTool isn’t what I’d call stable, nor were the last 3 before that. I need to reinstall PiTool before every use, otherwise SteamVR cannot detect the headset. It’s a weird issue, which doesn’t affect most users.

My suggestion is to download any PiTool version you find and run it. It will automatically alert you to the latest version and will update PiTool, the drivers, and the headset firmware. Hopefully, the latest version will be good, but it always seems to be in beta. As for PE, I can’t help you there, since I don’t use it.


Well after some digging I went here -
Downloaded the version on there which was the latest afaik and once installed and ran, I checked version and it confirmed the latest.

After that I clicked PE Home and it was downloaded and installed and all was good.
Tested a game or two in Steam and Oculus and everything fine.

Just leaving this here for anyone else :slight_smile:


sorry for off-topic:
I wanted to create a new topic in “pimax vr software”, but everytime I click on “create” I just get a popup
“You are not permitted to view the requested resource.”
I am new to this forum (hopping over from the old pimax forum) - what am I doing wrong?


I had a related issue a while back where i needed to run room setup in steam VR each time PI tool was restated.
it was due to an windows update going bad. so the user rights for programs and services on my pc was messed up… i could suspect that your problem might be some thing similar.

you can test it by creating a new clean windows user and see if the problem goes away whit the new user.

if the new user solves the problem… you can probably recover the old user the same way as i did.

I simply rolled all windows updates back until a point where i did know that i did not have the problem… and then the problem was gone… and then i let windows update apply the update again… and the problem did not come back…

witch are a bit strange… but proves that the windows update process are not 100% stable…

Hope that my history can help you.


If you click on the [+] on the top bar while reading this topic here it will create a topic in this Subcategory of PimaxVR Software

thanks for the reply, but this shows the same error as soon as I press “create topic”

1 Like

I have bumped your user level to see ifvthst helps.

Here are some screenshots


ha worked! Thx! So I was just unworthy of creating a new topic! :wink:
(edit: please feel free to ‘remove the noise’ in this thread)


There has been a couple of folks having trouble that are new. So may need to do some testing to fix up gaps.

1 Like

Hate to revive this thread, but I’m having the same issue. It may have to do with the fact that I created my account long ago but didn’t post much. Can you elevate my forum juju please Helio?

If you @Heliosurge he can elevate you The @ tags the person. As I just that he will read this now and see your new post. :smiley:

1 Like