Asgards Wrath Firmware .262

So I fired up AW for the first time in 4 months and started a new game. Im on a fresh install of windows 10 v2004 with pitool .262 and the latest nvidia drivers

the last time i played AW i was using firmware .253 which ran perfectly.

Now when I launch with Pitool regardless of pitool settings PP on/off FOV normal/large

when you get to the logo screen the entire view is wobbly. Its like you turn your head and the view swings into place a second later and then wobbles as if it were bobbing around in water.

It essentially unplayable.

I tried using revive and it doesn’t have the issue, but it fails to get past the difficulty setting , It just sits there with a blank screen with nothing but the flames visible on the ground.(if you play the game you know what I mean here)

Can anyone else confirm if AW is working for them launched from PiTool?


Yep and it’s not just AW. Also tried In Death (Oculus version). Same thing. Wobbles like crap. @PimaxQuorra
I just installed PT 262 today and was really enjoying that now my settings stay saved and all the flicker in loading screens was gone as well as some definite performance increase.
This will be painful or I may have to go back to 249. In Death is part of my exercise routine. Dam, I wish I had waited 1 more day.
I wouldn’t have updated had I know.
Thanks Pimax for not fully testing your frackin software before release. Sheesh.


A little further testing with my Oculus library also has A-tech Cybernetica doing the same thing.
The Climb, Lone Echo and Robo Recall worked fine though.
Will test more but a storm coming through now so later.
Kicking my a$$ as I hadn’t updated the firmware initially to 264 and except for 144Hz all the rest of the the pluses described in my first post were there in the PT 262.


Same for me, turned PP on and it worked again in AW for me…

1 Like

ok so this looks like a pandemic for Pimax FW 262. Im kind of relieved its not just me, but im super annoyed as AW is one of my favorites as is A-Tech and In death

lets make a list of all effected games. Ill try a few more soon.

I had the same issue a long time ago with different versions of revive and/or steamvr with robotrecall for example.

I dont remember the fix, but it involved a downgrade in revive version (I never downgraded pitool).

It is clearly an issue with the oculus wrapper (in pitool or in revive depending what you are using)

1 Like

Thats why I am still on 180 Beta with my pimax xr , never touch a running pimax :joy::joy::joy:


are you saying that you think revive is interfering with how pitool runs oculus games?

No. But as pitool is embedding some revive code, depending if you are using pitool or revive directly, you may have different behaviour with one or the other.

I did not downgrade my pitool, but I did downgrade my revive version a few times to ged rid of some bugs, crashs, or “wobble effect” as described.

I always launch my oculus games from revive first, and if it doesnt work, sometimes it works with pitool. But most of the time, I fix my issues by downgrading revive (and in the worst case scenario, downgrading steamvr, one time).

I see that different versions of revive are good with different games, or different versions of steamvr, so, it seems to be logical to have the same behaviour with pitool, except its more delicate to downgrade because you’ll lose some interesting upgrades.

It is my personnal experience, it may not be representative :slight_smile:


i will try 1 less version of pitool but keep FW the same to see if it’s still a problem.

they way it wobbles in Asgard you would think the gyro was broken.

Asgard was one of only games that worked flawlessly when launched from PiTool. When it first came out even Revive had problems. it wouldn’t run at all, even for vive users. it took like a few weeks for them to get Revive working.

Now its basically broken

Msn, and that reformat i did of w10. I didnt realize Asgard doesnt have cloud saves so now I have to start over. 60 hrs down the drain. But I dont mind the game is so good on Pimax.

1 Like

Just my 2 cts : version 2+ of revive seems to have problems with “old” occulus games for me. I always revert to 1.9.2 in this case (or before).

The wobbling effect, if its the same I experience, is software related, like a delay in the position processing.

I hope you’ll find a solution.


Bump! Latest pitool 262, Asgard`s Wrath not playable. It feels like motion compensation is turned on, and locked to HMD, but with huuuge lagg. I never used revive.


Phantom Covert Ops won’t work for me on the new pitool. It worked on the previous pitool I was on but just goes crazy on 262. I played it on revive this week but FFR didn’t work with revive and I was getting some stutter with all effects turned on. Seems to be an issue with the new pitool.


It would be nice to be able to change the revive binaires/code inside pitool as we want. Like dlls for example.
Better : choose the pitool-revive version for each game

Revive isn’t included in Pitool, it’s a completely separate tool that requires SteamVR. Pitool doesn’t run Oculus games via SteamVR.

The Oculus support is in the Pimax installation directory, under Plugin\OCSupport.

1 Like

True, but the Revive developer already said that he doesn’t want to talk to Pimax as they “stole” his code to put into pitool witouth asking and mentioning his work (an old thread in this forum talks about it).

My guess (maybe wrong) is that pitool includes some revive code into the OCSupport part, and updated sometimes? This is why I’m saying it would be a good idea to let users choose the “pitool-revive” version they want to use depending on the game.

1 Like

Yeah, I’ve heard that before as well, but until that is proven by the Revive developer there is no point in talking about it like it was an actual issue. All we have is a developer claiming something was stolen, without any proof or specifics. Not much to base a Pitool feature request on.


Yes, my point was just to say that I experienced different results with Occulus games depending on my revive version and/or my pitool version. So if somebody have issues, it may be useful to check with another version (revive or pitool).
It worked for me multiple times :slight_smile:

1 Like

Well the good news is going back to 249 resolved the issue with Oculus games. I didn’t roll back the firmware (264).
The bad news is the 144 Hz is a smaller fov and not near as good as it is in 262. I have grown to love 144 in DR, DCS, AC and Il2 in particular so will have to jump back and forth between Pitool versions until fixed.


this is decent news as i really dislike updating firmware