Any pimax 8k/5k+ owner that uses driver4vr?

Hello guys, I am having issues with having steamvr working with driver4vr.

Not sure if the problem is related to pimax/pitool/driver4vr/steamvr or if it is related just to driver4vr/steamvr .

Does anyone have encountered this issue with any other headset or with the pimax or else?

1 Like

I haven’t tried it as of yet. What are you using with driver4vr? Psmove, kinect, leap?

@jonnypanic & @LukeB i know has used it with the p4k.

1 Like

I would like to use it for replacing the vive controllers ’ s buttons with a console controller
. Then I would use cronusmax to replace the console controller with mouse and keyboard and hence with the captogloves


I would like to use it for replacing the vive controllers ’ s buttons with a mouse and keyboard

I would like to keep of the vive controllers , the positional tracking. I would like to Just replace the buttons on the vive tracker .

Not sure if that is even possible but if I do not test it, I would be able to see if that idea would work or not

1 Like

Is there any way to close completely everything related to the pimax headset. I have a feeling that there is some drivers of the pimax that are in my PC at boot and those drivers are related also to steamvr . If those drivers related to steamvr throught pimax are loaded in the background while I install driver4vr, the driver4vr does not install properly in steamvr.

1 Like

Pimax only has the piservers to my awareness. You might meed to poke Cronusmax to see if you can remap vive wands to a controller.

Are we sure that in any of pimax 's driver there is nothing related to a file called vrserver?

it seems that that file is a problem for starting driver4vr

I checked with cronusmax but it seems it is programmed for mapping only certain controllers :frowning:

Possible that steamvr does not offer any console’s controller support in vr ?

What I would use is this plugin:

I’m having a similar problem with just using an X360 controller, when I try to access Steam with the menu button, Steam VR crashes with the same error @MarcoBalletta posted, so this goes beyond external drivers(X360 icon shows in VR devices)

Pimax has it’s own pvrserver.dll (it’s version of vrserver)

SteamVR once Valve fixes it should offer alternative mapping. But atm Select/start csn bring up tge dashboard on a long hold press.

I use a wired XB1 controller the button beside the X box home button to the left (select on playstation) works to load the Dashboard. No crash on mine.

1 Like

I posted this on reddit and a couple other people that had the same issue. Someone had brought up fpsVR possibly causing the issue, but disabling it didn’t fix the crash. I had set up a custom binding using Steam Input settings(official), so that is the only other possible reason for the crash.(?)
I remember seeing someone having problems using Knuckles controllers, so I thought this may be a Pitool driver issue(with MarcoBalletta’s issue adding to confirming this).


It could be Steamvr are you using thr Beta? I am stuck atm on steamvr 1.14 & have no issues with this type of crash & always run fpsvr.

If your in the beta try opting out & reinstall steamvr.

Should I try to disinstall pitool and reinstall driver4vr without any pimax installed to see if it works and then reinstall pitool

I have this version of pitool. Should I change it anyway or stick with it ?

1 Like

@Heliosurge - Not sure if you were asking me or MarcoBalletta, I’m on the latest stable. I don’t want to hijack this thread, but I thought it may be related.

I asking to you and @Heliosurge .

So can you run driver4vr on pimax 8k/5k+ with no issue?

Which is the latest stable pitool to download please?

I tested driver4vr a while ago(I was using OSVR/PSMoves/Kinect), I should have access to the current demo as I had to sign up to the forum to download the demo. I didn’t like the pay model(annual fee), I know this has been changed, and I’m interested in what you are doing here as I’ve looked into something similar(keyboard input to vr).

1 Like

Worth a try. But like I said seems to be a steam input problem. Not the first time valve has messed with input device handling. Hotas was broken at one point.

As for pitool. I have been running 103r191. If your running 95 might be best to stick with it during your testing.

1 Like

Would you please be able to try also on your pc of you are not able to install/run driver4vr?

I your like to come up with a solution for playing vr games with gloves , using the vive trackers for tracking the hands and the gloves in place of the vive buttons . I know someone that with driver4vr and kinetic can do finger tracking too, but the problem is that when turning against the cameras of the kinetic, the tracking disappear

A year+ ago it was a 1 time fee for Driver4vr & just needed to phone home so to speak once a month. Did this change? Was $15.

May I have please the downloading links for both versions of the pitool?

For other people seems working driver4vr. I can’t run it. It might be just my problem :frowning:

I downloaded the latest demo, however since I have used the demo before I’m getting “You’re trial period has expired”, so I can’t test with Pimax.