8K Plus Unable To Properly Run Half Life: Alyx

I was using my Pimax 8K Plus tonight to live stream Half Life: Alyx and wow was it a horrible experience. The game is great but my 8K Plus is preventing me from enjoying it at all.

First of all tracking for this headset doesn’t work at all and constantly stutters/jitters and loses tracking, but I guess that’s on me because I bought base station 2.0s that say “Valve” on the back of them instead of ones that say “SteamVR”.

This second issue may be related to the first one, but my left controller constantly drops tracking as well. I’ve had both my left Index controller and my 8K plus replaced already and these first two issues have been persistent across both

This third issue I’ve only been getting after the replacement 8K Plus. The displays seem to have trouble displaying certain things (I’m not sure exactly what butt it happens more when looking at bright colored things). The displays start distorting the image when this happens. Also keep in mind that this issue is not the same as the jitter from my first issue I listed. It is a separate issue that happens on top of the first issue.

Now all of these previous issues I have actually happen in every game I play, but this last one only happens in Half Life: Alyx. In Half Life: Alyx, when you put your head through a wall, every visible part inside of the wall becomes a really bright orange color. When this happens, my Pimax 8K Plus’s displays just completely shut off. Its not just displaying a black image either because then I’d at least be able to tell the displays are lit up. No, the displays just completely turn off and go pitch black.

I know its a long shot but if anyone has had any of these issues and has found a way to fix them, I’d really love to know. I’ve been fighting support staff for this stuff for over a year and I just can’t take it anymore.

I have 8k+ and i played Alyx wihtout problems.
No tracking issues at all.
There was some display problem with blood on floor, but i fixed it somehow… i dont remember. Probablly paralel projection. Not sure anymore. But i played alyx and it was great!
But that’s pimax… I tried firmware update yesterday and didnt work. Now i cant get it work for 2 days straight! Tried several firmwares so far including one that worked until yesterday, i have it backuped, and non of them cant pass 10600 error problem.
Yeah… Pimax…

1 Like

My left display panel switches off when a bright light suddenly appears in the display however this only happens with 90Hz and 110Hz but NOT with 72Hz.

This is known to Pimax and I have been offered a replacement.

The orange color is just how HLA handles putting your head through the geometry.

You don’t need PP, the blood decal problem is solved by putting ‘sc_no_cull 1 +vr_multiview_instancing 0 +vr_enable_volume_fog 0’ in the launch options for the game in Steam.


“Valve” marks the newer hardware revision (ships with Index), “SteamVR” the older one (ships with Vive Pro), but I do not think there should be any performance difference between the two.


You’re right about there being two different versions but unfortunately there is a performance difference between the two. I’ve been discussing it with the Pimax directly and they said this is a known issue. I also used to do warranty repair for HTC on their headsets and other VR gear. We referred to them all differently by base station 1.0, 2.0, and 2.1 because there is a difference between the physical parts in the “SteamVR” and “Valve” base stations. I’m not even sure if HTC ever officially sold 2.1’s under their name but it wasn’t uncommon for us to receive products that hadn’t been released yet and products that weren’t 100% HTC for us to repair.


Thanks this is actually pretty helpful. This is the exact same issue I’ve been having. I wonder if lowering the refresh rate would also fix the screen distortion I get in general with bright colors. Thanks again for the tip. I’ll give it a try!

I’ve been talking with Pimax staff directly about the tracking issue and I’ve been told by them that it has to do with what version of base station 2.0s you’re using. If yours are tracking properly, would you mind telling me if yours say “Valve” or “SteamVR” on the back? I’ve been told by Pimax this is my issue but it would be nice to know from another user if this is actually the case. Mine say “Valve” on the back and I got them with my Index controllers on day 1 of the Index’s release.

This tracking issue can be from unnoticeable to incredibly frustrating for me. Last night in my playthrough of HL:A I got to a part where I was having to disarm motion bombs and the tracking issue would just throw me into the bombs and trip them while I was doing that.

I was streaming last night so I can just show clips from the parts I’m talking about where tracking just failed on me. The first one the controller looses tracking and in the second one the headset loses tracking twice within 60 seconds. All of these happening on the same part of the game.

my base stations are version 2.0 as well. On left top side i have Vlave logo, bot on right sire under serial number it says “SteamVR base station 2.0”

My tracking was ok in Alyx.
I got my pimax without stations or controlers, and i got them separately later on.

1 Like

Were they specific about what exactly is the difference between the two revisions which should affect the headset performance?

For the left controller you need to buy a steamvr dongle and pair the controller to it. It’s really frustrating Pimax hasn’t solved this. Flat out a hardware issue in your hmd, my 5k+ has the exact issue. I use a usb-c to usb A adapter attached to the HMD and have a dongle attached. Tracking is now flawless, but man it’s ridiculous to have to do this. This issue is specific to index controllers and does not happen with vive wands.

this one is cheap. You can probably get away with just plugging it into your pc, depending on the size of your playspace.

Much as all of this sucks, pimax hmds are the best way to experience alyx imo. Nothing compares once its all working.

I heard of this solution. I really want to avoid having to spend more money on things just getting the headset to function properly if I can. I may just end up getting one of these though because I really feel as if I have no other choice. I’ve been told by support that they want to fix this in a PiTool update but there hasn’t been an update for it in a month or so and the features they keep talking about adding in the weekly updates aren’t really addressing this issue either.

Interesting you have the same as mine. I really have no idea what could be wrong with my tracking now because that was my last idea that could have possibly been the issue.

1 Like

Unfortunately they didn’t, they just asked which one I had so I sent them a picture and they responded saying, “Unfortunately, this is the compatibility issue I’m trying to solve. We’ll update you on the development schedule later”. This was a month or two ago and I haven’t heard back yet. I don’t expect them to instantly fix this but it would be nice if they kept me just a little more updated on if they were getting to trying to fix this issue or not yet though.


They have been telling me the same since October 2020, that they will fix it in a firmware update, please be a lillte more patient… October 2020 :rofl: How patient must we be before this is fixed…
I had my 8KX replaced due to bad tracking (and other hardware defects) but still tracking is not up to par. I’m using Valve branded LH2.0’s as well.

Hi there. I ordered directly via steam, received “Valve SteamVR Base Station 2.0 Model 1004” only little jitter. No jumping or flipping issues or flaws! [Except the well known bugs from SteamVR last Year] my origin V1.0 from HTC Vive work without a flaw, too.

1 Like

What model Pimax headset do you have?

have a 5K, where that works as well and recently changed to 8KX. Both work without a flaw for me

1 Like

I hope they can fix in pitool, but I literally waited for 4 months for this and I don’t recommend you do the same. This has been an issue since mid-early 2020 https://community.openmr.ai/t/some-controller-compatibility-issues-with-index-controller-some-info/24313

1 Like

Unfortunately, if you don’t also have an 8K+ then I wouldn’t expect you to have the same issues since the hardware in the headsets is different in different models.

@Hailbot If you have any tracking issues have you tried this?

Turn off your HMD.
Navigate to & delete all the contents of:
C:\ProgramData\pimax\runtime\config\lighthouse (don’t worry - they’ll be recreated automatically when restarting the pitool service)

Turn on your HMD.

If you still get jitter on your controllers get a dongle as above - I have one and my tracking is always spot on but very occasionally I need to delete the LH contents folder after a few Pitool updates.