8K + - Firmware Update gone bad

After my 8K X did not want to be recognized any more…
(New Hardware with APU - seems that got PiTool confused and said DP not connected).
… I got the 8K + out of its box - not much used.
The PimaxClient detected it right away and suggested a firmware update (its been in its box very long). The Update completed but kept resulting in status failed and as mentioned here:
PIMAX 8K - Firmware update process stuck - SOLVED - Pimax 8K Series - OpenMR | Community
it stayed in the loop.

So I dug up again:

PIMAX FOR DUMMIES #1: Getting Started with Pimax 8K & 5K+, Tweaks, Hints & Firmware Update Tutorial

and tryed the 3, 2 1 finger thing at the end and

Pitool & Firmware Links - PimaxVR Software / Release Notes - OpenMR | Community

I did find some P1, P2 and P3 without dfu ending files in the Pimax folder
C:\Program Files\Pimax\Runtime\dfudriver

but besides not being sure which one to use for the 8K +
( I also downloaded the P2_RELEASE_M264_t20200508200801_r96b28a3.dfu )

the first problem is that the flashing tool DFUupgrade does not recognize the HMD. (Be sure to not forgett to kill als tasks and services from PiMax (search for those starting with Pi )

Are there any further Tips for getting it “recognized” again? I did not try all USB Ports only the one it worked on initially (so I will be doing that now).strong text

1 Like

Ok … solved…
I ran the stm_dfu_3040_64.exe manually and it said it updated the microcontroller driver - after that the DfuSeCommand.exe worked and updated

1 Like

Seems talking to yourself can help :wink:
and to make it complete, now also the normal update worked.

@PimaxQuorra could it be that the driver “state” is not checked and can cause issues? Maybe check with the devs - I updatd the Motherboard and CPU could be that the driver from stm_dfu_3040_64.exe was not in a workable state after that hardware update and needed reinstall.


Jist to confirm are you saying this client has the forced firmware update again?

No, it showed that there is an update and I clicked it but it left it in the update state. I guess the hardwäre change (CPU Mobo) left the driver to access the HMD Hardware “unfinished” - or some other mixture of things.

1 Like

Got it!

I will pass along to our software dev.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.