5k+ works for a few seconds - then screen blank

Does anybody else have this problem?
Got my 5k+ today (great! :slight_smile: )
After plugging everything in the led goes green. Then I start e.g. the SteamVR Home application.

I can see that the screens go on. And if I am fast I can even put the headset on and look around. After a few seconds the screens go black and the led on the HMD red though.
The only reliable way to get the led green again is to shut down computer and HMD, wait for a few seconds and start stuff up again.

Has anybody a similar problem?

AMD Ryzen 1700
NVidia 1080 TI (the standard blower type one from NVidia). driver: 417.35 (just updated to rule the driver out)
Windows 10 (1803)
Monitor: 3440x1440 60 Hz, connected via DP (runs in DP 1.2 mode)

Currently have disabled Lighthouse mode (as I don’t have the basestations here atm).

Edit: Using PiTool V1.0.1.91
Even in the “led red mode” I get “pass” and “connected” on everything in the diagnosis tool (including HDMI/DP).

I run my monitor also via Displayport - would I need to switch to HDMI for the monitor when connecting the HMD via DP? (Would be odd, usually several DP devices shouldn’t be a problem?) Have only one single monitor connected additional to the HMD.

1 Like

Make sure the power connector is plugged in all the way on the headset. Hopefully the power cable itself isn’t defective.

1 Like

Hm, the connector seems to be hardwired to the HMD? Cannot plug this out or in (at least it doesn’t look so - haven’t used force…)

Edit: If you mean the connection between power plug and the connector box - yes, that’s connected. The red led at least gets current all the time :slight_smile:

Yeah, if I recall correctly, it’s not actually hardwired to the hmd. I mean, you don’t really need to unplug it and plug it back in. Just push on it to make sure its fully plugged in. Try pushing the power connector going into the hmd. Just to make sure it’s fully connected and not a little loose.


You are right. Got it unplugged and put it back in as tightly as possible.
No change. Actually now I haven’t gotten a green led even when switching everything off :frowning: (perhaps I didn’t wait long enough?) Still under HDMI/DP it shows “Connected”

Try swapping usb ports on your computer.

1 Like

Thanks, exactly what I need :slight_smile:
Let’s see…

apparently that didn’t help :frowning:

Did you try a usb 3.0 port? Also it might be a long shot, but maybe your computer got confused and is trying to push 60hz on the Pimax because your monitor is running at 60hz. Try unplugging your monitor while you have the headset running maybe?

1 Like

Yes, it’s plugged to a USB 3.0 port.
Now I get “Disconnected: Diagnose (10935)” when plugging in USB and “Diagnose (10535)” when unplugging it.
Odd thing is: In the diagnosis tool I get
USB: Connected, USB 3.0: Pass, HDMI/DP: Connected etc. when USB is plugged in (but still 10935)
USB Disconnected, HDMI/DP: Disconnected when unplugging the USB cable (even though HDMI is still connected).

Have also tried to completely uninstall and reinstall PiTool - no sucess.

Device manager doesn’t show any driver problems

Hmm. I don’t know :thinking:
Hopefully you can figure it out though.

I hope, too. Thanks for trying to help though, much appreciated!

One more thing you might wanna try is re-installing steamvr.

Might give this a try. Unlikely to help though as before the led went green before even starting SteamVR. Seems to be a lower level problem.

I have heard peeps having issues with running Steam beta version. I didnt even know which I installed when installing steam but mine is NOT the beta. See what version you have and “maybe” that might be an issue for you??

1 Like

Hm, should be the regular Steam version. The about box contains these infos:
Build date: Nov 26 2018 12:19:02
Steam-API: v018
Steam-Paket-Version: 1543346820

Reinstalling SteamVR didn’t help. Out of ideas atm., wrote a support ticket with Export Log.
Will report when there was an easy fix.

1 Like

Someone in here had a bad power bank. They bought a new one and it fixed the issue. You might have the same problem


Uninstall pitool and delete the config folders at C:\Users\John\AppData\Local “pimax and pitool” folders. And reinstall everything.

I have had my software save bad settings in the config folders that do not get deleted on a uninstall.