3090 Ti + Pimax = Broken?

Just upgraded from a 3080 Ti to a MSI 3090 Ti* and my Pimax 8K-X is not recognized. Googling and of course I found some very recent (mostly Reddit) threads dedicated to this same issue but no clear solution. Everything work properly on the 3080 Ti of course.

Is there a solution? I won’t have long; need to return the card inside the return window if I can’t get it to work.

(edit; my other Pimax HMD, a 5K+ is also not recognized on this card).

  • I know this is an absurd upgrade from the 3080 Ti, but I have three older cards to sell off and am worried that the 4000 series may have availability issues like we’ve seen for nearly 2 years now on the 3000 series. So I figured a 3090 Ti would be good to have in case 4000 series availability turns out to be 1+ years away and I should be able to recover about 2/3 the purchase price from selling of the older cards.

H i:
Unfortunately, the current 3090Ti and 8kx are not compatible. We are trying to work with Nvidia to find out the cause, but everything is slowing down because of the blockade.
If not necessary, we recommend you stay at 3080.



Thanks for the response! Can anyone else confirm? If this is truly the case I’ll start the 3090 Ti return process ASAP.

That doesn’t bode well though. It’s hard to believe Nvidia could screw up so badly that the card won’t work with Pimax HMDs, when all their other current cards do. What’s that about?

Wow!!! That’s Crazy talk seeing how i’m running a 3090 TI FE with my 8KX spectacularly.


@cruser_icu Anything special you had to do? I’ve verified that neither my 8K-X nor my 5K+ is recognized by my MSI 3090 Ti. Popped my 3080 Ti back in and all is good.

Drivers and PiTool are fully up to date and the system is effectively completely fresh and clean. It’s a recent build with a recent clean install of Win10 and zero (I mean it) extra software - it’s a dedicated gamerig with absolutely no usage of any other sort; so this being a weird software incompatibility is extremely low (especially as everything works without flaw on with the 3080 Ti.)

1 Like

There was nothing special that I did to get it working, I pulled out my old GTX 1080 installed the 3090 Ti, did a new driver install and it worked flawlessly. I have since updated Pitool to .275 and auto firmware update to .299 so I can run 90hz refresh rate.


that’s really crazy!!
Could you please show me the log? We need to check it since you are the first one to run successfully


What log? I would be more than happy to post the log if I knew where to find it.


Log sent !! Hopefully pimax can figure something out for people that are having issues, I find it really hard to believe I’m the only one that has a working 3090Ti with the 8KX.


I can also confirm my EVGA 3090ti runs just fine. I did not need to do anything special it just started right up. I have an 8kx and my Nvidia drivers are still on 512.16 though don’t know if thats why.

There was a 3090ti hotfix released from 512.15 to 512.16 that 3090ti owners needed to download maybe that is relevant?


I’ve read that the 3090 Ti consumes way more power than the 3090. So your electricity bills are going to be higher for slightly better performance than a 3090.

I think if you’re buying a 3090ti then electricity bills aren’t much of a concern lol


Current driver version is 512.59 (it’s now the same release for 3080 and 3090 series etc.) I’m not going to try an older version as I don’t want to break things and ultimately I would need the card to work going forward anyway; I wouldn’t be able to keep a card that only seems to work on an older driver version.

Hi, I have the same issue with the Rtx 3090 ti not working with the 8kx. What firmware do you use cruser and was the 8kx a recent purchase? (Version 2.0)?

Hi Gullrum, I’m using the .299 firmware and Pitool .275, and nvidia driver Version 512.59. My 8KX is not a newer version, it’s a kickstarter trade up version from 2019.

Thanks for the quick response. I am not sure that firmware will work on my newer 8kx version and a bit hesitant to try…

I have the old 8kx as well so it might be the newer model that is incompatible

1 Like

Thanks for the quick feedback Zuiquan1, I presume you use Rtx 3090 ti as well? Really gutted I can’t use the headset… got two rigs and both have been upgraded to Rtx 3090 ti…

Once I installed Pitool .275 the firmware automatically downloaded and installed the first time I started Pitool.
I can’t say the .299 firmware will help because the 3090Ti worked before I updated Pitool and firmware.
What I don’t understand is mr_spongeworthy also can’t use his 5k+ with the 3090Ti. Maybe @mr_spongeworthy can chime in here and let us know if his 5k+ and 8kx are newer devices.

The initial error I got was 10936 (dp not connected). I updated the firmware to the latest version shared on the pimax homepage and the headset got bricked (cannot find usb - 10500 error)… raised a ticket but still waiting for a solution…

1 Like