3080TI 10600 Error

i just bought my EVGA Geforce RTX 3080 TI FTW3 HYBRID and i cant get my 5k super to boot at all on the headset no matter what display port i plug it into it used to boot just fine on my 5700xt. I dont know what to do about it anymore at this point i have tried everything does anyone know anything about this?

Everything was working till he got that card.

We cant get it to fully load, we where on pitool V283 and tried V284.
he might just need a firmware or something for his 5K Super to supper the 3080 TI??.

i had done teamviewer, and tried DFU.exe and it shows up fine(it can detect the headset).
just pitool wont load it…

It best we ask here @Heliosurge @PimaxQuorra
(i want to avoid support if we can…)


@PimaxQuorra Ticket number so you can talk to these support guys #39262


Checking with our tech specialist.

Maybe I could get a debug firmware that fix this issue.

1 Like

Thanks, i will let him know.

we even tried swapping his Vbios slider from OC to Normal on the GPU(we even have the latest Vbios).
that did nothing, along with uninstalling V284(clean, deleting all traces from Appdata and programs)
and trying the latest Client V1.10, and still no boot.

we included the Logs that client can do, and a screenshot showing its only the DP with 10600 is the issue.


alright well get back to me on this soon i would like to be able to use my headset soon

Hmm. Does EVGA still have support for their cards?
I hope it’s not a defunct card or anything physically wrong with it.

Since EVGA have stopped making nVidia GPUs. AFAIK

I mean, if they have support now, that’s great, but it won’t be around forever.

i had been diving into this issue.

As i too want to get a new GPU (either a 4080 or 4090)
at first i was going to get the same card, but if its going to be an issue.
it needs to be resolved.

but, i was reading more on people like @Ben10dom1 had, and on the 8KX(5K Super too)
with the 3080 ti/3090

It could be that he does not have a fiber optic cable, and its a cable compatibility too. :thinking:
been reading it on here: 3090 Ti + Pimax = Broken? - #58 by Gullrum

maybe he needs a optical cable sent to him or something.
(have support send one, But we still need to figure this out regardless)


yes EVGA still supports their cards they just said they are no longer making new cards already existing ones still have support

1 Like

well after getting a debug firmware my headset stopped working.
so me and @KingTodd tried flashing back the firmware and now my headset is bricked on whitelight.
also it turns out my two cables are no longer working they also got bricked in the process of getting this fixed so would it be possible to get a new cable? preferably the fiber optic cable as i have seen from other posts on this forum that the fiber optic cable fixes the issues.

We Tried the P2 and P3 Firmwares that are included in the pitool software and neither worked headset is still stuck whitelight.


1 Like

Update we found a older firmware online and reflashed it to that and it worked headset is unbricked, i just need a new cable now because my two cables are bad.

1 Like

Hey Dom,

I will discuss the matter with Yvette, and she will handle your case. While I cannot guarantee any specific outcome, I will do my best to work with our technical support team to find a resolution for your issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.