Xortex in The Lab not working with Sword Controllers?

I was on the road for a couple of years and unable to use my 5K+ as it was sent piece by piece, so I had everything shipped to my brother’s until I got settled this past December. I recently got the Sword controllers and since I am now in a house again, hooked everything up so I can finally play - after waiting for 4+ years (as a KS backer).

Anyway, of course, one of the first things I tried was The Lab on Steam. All of the little modules work except for the arcade game, Xortex 26XX. I can start it, but in the room where it says “grab the ship to begin”, I can’t grab it. When the swords get close, the ship gets the yellow border, and it shakes a little, but clicking does nothing. My robot hands disappear. Once disappeared, they don’t show up again. Getting close with my invisible hands repeats the yellow border and slight shaking when I click. Nothing else happens.

Anyone else seen this? Am I just doing something wrong?


Haven’t tried the sword controllers yet. Have you tried vive mode in pitool?

1 Like

I thought I did, but will double check tonight. I assumed that feature would affect HMD rather than controllers. Still, I played and finished Chapter 1 of The Gallery with no problems, along with several demo-like (short) games. My brother has the original Vive and I used those controllers years ago. The swords are much better. Looks like celt didn’t like my hijack of that other thread. Sensitive I guess. I appreciate your patience.

Man, I really don’t feel like working today. Just want to do more VR now that I finally can.



If you still encountered any issue with the Sword controller, please let us know!

Some users are reported the Sword has a sensitive touch, it might be vary based on user’s experience.


I’m going to suggest that we rename this Topic to “_____not working with Sword Controllers” as I think now that people are actually getting them this is likely going to be the case for ALOT of games.

Funny how the whole excuse for why we didn’t get joysticks was to prevent “compatibility issues” with games because it wouldn’t require developer intervention.

lol , …indeed :crazy_face:

Is the Grip button analog? if emulating a Vive wand I hope the trigger point is somewhere in the middle of the range as if it requires being pressed and held all the way to 100% it woukd be annoying and if its too light like 5% it might be to sensitive.

oh and @Heliosurge why haven’t you used yours yet?

I assume vive mode emulates wands but shouldn’t that be the default?

What else can they emulate?

Is there a new UI in Pitool for sword controllers that allows us to configure how they work?

I’m assumung PImax Experience doesn’t show a model of their own sword controllers when in use and no updates on it since they killed it and have mentioned nothing about it’s replacement in a year.

Could be a strange bug. Hard to say. Figured worth a check with Vive mode.

I have a Razer Hydra that emulates Vive Wands through a driver in steam.

Have to clear space to setup LHes. Only recently was able to ship some clutter. My Uncle is up visiting as well so haven’t had much time to indulge things.

As mentioned haven’t tested. But judging by Quorra’s comment sounds like at present only SteamVR bindings setup.

Indeed likely haven’t added skin models for Steam either. Hydra had them though(in Steam).

1 Like

I didn’t get back in to The Lab yet, because I was messing with the Oculus app. I tried some free game - maybe called Farlands. At first, I launched from Experience from Oculus menu. The controls were super crap and I could barely get out of the game. I then installed revive and it worked just fine. I think buttons were remapped a little, but worked good. I intend to still get back into The Lab and try the setting change that was suggested. I’m also working on two construction projects at home, so we’ll see if I can get to it soon or not.

A couple of notes about the Swords: 1) you have to have a recent version of PiTool. It adds a fourth controller selection when you add a controller. 2) In SteamVR games, you sometimes see the correct outline for your controller. I’m not sure why it isn’t all the time, but it is cool. It includes the light on the front in the color it is currently emitting. 3) They are very comfortable.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.