World scale is wrong

Hello Guys, I really have a scale problem with my Pimax 5K+.

Worlds are too big, and that’s a big immersion breaker :frowning:

I saw that some other people have the same problem, but can’t find a solution. Could it be a hardware problem with my hmd ? Like a default on it ?

I didn’t have the time to really play with my Pimax until now and it’s soooo frustrating to have this bug while playing Alyx…

The problem appears in every games with the 5K+ but everything looks good with the vive.

@SweViver does this ring a bell to you ?

Thanks for your help.


Experiment with vertical offset it will change world scale.


I fixed my world-scale issue (things were too small in Elite Dangerous), by reducing my hardware IPD setting. Here’s a post which might help…

1 Like

Thx for the advices. I will try asap.

I’m my case the world is bigger despite the floor is set correctly. It’s like 1m in real world is only 80cm or so in VR.


In my case, when sitting in the cockpit in Elite D, my arms seemed too skinny and my hands were too small and far away.

Reducing my hardware IPD by 2mm fixed the problem for me. I had gotten used to the scaling issue (I thought it was a problem in ED) and played that way for months without any eyestrain or other problems. However, my immersion has improved, now that the world scale feels “right”.


This has been a problem with Elite since it was released, Even My old HTC Vive has the same problem.

That’s what I thought too. For me, reducing my hardware IPD by 2mm completely fixed that. ED scale is now correct. You might want to try that.

1 Like

Oddly i do think this has to do entirely with HMD positioning and IPD setting. now that I’m used to it, 120Hz on the pimax feels better than my vive or quest in 3d depth and world scale. Definitely took months of adjustment though, tbh. The deluxe audio strap helped immensely.


Hello Guys.

So I did my tests. CC @PimaxVR

I found on reddit a solution to the scale problem.

So IRL my IPD is 66. On the 5K+ it’s set at 70 because It’s the best value I found to reduce eyestrain.

As I undestood, The Pimax don’t communicate the IPD value to steam VR who applies it’s default value wich is 63. This is why world’s scale is wrong.

As I saw on Reddit, I add the line " “ipdOffset” : +0.007, " (70-63) in the steamvr.vrsettings file and it works !

BUT -I have to do this everytime before launching Steam VR
- If I launch a game directly from PiTool to get the correct setup saved for the game, It doesn’t work.

I try to use the “IPD Offset” of PiTool, but it doesn’t work.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.