Will PiTool 263 force a firmware update on my 8K-X?

Looking for a PiTool version that does not suffer from the Oculus 80%/90% max GPU usage bug and which also does not have a 1/3 rate Smart Smoothing mode and which will also detect my 8K-X reliably. The oldest version of PiTool I’ve tried is 271 (no 1/3 rate), but it does not detect my 8K-X reliably. 272 does, but it has the 1/3 rate option, which is a real bummer. V263 was mentioned in a thread as pre-dating the Oculus 80%/90% max GPU usage bug, so I would like to try v263, as long as I know it won’t flash my 8K-X firmware. I keep a sector-clone of my boot drive, so I can easily test v263 without risking problems on my main boot drive, but I don’t even want to touch it if it will flash my firmware. Anyone know the answer?

2 Likes

Okay if your hmd firmware is newer than the one pre packaged with pitool it will not force a firmware update.

However. Install pitool 263 with headset not connected to pc.
After install open pitool program folder.
Goto pitool\dfudrivers
Move/delete files p*.* you may see something like
P1
P2
P2.dfu

These are the firmware packaged with pitool. Once backup/deleted. You can run pitool with headset connected.

At least has worked for me.

What 8kX firmware are you running?

3 Likes

@Heliosurge @hammerhead_gal Thanks for the tip. I booted from my clone and tried 263 as well as a number of other versions without success. The oldest version that will detect my HMD is v272, which has both the Oculus GPU Usage bug AND is the first version to completely destroy the usability of the Smart Smoothing feature by adding that 1/3 disaster. Someday I hope to find out my 8K-X experience is no longer being ruined by poor software, but that day isn’t today I’m afraid. I’m on firmware 2.1.255.299

Try downgrading FW to 296 debug and update to maybe 298. Might work.

Reason why 296 first is to clean 299 out then install 298. This might work for 263. You may need to stick with 296 maybe.

Fw 299 is useless for me as it breaks compatibility with 1080ti