VRServer.exe running even when Pimax is powered off

I noticed that when I physically power off my Pimax 5k+ (via the power button), my GPU spikes to 80% load. The only way to fix it is to manually kill the “VRServer.exe” process in task manager.

Virtual Desktop (the only thing I care about) runs perfectly fine even after I kill VRServer. I don’t even need to have SteamVR running, and VD works great. But as soon as I power down the headset, VRServer auto launches and my GPU load spikes.

Anyway to stop this?


*Using latest pi tool and drivers (1080Ti)


@Sean.Huang might be interested in this issue.

1 Like

Set the PiServiceLauncher service to start manually, then enable it/disable it manually from the services tab of your task manager.

Is it Pimax software? On my (albeit old) PiTool there is no such file.

I’m pretty sure “VR Server.exe” is a steam/valve thing. I think it’s the ‘steam home’ environment that is running (and causing the GPU load spike)

1 Like

Wait wont I have to manually enable it EVERY time I use the headset then? Or is piservicelauncher not needed just for Virtual Desktop to work?

*well just tried changing from automatic to manual startup. VD still works (that’s good), but VR Server.exe still launches automatically when I power down the headset.

VR Server has the blue steam looking logo, and another process ‘steamtours’ seems to also be spiking the GPU. I’m 99% sure this is just the steam vr home environment that is killing the GPU, the question is, why in the crap is it running (and launching automatically) when the headset is powered off…

In the SteamVR settings (General tab) you can disable the option to use SteamVR Home. You can still run it at any time like any other app.


Thanks I think that did the trick. With SteamVR home disabled this VR Server.exe still auto launches when powering down the headset, but it doesn’t spike the GPU like before.

1 Like

vrserver.exe is located here:

C:\Program Files (x86)\Steam\SteamApps\common\SteamVR\bin\win64

When I had a rift cv1 I was renaming all the exe’s from this folder to force some games to use oculus native mode (pcars2 for example).

Rename vrserver.exe to smthg like vrserver.exe.bak and see if you can still use the Pimax without issue (and vrserver.exe should of course now not launch anymore).

Thanks for the tip but renaming vrserver causes steamvr to spit errors when launching VD

1 Like

Thanks for the feedback, bad idea then^^