USB device not recognized

Been an issue for almost 1,5 years after I received the device. Been just googling this issue from time to time and hoping it’s something that could be solved by a firmware update.

This error usually occurs on a 2nd use (sometimes 1st) after a boot and gets resolved only by a reboot (sometimes multiple).

Other symptoms that have happened and may be related and are resolved by turning the headset off and on:

  • Headset not turning on (no green light). On the current Pitool, this is accompanied with a massive IO blocking going on on the background, indefinetly until the piservice is stopped. (no CPU usage, mouse input becomes jittery).
  • Headset displays inverted colors on one or both panels.

MB: GA-AX370-Gaming 5, everything up to date (bios, chipset, etc), no extension cables. Been through multiple clean system installs and different GPUs in the 1,5 years.

Love the features but it’s been a real pain using this headset.

Is there any way to resolve this issue? Either by replacing the headset or getting some technical details on what usually causes this, so I could fix it myself. I’m in EU.

1 Like

Are you using MB RGB lighting software? Known to cause issues with USB. Also try to reduce usb devices to only what is needed. Do not use front panel USBs as they often can have problems. Try different ports.

What gpu are you using?

I’ve tried that. Even without the keyboard and mouse. So no physical USB connections besides the Pimax 5k+ (no mouse and a PS/2 keyboard). Currently have no mobo vendor’s bloat installed at all.

GPUs: Radeon VII and Radeon RX 5700 XT, currently back on a Radeon VII

1 Like

I know in early days AMD Vegas had some issues with Pimax 5k and 8k headsets causing the mouse freeze/jitter issues. I had hoped AMD and pimax have had this resolved. I include AMD as During my testing after receiving the headsets the Amd r9 390 gpu ran perfectly.

May need to compare with other users as I believe the Amd Gpu compatibility issues have been mostly resolved. As something to try would be an USB add on card as some USB chipsets are known to be problematic with some vr headsets.

1 Like

Well I can test it with an AMD’s X470 / B450. I don’t think it’s GPU related. I’ve had no issues with Vive headsets. USB clutter (controllers, wheels, USB audio interfaces, vJoy) have had no effect on the frequency of the issues with Pimax.

Are you recommending any specific USB cards for this, something that exceeds all the specs in the world?

In january, the latest pitool (beta) was always resetting all of my USB devices when Pimax headset was connected and starting up (kb, mouse, headphones, wheel). USB errors were less frequent then. More frequent now and back when it first arrived, fresh from the production line.

I’m also building a PC for a simrig with a Simucube 2 and I’d prefer not to get injured when using with a Pimax headset. A headset that could potentially mess with the usb controller or stall system interrupt handling.

1 Like

It was indeed GPU related when the headsets were released.

I have a Ryzen 2700x on a b450 Asus with 1080ti no issues. I also have an i5 6500 z170 chipset with amd r9 390.

A buddy of mine we tested on his threadripper with Vega 64 and on his co workers i7 8700 with Vega 64. Usb connectivity issues, mouse jitter issues and mini freezes.

Though am sure some other amd 5700x users have had this working since then. If you have an option to test with an Nvidia card you may find it will work better.

Though it might be an idea to try the b450 and 470 mb as it may make a difference.

In those early days Vega gpus and the 2 series prior had driver issues on Pimax headsets. Both Amd and pimax were aware. And am sure a few users reported it was working much better since with both being updated.

Vive and Rift headsets were not having the same difficulties on Amd gpu

Currently I have a B450 and RX 580 to test it on. I’ll post an update if I’ve gotten around to test it. Maybe there were less issues or none of these specific USB errors with 5700. I don’t remember the exact timeline. Was using 5700+Pimax since mid-february for a few months and then took a break since may until now.

1 Like

YeahnI would give it a try. Now from memory it was Fury, rx480, rx580 and vega based. But as mentioned recalled users reporting it was working on some of these models later. Specifically remember the 5700

Still seemed like a USB related issue. I also found out that my x370 mobo’s USB 3.1 Gen1/Gen2 ports were all color-coded the same. Gen2 seems to be working better so far.

Test results:
X470 + RX 580 + USB 3.1 Gen1: Complete silence. Device showing up as a “Generic USB hub”
X470 + RX 580 + USB 3.1 Gen2: Reliably getting green light and display backlight (without using any lighthouses, no logo, no tracking or setup or other VR softwares).
X370 + RX 5700 XT + USB 3.1 Gen1: “USB device not recognized”, Pimax restart loops. The difference with Radeon VII seems to be that so far it hasn’t required any system restarts for a chance of getting the HMD to start.
X370 + RX 5700 XT + USB 3.1 Gen2: Did 3 HMD restarts, and had no issues after an initial fail (no green light) and piservice restart (no reboot since Gen1 trials).

1 Like

Hi ,

— I recommend grabbing " usb deview " ,
Then checking the output from that. Its great for getting
detailed information on * all usb * references. That will help
to step through trouble shooting.

This is the same program " Valve " recommended that
developers use to figure out usb issues. Its a free download
and has been super useful :

Nirsoft : USB deview
[ ]


Hello, I am OpenMR and pimax BBS moderator, I found your problem has not been well solved, it makes me very concern you in piamx BBS of experience, so I would like to suggest you may feedback to our technical support for customer service, he will provide one-on-one make you satisfactory service to help you solve the problem, in addition to ensure the neatness of the layout, I will hide this topic, this is to submit technical support work order link:

1 Like

Hi bot/human/canned response.

In case it wasn’t clear from my previous response: So far everything seems to be working reliably when using a USB 3.1 Gen2 specifically.

If you want, I can submit a ticket(edit: submitted) and/or help to debug it on USB 3.1 Gen1 if Gen2 is not a requirement by the specs.

Don’t know how wise it would be to hide the topic.

Obviously, it is a more sensible choice to raise a ticket for technical support, rather than seeking help from ordinary people in the forum. This may be a usb interference. I am not a robot. I just give you a better channel to solve the problem. You have misunderstood, this is my fault, I apologize to you, your question is just a case, we hope to expose to the public and discuss the common issues.


Thanks for the link and sorry for being cynical :slight_smile:

1 Like

No, my approach is indeed a bit reckless, you can continue to contact me in the form of a message.

Why hide a topic that may help others? Plus the community support helps pimax often resolving issues where possible.

1 Like

I want to hide uncommon problems and transfer them to technical support, because I think it’s more suitable for users to handle personal problems one-on-one by technical support, because they know about usb problems. Do you think it’s okay?

It’s not that uncommon of an issue. @chuan_l even posted usb tool recommended by Valve for debugging usb issues. Rgb lighting motherboard software has been identified as well.

Recommending filing a ticket is apart of the process recommended. By hiding the topic if another user experiences the same issue and the op has posted the cause and solution derived from pimax tech or community.

Saves time for other pimax users and also helps the tech support team workload.

Hopefully soon can re enable more of the forum features like Best solution.

1 Like